aboutsummaryrefslogtreecommitdiff
path: root/misc/getopt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/getopt/Makefile')
-rw-r--r--misc/getopt/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
new file mode 100644
index 000000000000..d8abc6c0018e
--- /dev/null
+++ b/misc/getopt/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: getopt
+# Date created: 2003-06-05
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= getopt
+PORTVERSION= 1.1.3
+CATEGORIES= misc
+MASTER_SITES= http://huizen.dds.nl/~frodol/
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= A getopt(1) replacement that supports GNU-style long options
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+USE_GETOPT_LONG= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
+MAKE_ENV= LIBCGETOPT=0 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= getopt.1
+DOCS= Changelog README
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>