aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellm-xkb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gkrellm-xkb/Makefile')
-rw-r--r--misc/gkrellm-xkb/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/gkrellm-xkb/Makefile b/misc/gkrellm-xkb/Makefile
index 0034d1efa6d9..b00a46222313 100644
--- a/misc/gkrellm-xkb/Makefile
+++ b/misc/gkrellm-xkb/Makefile
@@ -15,8 +15,14 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/xkb.so
-MAKE_ENV= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
+MAKE_ENV= PLUGIN_DIR=${PLUGINDIR}
ALL_TARGET= xkb.so
+PLUGINDIR= ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+
+post-patch:
+ @${REINPLACE_CMD} '/$$(CC)/ s|FLAGS|CFLAGS|' ${WRKSRC}/Makefile
+
+pre-install:
+ @${MKDIR} ${PLUGINDIR}
-NO_STAGE= yes
.include <bsd.port.mk>