aboutsummaryrefslogtreecommitdiff
path: root/misc/gnome-mime-data/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gnome-mime-data/Makefile')
-rw-r--r--misc/gnome-mime-data/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/misc/gnome-mime-data/Makefile b/misc/gnome-mime-data/Makefile
index d846951d17f6..9835c797bdc2 100644
--- a/misc/gnome-mime-data/Makefile
+++ b/misc/gnome-mime-data/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnome-mime-data
-PORTVERSION= 2.4.3
+PORTVERSION= 2.18.0
CATEGORIES= misc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-mime-data/2.4
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-mime-data-${PORTVERSION}
DIST_SUBDIR= gnome
@@ -24,4 +24,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>