aboutsummaryrefslogtreecommitdiff
path: root/misc/gregexp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gregexp/Makefile')
-rw-r--r--misc/gregexp/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/misc/gregexp/Makefile b/misc/gregexp/Makefile
new file mode 100644
index 000000000000..c35f88b3783b
--- /dev/null
+++ b/misc/gregexp/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: gregexp
+# Date created: May 4, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gregexp
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://dentrassi.de/download/gregexp/${PORTVERSION}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A graphical regular expression explorer
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20 gnomeprefix
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>