aboutsummaryrefslogtreecommitdiff
path: root/misc/hello/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/hello/Makefile')
-rw-r--r--misc/hello/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index 707985db1482..afc1f68a3dba 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -15,11 +15,18 @@ MASTER_SITE_SUBDIR= hello
MAINTAINER= shipley@dis.org
COMMENT= A utility for saying hello to the world and reading email
-USE_GETTEXT= YES
USE_PERL5_BUILD= YES
GNU_CONFIGURE= YES
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= hello.1
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.include <bsd.port.mk>