aboutsummaryrefslogtreecommitdiff
path: root/misc/inplace/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/inplace/Makefile')
-rw-r--r--misc/inplace/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/inplace/Makefile b/misc/inplace/Makefile
new file mode 100644
index 000000000000..647a32301b97
--- /dev/null
+++ b/misc/inplace/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: inplace(1)
+# Date created: 2 May 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inplace
+PORTVERSION= 1.0.1
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= knu
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A tool to edit files in-place through given filter commands
+
+USE_BZIP2= yes
+USE_RUBY= yes
+
+MAKE_ARGS= PREFIX="${PREFIX}"
+MAKEFILE= BSDmakefile
+
+MAN1= inplace.1
+MANCOMPRESSED= maybe
+PLIST_FILES= bin/inplace
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+.include <bsd.port.post.mk>