aboutsummaryrefslogtreecommitdiff
path: root/misc/kdeutils2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/kdeutils2/Makefile')
-rw-r--r--misc/kdeutils2/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/misc/kdeutils2/Makefile b/misc/kdeutils2/Makefile
index 8fed890836c1..672e5434d23e 100644
--- a/misc/kdeutils2/Makefile
+++ b/misc/kdeutils2/Makefile
@@ -1,28 +1,29 @@
-# New ports collection makefile for: kdeutils
-# Date created: 28 October 1997
-# Whom: Stefan Eßer <se@freebsd.org>
+# New ports collection makefile for: kdeutils2
+# Date created: Sun 14 May 2000 02:52:20
+# Whom: Will Andrews <will@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= kdeutils
-PORTVERSION= 1.1.2
+PORTVERSION= 1.90
CATEGORIES= misc kde
MASTER_SITES= $(MASTER_SITE_KDE)
-MASTER_SITE_SUBDIR= stable/1.1.2/distribution/tar/generic/source/bz2
+MASTER_SITE_SUBDIR= unstable/distribution/tar/src
-MAINTAINER= se@freebsd.org
+MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- kdecore.3:${PORTSDIR}/x11/kdelibs11
+ kdecore.4:${PORTSDIR}/x11/kdelibs2
+MOC?= ${X11BASE}/bin/moc2
USE_BZIP2= yes
-USE_QT= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
- "--with-extra-includes=$(PREFIX)/include"
-CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
- INSTALL_SCRIPT="install -c -m 555"
+USE_QT2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib
+CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
.include <bsd.port.mk>