aboutsummaryrefslogtreecommitdiff
path: root/misc/ldconfig_compat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/ldconfig_compat/Makefile')
-rw-r--r--misc/ldconfig_compat/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/misc/ldconfig_compat/Makefile b/misc/ldconfig_compat/Makefile
new file mode 100644
index 000000000000..b3d75aee009d
--- /dev/null
+++ b/misc/ldconfig_compat/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ldconfig_compat
+# Date created: 30 Dec 2005
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldconfig_compat
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Ldconfig compatibility script
+
+NO_BUILD= yes
+SUB_FILES= ldconfig_compat.sh
+USE_RC_SUBR= yes
+
+LOCAL_DIRS= ${LDCONFIG_DIR} \
+ ${LDCONFIG32_DIR}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/bsd.ldconfig.mk"
+
+.if ${OSVERSION} >= 700012
+IGNORE= isn't needed (part of base rc.d)
+.endif
+
+do-fetch:
+ @${DO_NADA}
+
+do-install:
+.if ${OSVERSION} >= 600101
+ @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh ${PREFIX}/etc/rc.d/ldconfig_compat
+ @${ECHO_CMD} "etc/rc.d/ldconfig_compat" >> ${TMPPLIST}
+.elif ${OSVERSION} >= 500037
+ @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh /etc/rc.d/ldconfig_compat
+ @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
+ @${ECHO_CMD} "etc/rc.d/ldconfig_compat" >> ${TMPPLIST}
+.else
+ @${INSTALL_SCRIPT} ${WRKDIR}/ldconfig_compat.sh ${PREFIX}/etc/rc.d/000.ldconfig_compat.sh
+ @${ECHO_CMD} "etc/rc.d/000.ldconfig_compat.sh" >> ${TMPPLIST}
+.endif
+.for prefix in ${PREFIX} ${X11BASE}
+ @${ECHO_CMD} "@cwd ${prefix}" >> ${TMPPLIST}
+.for dir in ${LOCAL_DIRS}
+ @${MKDIR} ${prefix}/${dir}
+ @${ECHO_CMD} "@dirrm ${dir}" >> ${TMPPLIST}
+.endfor
+.endfor
+
+.include <bsd.port.post.mk>