aboutsummaryrefslogtreecommitdiff
path: root/misc/openhmd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/openhmd/Makefile')
-rw-r--r--misc/openhmd/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/misc/openhmd/Makefile b/misc/openhmd/Makefile
new file mode 100644
index 000000000000..5fd07f75121b
--- /dev/null
+++ b/misc/openhmd/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= OpenHMD
+DISTVERSION= 0.2.0-215
+DISTVERSIONSUFFIX= -g6f91c10
+CATEGORIES= misc
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= API and drivers for immersive technology
+
+LICENSE= BSL
+xLICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libhidapi.so:comms/hidapi
+
+USES= cmake:outsource
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/openhmd.h \
+ lib/libopenhmd.so \
+ lib/libopenhmd.so.0 \
+ lib/libopenhmd.so.0.1.0
+
+.include <bsd.port.mk>