aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Geo-Coder-Bing
diff options
context:
space:
mode:
Diffstat (limited to 'misc/p5-Geo-Coder-Bing')
-rw-r--r--misc/p5-Geo-Coder-Bing/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/misc/p5-Geo-Coder-Bing/Makefile b/misc/p5-Geo-Coder-Bing/Makefile
index 1b93fd7b2885..5e030a347aa8 100644
--- a/misc/p5-Geo-Coder-Bing/Makefile
+++ b/misc/p5-Geo-Coder-Bing/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Coder-Bing
-# Date created: 2011-10-13
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Geo-Coder-Bing
PORTVERSION= 0.11
@@ -14,25 +10,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Geocode addresses with the Bing Maps API
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
p5-LWP-Protocol-https>=6.02:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
- p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
- p5-LWP-Protocol-https>=6.02:${PORTSDIR}/www/p5-LWP-Protocol-https \
- p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
- p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Geo::Coder::Bing.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>