aboutsummaryrefslogtreecommitdiff
path: root/misc/posixtestsuite
diff options
context:
space:
mode:
Diffstat (limited to 'misc/posixtestsuite')
-rw-r--r--misc/posixtestsuite/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
index c2d59145ca23..1a15a57ffbb5 100644
--- a/misc/posixtestsuite/Makefile
+++ b/misc/posixtestsuite/Makefile
@@ -31,9 +31,9 @@ THEPIPE= | tee 2>&1
.endif
.if defined(WITH_THRLIB)
-THRLIB=${WITH_THRLIB}
+THRLIB= ${WITH_THRLIB}
.else
-THRLIB= ${PTHREAD_LIBS}
+THRLIB= -lpthread
.endif
pre-everything::
@@ -48,7 +48,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " * QUIET - don't print progress messages while running"
@${ECHO} " * WITH_THRLIB - choose thread library to run test against"
- @${ECHO} " (NB: by default '"${PTHREAD_LIBS}"' is used)"
+ @${ECHO} " (NB: by default '"-lpthread"' is used)"
@${ECHO} ""
@${ECHO} "Examples:"
@${ECHO} ""