aboutsummaryrefslogtreecommitdiff
path: root/misc/py-qt4-demo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/py-qt4-demo/Makefile')
-rw-r--r--misc/py-qt4-demo/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 1723acb83421..382633f67bb8 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= demo
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.3
+PORTREVISION= # zero
CATEGORIES= misc devel python
MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
http://freebsd.ricin.com/ports/distfiles/
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME= PyQt-x11-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
-COMMENT= Python bindings for the Qt4 toolkit, demo and examples
+COMMENT= Python bindings for the Qt4 toolkit, demo and other examples
USE_PYTHON= yes
@@ -32,12 +32,12 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtCore.so:${PORTSDIR}/devel/py-qt4-core
${PYTHON_SITELIBDIR}/PyQt4/QtXml.so:${PORTSDIR}/textproc/py-qt4-xml \
${PYTHON_SITELIBDIR}/PyQt4/QtAssistant.so:${PORTSDIR}/devel/py-qt4-assistant \
${PYTHON_SITELIBDIR}/PyQt4/QtOpenGL.so:${PORTSDIR}/x11/py-qt4-opengl \
- ${PYTHON_SITELIBDIR}/PyQt4/Qsci.so:${PORTSDIR}/devel/py-qt4-qscintilla2 \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtScript.so:${PORTSDIR}/devel/py-qt4-script \
${PYTHON_SITELIBDIR}/PyQt4/QtSql.so:${PORTSDIR}/databases/py-qt4-sql \
${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:${PORTSDIR}/graphics/py-qt4-svg \
${PYTHON_SITELIBDIR}/PyQt4/QtTest.so:${PORTSDIR}/devel/py-qt4-test \
${PYTHON_SITELIBDIR}/PyQt4/QtDesigner.so:${PORTSDIR}/devel/py-qt4-designer \
- ${LOCALBASE}/lib/plugins/designer/libpythonplugin.so:${PORTSDIR}/devel/py-qt4-designerplugin \
+ ${LOCALBASE}/lib/qt4/plugins/designer/libpythonplugin.so:${PORTSDIR}/devel/py-qt4-designerplugin \
${PYTHON_SITELIBDIR}/dbus/mainloop/qt.so:${PORTSDIR}/devel/py-qt4-dbus
.if !defined(NOPORTDOCS)
RUN_DEPENDS+= ${LOCALBASE}/share/doc/py-qt4/pyqt4ref.html:${PORTSDIR}/misc/py-qt4-doc
@@ -45,13 +45,20 @@ RUN_DEPENDS+= ${LOCALBASE}/share/doc/py-qt4/pyqt4ref.html:${PORTSDIR}/misc/py-qt
.endif
do-build:
- ( cd ${WRKSRC}/examples && \
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py \
- `ls */*.py */*/*.py */*/*/*.py` )
+.if !defined(NOPORTEXAMPLES)
+ cd ${WRKSRC}/examples &&\
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py\
+ `ls */*.py */*/*.py */*/*/*.py`
+.endif
do-install:
- ( cd ${WRKSRC} && \
- ${MKDIR} -m 0755 ${EXAMPLESDIR} && \
- ${CP} -R examples/ ${EXAMPLESDIR} )
+.if !defined(NOPORTEXAMPLES)
+ cd ${WRKSRC} &&\
+ ${RM} -f examples/designer/plugins/plugins.py.orig &&\
+ ${MKDIR} ${EXAMPLESDIR} &&\
+ ${CP} -R examples/ ${EXAMPLESDIR}
+.else
+ @${ECHO} "NOPORTEXAMPLES is set -- installing nothing."
+.endif
.include <bsd.port.post.mk>