aboutsummaryrefslogtreecommitdiff
path: root/misc/py-qt4-demo
diff options
context:
space:
mode:
Diffstat (limited to 'misc/py-qt4-demo')
-rw-r--r--misc/py-qt4-demo/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 8766fad650b7..f7834161dd6f 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -15,15 +15,15 @@ COMMENT= Python bindings for the Qt4 toolkit, Qt demo and examples
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
-USES= python
+USES= python pyqt:4
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
-
-.for component in ${PYQT4_COMPONENTS:Ndemo}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-${component}>=0:${PORTSDIR}/${${component}_PORT}
-.endfor
+USE_PYQT= assistant_run core_run dbus_run dbussupport_run declarative_run \
+ designer_run designerplugin_run doc_run gui_run help_run \
+ multimedia_run network_run opengl_run phonon_run qscintilla2_run \
+ script_run scripttools_run sql_run svg_run test_run webkit_run xml_run \
+ xmlpatterns_run sip_run qscintilla2_run
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/examples