aboutsummaryrefslogtreecommitdiff
path: root/misc/shc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/shc/Makefile')
-rw-r--r--misc/shc/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/misc/shc/Makefile b/misc/shc/Makefile
index 9664a0675704..55dc2a77fad4 100644
--- a/misc/shc/Makefile
+++ b/misc/shc/Makefile
@@ -1,28 +1,30 @@
-# ex:ts=8
# Ports collection makefile for: shc
-# Date created: Feb 14, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+# Date created: Feb 14, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= shc
-PORTVERSION= 3.8.7
+PORTVERSION= 3.8.9
CATEGORIES= misc
MASTER_SITES= http://www.datsi.fi.upm.es/~frosal/sources/ \
CRITICAL
EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= A shell script "encoder"
+COMMENT= A generic script compiler
MAKE_JOBS_SAFE= yes
MAN1= shc.1
PLIST_FILES= bin/shc
+post-extract:
+ @${RM} ${WRKSRC}/shc
+
do-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/shc ${WRKSRC}/shc.c
+ ${CC} ${CFLAGS} -o ${WRKSRC}/shc ${WRKSRC}/${PORTNAME}-${PORTVERSION}.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/shc ${PREFIX}/bin