aboutsummaryrefslogtreecommitdiff
path: root/misc/sshbuddy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/sshbuddy/Makefile')
-rw-r--r--misc/sshbuddy/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/misc/sshbuddy/Makefile b/misc/sshbuddy/Makefile
index 7e4968b2b7e1..19941c4c91ca 100644
--- a/misc/sshbuddy/Makefile
+++ b/misc/sshbuddy/Makefile
@@ -10,19 +10,17 @@ MASTER_SITES= http://linuxmafia.com/pub/linux/security/sshbuddy/
MAINTAINER= wrighrc@gmail.com
COMMENT= Simple and small GUI utility to manage ssh sessions
-RUN_DEPENDS= expectk:${PORTSDIR}/lang/expect
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
-USES= shebangfix
-USE_XORG= x11
-SHEBANG_FILES= ${WRKSRC}/sshbuddy.expk
-SHEBANG_LANG= expectk
-expectk_OLD_CMD= /usr/bin/expectk
-expectk_CMD= ${LOCALBASE}/bin/expectk
+USES= tk
NO_BUILD= yes
PLIST_FILES= bin/sshbuddy
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|' ${WRKSRC}/sshbuddy.expk
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
+ ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
.include <bsd.port.mk>