aboutsummaryrefslogtreecommitdiff
path: root/misc/survex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/survex/Makefile')
-rw-r--r--misc/survex/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/survex/Makefile b/misc/survex/Makefile
new file mode 100644
index 000000000000..9b59d7ba7076
--- /dev/null
+++ b/misc/survex/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= survex
+DISTVERSION= 1.2.36
+CATEGORIES= misc
+MASTER_SITES= https://survex.com/software/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cave survey software
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+ libproj.so:graphics/proj
+
+USES= desktop-file-utils gmake pkgconfig shared-mime-info
+GNU_CONFIGURE= yes
+USE_WX= 3.0
+USE_XORG= xxf86vm
+USE_GL= gl glu
+INSTALLS_ICONS= yes # because wxWidgets-3.0 is gtk/gnome based
+
+MAKE_ENV= WX_CONFIG=${WX_CONFIG}
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>