aboutsummaryrefslogtreecommitdiff
path: root/misc/sword/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/sword/Makefile')
-rw-r--r--misc/sword/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 5445ed44521c..066d529cefd4 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= sword
-PORTVERSION= 1.5.9
-PORTREVISION= 3
+PORTVERSION= 1.5.10
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.5/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= bibletime
+ http://crosswire.org/ftpmirror/pub/sword/source/v1.5/ \
+ LOCAL
+MASTER_SITE_SUBDIR= tabthorpe
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= A project framework for manipulating Bible texts
@@ -19,13 +19,19 @@ COMMENT= A project framework for manipulating Bible texts
USE_GNOME= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:19
+USE_AUTOTOOLS= automake:110
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --without-conf --without-lucene
+CONFIGURE_ARGS+= --without-conf --without-clucene --with-zlib
USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 800000
+BROKEN= Does not compile under 8.X
+.endif
+
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --without-curl
PLIST_SUB+= INSTALLMGR="@comment "
@@ -56,4 +62,4 @@ post-install:
register:
@(cd ${WRKSRC} && ${GMAKE} register)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>