aboutsummaryrefslogtreecommitdiff
path: root/misc/sword15
diff options
context:
space:
mode:
Diffstat (limited to 'misc/sword15')
-rw-r--r--misc/sword15/Makefile58
-rw-r--r--misc/sword15/distinfo3
-rw-r--r--misc/sword15/files/patch-configure13
-rw-r--r--misc/sword15/files/patch-configure.ac13
-rw-r--r--misc/sword15/files/patch-include::ftpparse.h19
-rw-r--r--misc/sword15/files/patch-src::utilfuns::ftpparse.c10
-rw-r--r--misc/sword15/files/pkg-message.in16
-rw-r--r--misc/sword15/pkg-descr8
-rw-r--r--misc/sword15/pkg-plist232
9 files changed, 0 insertions, 372 deletions
diff --git a/misc/sword15/Makefile b/misc/sword15/Makefile
deleted file mode 100644
index b84a69ff6144..000000000000
--- a/misc/sword15/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: sword
-# Date created: 22 may 2001
-# Whom: Willem van Engen <wvengen@stack.nl>
-#
-# $FreeBSD$
-#
-
-PORTNAME= sword
-PORTVERSION= 1.5.9
-PORTREVISION= 2
-CATEGORIES= misc
-MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.5/ \
- http://www.goodking.ca/pub/files/
-
-MAINTAINER= thomas@goodking.ca
-COMMENT= A project framework for manipulating Bible texts
-
-USE_GNOME= pkgconfig
-USE_GMAKE= yes
-USE_GCC= 3.4+
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --without-conf --without-clucene
-USE_LDCONFIG= yes
-SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.if defined(WITHOUT_CURL)
-CONFIGURE_ARGS+= --without-curl
-PLIST_SUB+= INSTALLMGR="@comment "
-.else
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-curl
-PLIST_SUB+= INSTALLMGR=""
-
-pre-everything::
- @${ECHO_CMD} "Define WITHOUT_CURL to disable remote fetch (curl) support in the installmanager"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
-
-post-install:
- @${MKDIR} ${PREFIX}/share/sword/mods.d
-.if !exists(${PREFIX}/etc/sword.conf)
- @(cd ${WRKSRC} && make install_config)
-.else
- @${ECHO_CMD} "Config file not installed since ${PREFIX}/etc/sword.conf already exists."
- @${ECHO_CMD} "Please check that DataPath points to your modules (default ${DATADIR}).";
-.endif
- @${ECHO_CMD} ""
- @${CAT} ${PKGMESSAGE}
-
-register:
- @(cd ${WRKSRC} && make register)
-
-.include <bsd.port.mk>
diff --git a/misc/sword15/distinfo b/misc/sword15/distinfo
deleted file mode 100644
index addda689560f..000000000000
--- a/misc/sword15/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sword-1.5.9.tar.gz) = e1f1af8c2add8310d0bbcddc9af523b8
-SHA256 (sword-1.5.9.tar.gz) = dd170431235cc419cbe6c40362640927a78dc93e082623709abe1310fe804481
-SIZE (sword-1.5.9.tar.gz) = 1816315
diff --git a/misc/sword15/files/patch-configure b/misc/sword15/files/patch-configure
deleted file mode 100644
index 8ff7c16b76b2..000000000000
--- a/misc/sword15/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Sun May 29 00:59:43 2005
-+++ configure Mon Jul 10 14:10:06 2006
-@@ -20481,8 +20481,8 @@
- echo "curl found - remote install options available"
- CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
- CURL_LIBS=`$CURL_CONFIG --libs`
-- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
-- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
-+ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
-+ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
- fi
- fi
-
diff --git a/misc/sword15/files/patch-configure.ac b/misc/sword15/files/patch-configure.ac
deleted file mode 100644
index f461d8952bcf..000000000000
--- a/misc/sword15/files/patch-configure.ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac.orig Mon Jul 10 18:22:50 2006
-+++ configure.ac Mon Jul 10 18:23:13 2006
-@@ -187,8 +187,8 @@
- echo "curl found - remote install options available"
- CURL_AM_CFLAGS=`$CURL_CONFIG --cflags`
- CURL_LIBS=`$CURL_CONFIG --libs`
-- AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE"
-- AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE"
-+ AM_CXXFLAGS="$AM_CXXFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
-+ AM_CFLAGS="$AM_CFLAGS -DCURLAVAILABLE $CURL_AM_CFLAGS"
- fi
- fi
-
diff --git a/misc/sword15/files/patch-include::ftpparse.h b/misc/sword15/files/patch-include::ftpparse.h
deleted file mode 100644
index e135d22a25e8..000000000000
--- a/misc/sword15/files/patch-include::ftpparse.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- include/ftpparse.h.orig Tue Aug 17 10:49:11 2004
-+++ include/ftpparse.h Tue Aug 17 10:49:24 2004
-@@ -1,7 +1,6 @@
- #ifndef FTPPARSE_H
- #define FTPPARSE_H
-
--#include <time.h>
-
- /*
- ftpparse(&fp,buf,len) tries to parse one line of LIST output.
-@@ -25,7 +24,7 @@
- int sizetype;
- long size; /* number of octets */
- int mtimetype;
-- time_t mtime; /* modification time */
-+ long mtime; /* modification time */
- int idtype;
- char *id; /* not necessarily 0-terminated */
- int idlen;
diff --git a/misc/sword15/files/patch-src::utilfuns::ftpparse.c b/misc/sword15/files/patch-src::utilfuns::ftpparse.c
deleted file mode 100644
index ab8a3eab8e85..000000000000
--- a/misc/sword15/files/patch-src::utilfuns::ftpparse.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/utilfuns/ftpparse.c.orig Thu Feb 19 23:22:11 2004
-+++ src/utilfuns/ftpparse.c Thu Feb 19 23:22:19 2004
-@@ -21,6 +21,7 @@
- NCSA Telnet FTP server. Has LIST = NLST (and bad NLST for directories).
- */
-
-+#include <time.h>
- #include <ftpparse.h>
-
- static long totai(long year,long month,long mday)
diff --git a/misc/sword15/files/pkg-message.in b/misc/sword15/files/pkg-message.in
deleted file mode 100644
index db3c756d6416..000000000000
--- a/misc/sword15/files/pkg-message.in
+++ /dev/null
@@ -1,16 +0,0 @@
-To use sword, you need to have bible, commentary and/or lexicon
-modules. You can install those from the crosswire website in two
-ways. If you live in a persecuted country however and do not wish
-to risk detection, you should *not* try this.
-
- 1. Use installmgr (doesn't work when port is built WITHOUT_CURL). E.g.:
- # installmgr -init
- # installmgr -r crosswire
- # installmgr -ri crosswire ASV
- See `installmgr --help` for details.
- 2. Download raw zip-archives from
- http://www.crosswire.org/sword/modules/
- and unpack them in %%PREFIX%%/share/sword.
-
-You probably want to install a bible-application that uses sword,
-like bibletime or gnomesword.
diff --git a/misc/sword15/pkg-descr b/misc/sword15/pkg-descr
deleted file mode 100644
index c87f98fae37a..000000000000
--- a/misc/sword15/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-The SWORD Project is an effort to create an ever expanding software
-package for research and study of God and His Word. The SWORD Bible
-Framework allows easy manipulation of Bible texts, commentaries,
-lexicons, dictionaries, etc. Many frontends are built using this
-framework. An installed module set may be shared between many
-frontends using the framework.
-
-WWW: http://www.crosswire.org/sword/
diff --git a/misc/sword15/pkg-plist b/misc/sword15/pkg-plist
deleted file mode 100644
index 3234e4fbd15d..000000000000
--- a/misc/sword15/pkg-plist
+++ /dev/null
@@ -1,232 +0,0 @@
-bin/addld
-bin/diatheke
-bin/imp2gbs
-bin/imp2ld
-bin/imp2vs
-bin/installmgr
-bin/mkfastmod
-bin/mod2imp
-bin/mod2osis
-bin/mod2vpl
-bin/mod2zmod
-bin/osis2mod
-bin/vpl2mod
-bin/vs2osisref
-bin/xml2gbs
-etc/sword.conf
-include/sword/Greek2Greek.h
-include/sword/GreekChars.h
-include/sword/canon.h
-include/sword/cipherfil.h
-include/sword/curlftpt.h
-include/sword/defs.h
-include/sword/echomod.h
-include/sword/encfiltmgr.h
-include/sword/entriesblk.h
-include/sword/femain.h
-include/sword/filemgr.h
-include/sword/flatapi.h
-include/sword/ftplib.h
-include/sword/ftplibftpt.h
-include/sword/ftpparse.h
-include/sword/ftptrans.h
-include/sword/gbffootnotes.h
-include/sword/gbfheadings.h
-include/sword/gbfhtml.h
-include/sword/gbfhtmlhref.h
-include/sword/gbfmorph.h
-include/sword/gbfosis.h
-include/sword/gbfplain.h
-include/sword/gbfredletterwords.h
-include/sword/gbfrtf.h
-include/sword/gbfstrongs.h
-include/sword/gbfthml.h
-include/sword/gbfwebif.h
-include/sword/gbfwordjs.h
-include/sword/greeklexattribs.h
-include/sword/hebrewmcim.h
-include/sword/hrefcom.h
-include/sword/installmgr.h
-include/sword/latin1utf16.h
-include/sword/latin1utf8.h
-include/sword/listkey.h
-include/sword/localemgr.h
-include/sword/lzsscomprs.h
-include/sword/markupfiltmgr.h
-include/sword/multimapwdef.h
-include/sword/nullim.h
-include/sword/osisfootnotes.h
-include/sword/osisheadings.h
-include/sword/osishtmlhref.h
-include/sword/osislemma.h
-include/sword/osismorph.h
-include/sword/osismorphsegmentation.h
-include/sword/osisosis.h
-include/sword/osisplain.h
-include/sword/osisredletterwords.h
-include/sword/osisrtf.h
-include/sword/osisscripref.h
-include/sword/osisstrongs.h
-include/sword/osiswebif.h
-include/sword/osiswordjs.h
-include/sword/papyriplain.h
-include/sword/plainfootnotes.h
-include/sword/plainhtml.h
-include/sword/rawcom.h
-include/sword/rawfiles.h
-include/sword/rawgenbook.h
-include/sword/rawld.h
-include/sword/rawld4.h
-include/sword/rawstr.h
-include/sword/rawstr4.h
-include/sword/rawtext.h
-include/sword/rawverse.h
-include/sword/regex.h
-include/sword/roman.h
-include/sword/rtfhtml.h
-include/sword/sapphire.h
-include/sword/scsuutf8.h
-include/sword/stringmgr.h
-include/sword/strkey.h
-include/sword/swbasicfilter.h
-include/sword/swbuf.h
-include/sword/swcacher.h
-include/sword/swcipher.h
-include/sword/swcom.h
-include/sword/swcomprs.h
-include/sword/swconfig.h
-include/sword/swdisp.h
-include/sword/swfilter.h
-include/sword/swfiltermgr.h
-include/sword/swgenbook.h
-include/sword/swinputmeth.h
-include/sword/swkey.h
-include/sword/swld.h
-include/sword/swlocale.h
-include/sword/swlog.h
-include/sword/swmacs.h
-include/sword/swmgr.h
-include/sword/swmodule.h
-include/sword/swobject.h
-include/sword/swoptfilter.h
-include/sword/swsearchable.h
-include/sword/swtext.h
-include/sword/swunicod.h
-include/sword/swversion.h
-include/sword/sysdata.h
-include/sword/teiplain.h
-include/sword/teirtf.h
-include/sword/thmlfootnotes.h
-include/sword/thmlgbf.h
-include/sword/thmlheadings.h
-include/sword/thmlhtml.h
-include/sword/thmlhtmlhref.h
-include/sword/thmllemma.h
-include/sword/thmlmorph.h
-include/sword/thmlosis.h
-include/sword/thmlplain.h
-include/sword/thmlrtf.h
-include/sword/thmlscripref.h
-include/sword/thmlstrongs.h
-include/sword/thmlvariants.h
-include/sword/thmlwebif.h
-include/sword/thmlwordjs.h
-include/sword/treekey.h
-include/sword/treekeyidx.h
-include/sword/unicodertf.h
-include/sword/untgz.h
-include/sword/url.h
-include/sword/utf16utf8.h
-include/sword/utf8arshaping.h
-include/sword/utf8bidireorder.h
-include/sword/utf8cantillation.h
-include/sword/utf8greekaccents.h
-include/sword/utf8hebrewpoints.h
-include/sword/utf8html.h
-include/sword/utf8latin1.h
-include/sword/utf8nfc.h
-include/sword/utf8nfkd.h
-include/sword/utf8transliterator.h
-include/sword/utf8utf16.h
-include/sword/utilstr.h
-include/sword/utilxml.h
-include/sword/versekey.h
-include/sword/versetreekey.h
-include/sword/zcom.h
-include/sword/zconf.h
-include/sword/zipcomprs.h
-include/sword/zld.h
-include/sword/zlib.h
-include/sword/zstr.h
-include/sword/ztext.h
-include/sword/zverse.h
-lib/libsword-1.5.9.so
-lib/libsword.a
-lib/libsword.la
-lib/libsword.so
-libdata/pkgconfig/sword.pc
-%%DATADIR%%/locales.d/abbr.conf
-%%DATADIR%%/locales.d/af-utf8.conf
-%%DATADIR%%/locales.d/af.conf
-%%DATADIR%%/locales.d/ar_EG-cp1256.conf
-%%DATADIR%%/locales.d/ar_EG-utf8.conf
-%%DATADIR%%/locales.d/bg_BG-cp1251.conf
-%%DATADIR%%/locales.d/bg_BG-utf8.conf
-%%DATADIR%%/locales.d/cs-utf8.conf
-%%DATADIR%%/locales.d/cs.conf
-%%DATADIR%%/locales.d/da-utf8.conf
-%%DATADIR%%/locales.d/da.conf
-%%DATADIR%%/locales.d/de-utf8.conf
-%%DATADIR%%/locales.d/de.conf
-%%DATADIR%%/locales.d/de_abbrev-utf8.conf
-%%DATADIR%%/locales.d/de_abbrev.conf
-%%DATADIR%%/locales.d/en_GB.conf
-%%DATADIR%%/locales.d/es-utf8.conf
-%%DATADIR%%/locales.d/es.conf
-%%DATADIR%%/locales.d/et-utf8.conf
-%%DATADIR%%/locales.d/et.conf
-%%DATADIR%%/locales.d/et_abbr-utf8.conf
-%%DATADIR%%/locales.d/et_abbr.conf
-%%DATADIR%%/locales.d/fi-utf8.conf
-%%DATADIR%%/locales.d/fi.conf
-%%DATADIR%%/locales.d/fr-utf8.conf
-%%DATADIR%%/locales.d/fr.conf
-%%DATADIR%%/locales.d/he-utf8.conf
-%%DATADIR%%/locales.d/hu-utf8.conf
-%%DATADIR%%/locales.d/hu.conf
-%%DATADIR%%/locales.d/id.conf
-%%DATADIR%%/locales.d/it-utf8.conf
-%%DATADIR%%/locales.d/it.conf
-%%DATADIR%%/locales.d/ko-utf8.conf
-%%DATADIR%%/locales.d/ko.conf
-%%DATADIR%%/locales.d/ko_abbrev-utf8.conf
-%%DATADIR%%/locales.d/ko_abbrev.conf
-%%DATADIR%%/locales.d/la.conf
-%%DATADIR%%/locales.d/lt-utf8.conf
-%%DATADIR%%/locales.d/nl.conf
-%%DATADIR%%/locales.d/no-utf8.conf
-%%DATADIR%%/locales.d/no.conf
-%%DATADIR%%/locales.d/pl-utf8.conf
-%%DATADIR%%/locales.d/pl.conf
-%%DATADIR%%/locales.d/pt-utf8.conf
-%%DATADIR%%/locales.d/pt.conf
-%%DATADIR%%/locales.d/pt_BR-utf8.conf
-%%DATADIR%%/locales.d/pt_BR.conf
-%%DATADIR%%/locales.d/ro.conf
-%%DATADIR%%/locales.d/ru_RU-cp1251.conf
-%%DATADIR%%/locales.d/ru_RU-koi8-r.conf
-%%DATADIR%%/locales.d/ru_RU-utf8.conf
-%%DATADIR%%/locales.d/sk-utf8.conf
-%%DATADIR%%/locales.d/sk.conf
-%%DATADIR%%/locales.d/sl.conf
-%%DATADIR%%/locales.d/sv-utf8.conf
-%%DATADIR%%/locales.d/sv.conf
-%%DATADIR%%/locales.d/th-utf8.conf
-%%DATADIR%%/locales.d/uk_UA-cp1251.conf
-%%DATADIR%%/locales.d/uk_UA-koi8-u.conf
-%%DATADIR%%/locales.d/uk_UA-utf8.conf
-@dirrm %%DATADIR%%/mods.d
-@dirrm %%DATADIR%%/locales.d
-@dirrm %%DATADIR%%
-@dirrm lib/sword
-@dirrm include/sword