aboutsummaryrefslogtreecommitdiff
path: root/misc/trurl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/trurl/Makefile')
-rw-r--r--misc/trurl/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/misc/trurl/Makefile b/misc/trurl/Makefile
new file mode 100644
index 000000000000..132c34bac63f
--- /dev/null
+++ b/misc/trurl/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= trurl
+DISTVERSION= 0.5
+CATEGORIES= misc www
+
+MAINTAINER= otis@FreeBSD.org
+COMMENT= Command line tool for URL parsing and manipulation
+WWW= https://github.com/curl/trurl
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USE_GITHUB= yes
+GH_ACCOUNT= curl
+GH_TAGNAME= ${PORTNAME}-${DISTVERSION}
+
+MAKE_ARGS= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/trurl \
+ share/man/man1/trurl.1.gz
+
+.include <bsd.port.mk>