aboutsummaryrefslogtreecommitdiff
path: root/misc/xfce4-iconbox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xfce4-iconbox/Makefile')
-rw-r--r--misc/xfce4-iconbox/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/xfce4-iconbox/Makefile b/misc/xfce4-iconbox/Makefile
index 4600611d34c7..5e321187e820 100644
--- a/misc/xfce4-iconbox/Makefile
+++ b/misc/xfce4-iconbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-iconbox
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= misc xfce
MASTER_SITES= http://www.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://linux.imp.mx/xfce4/xfce_${PORTVERSION}/src/
@@ -16,12 +17,17 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 icon box, an alternative taskbar
BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
USE_GNOME= gtk20
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>