aboutsummaryrefslogtreecommitdiff
path: root/misc/xiphos
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xiphos')
-rw-r--r--misc/xiphos/Makefile47
-rw-r--r--misc/xiphos/distinfo2
-rw-r--r--misc/xiphos/files/patch-Makefile.in30
-rw-r--r--misc/xiphos/files/patch-src::gnome2::mod_mgr.c12
-rw-r--r--misc/xiphos/files/patch-src::gnome2::tabbed_browser.c17
-rw-r--r--misc/xiphos/pkg-descr11
-rw-r--r--misc/xiphos/pkg-plist66
7 files changed, 0 insertions, 185 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
deleted file mode 100644
index 2218f29326d8..000000000000
--- a/misc/xiphos/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: gnomesword
-# Date created: Oct 26, 2002
-# Whom: J Shoemaker <shoemaker@softhome.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomesword
-PORTVERSION= 2.1.1
-PORTREVISION= 2
-CATEGORIES= misc gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A bible interface utilizing the sword framework
-
-BROKEN= Configure fails
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
-BUILD_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
-LIB_DEPENDS= sword.4:${PORTSDIR}/misc/sword
-RUN_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
-
-USE_X_PREFIX= yes
-INSTALLS_OMF= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget gtkhtml3 intlhack
-USE_REINPLACE= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-post-patch:
- @${REINPLACE_CMD} -e 's|=share/pix|=share/gnome/pix|g ; \
- s|=share/app|=share/gnome/app|g' ${WRKSRC}/configure
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog INSTALL NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/misc/xiphos/distinfo b/misc/xiphos/distinfo
deleted file mode 100644
index 45bceac835a4..000000000000
--- a/misc/xiphos/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gnomesword-2.1.1.tar.gz) = 46b0c941e4f5780aaf8a72da87d0d045
-SIZE (gnomesword-2.1.1.tar.gz) = 1758480
diff --git a/misc/xiphos/files/patch-Makefile.in b/misc/xiphos/files/patch-Makefile.in
deleted file mode 100644
index b629c1eae92d..000000000000
--- a/misc/xiphos/files/patch-Makefile.in
+++ /dev/null
@@ -1,30 +0,0 @@
---- Makefile.in.orig Wed Jul 14 23:34:10 2004
-+++ Makefile.in Sat Aug 21 16:34:24 2004
-@@ -61,7 +61,7 @@
- install-recursive installcheck-recursive installdirs-recursive \
- pdf-recursive ps-recursive uninstall-info-recursive \
- uninstall-recursive
--am__installdirs = "$(DESTDIR)$(gnomemenudir)" "$(DESTDIR)$(gnomesworddocdir)"
-+am__installdirs = "$(DESTDIR)$(gnomemenudir)"
- gnomemenuDATA_INSTALL = $(INSTALL_DATA)
- gnomesworddocDATA_INSTALL = $(INSTALL_DATA)
- DATA = $(gnomemenu_DATA) $(gnomesworddoc_DATA)
-@@ -627,7 +627,7 @@
- all-am: Makefile $(DATA) config.h
- installdirs: installdirs-recursive
- installdirs-am:
-- for dir in "$(DESTDIR)$(gnomemenudir)" "$(DESTDIR)$(gnomesworddocdir)"; do \
-+ for dir in "$(DESTDIR)$(gnomemenudir)"; do \
- test -z "$$dir" || $(mkdir_p) "$$dir"; \
- done
- install: install-recursive
-@@ -674,8 +674,7 @@
-
- info-am:
-
--install-data-am: install-data-local install-gnomemenuDATA \
-- install-gnomesworddocDATA
-+install-data-am: install-data-local install-gnomemenuDATA
-
- install-exec-am:
-
diff --git a/misc/xiphos/files/patch-src::gnome2::mod_mgr.c b/misc/xiphos/files/patch-src::gnome2::mod_mgr.c
deleted file mode 100644
index 15d85dbfb7b7..000000000000
--- a/misc/xiphos/files/patch-src::gnome2::mod_mgr.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/gnome2/mod_mgr.c.orig Sun Mar 28 04:39:23 2004
-+++ src/gnome2/mod_mgr.c Sat Aug 21 15:56:12 2004
-@@ -1910,8 +1910,7 @@
-
- GtkTreeModel *model;
- GError *error = NULL;
-- GtkTooltips *tooltips;
-- tooltips = gtk_tooltips_new();
-+ GtkTooltips *tooltips = gtk_tooltips_new();
- GString *str = g_string_new(NULL);
- GtkCellRenderer *renderer;
- GtkTreeViewColumn *column;
diff --git a/misc/xiphos/files/patch-src::gnome2::tabbed_browser.c b/misc/xiphos/files/patch-src::gnome2::tabbed_browser.c
deleted file mode 100644
index 52dd1d8f7527..000000000000
--- a/misc/xiphos/files/patch-src::gnome2::tabbed_browser.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/gnome2/tabbed_browser.c.orig Thu Jun 17 04:53:24 2004
-+++ src/gnome2/tabbed_browser.c Sat Aug 21 15:59:13 2004
-@@ -664,11 +664,13 @@
- */
- void gui_close_passage_tab(gint pagenum)
- {
-+ PASSAGE_TAB_INFO *pt;
-+
- if (-1 == pagenum)
- pagenum = gtk_notebook_get_current_page(GTK_NOTEBOOK(widgets.notebook_main));
- if (1 == gtk_notebook_get_n_pages(GTK_NOTEBOOK(widgets.notebook_main)))
- return;
-- PASSAGE_TAB_INFO *pt = (PASSAGE_TAB_INFO*)g_list_nth_data(passage_list, (guint)pagenum);
-+ pt = (PASSAGE_TAB_INFO*)g_list_nth_data(passage_list, (guint)pagenum);
- passage_list = g_list_remove(passage_list, pt);
- if(pt->text_mod) g_free(pt->text_mod);
- if(pt->commentary_mod) g_free(pt->commentary_mod);
diff --git a/misc/xiphos/pkg-descr b/misc/xiphos/pkg-descr
deleted file mode 100644
index b4df0ae732f5..000000000000
--- a/misc/xiphos/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-The GnomeSword GUI is a frontend to the SWORD project.
-
-The SWORD Project is an effort to create an ever expanding software package
-for research and study of God and His Word. The SWORD Bible Framework allows
-easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
-Many frontends are build using this framework. An installed module set may be
-shared between any frontend using the framework.
-
-WWW: http://www.crosswire.org/
-
-// J Shoemaker <shoemaker@softhome.net>
diff --git a/misc/xiphos/pkg-plist b/misc/xiphos/pkg-plist
deleted file mode 100644
index 6ebb6e7655d6..000000000000
--- a/misc/xiphos/pkg-plist
+++ /dev/null
@@ -1,66 +0,0 @@
-bin/gnomesword2
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-share/gnome/applications/gnomesword.desktop
-share/gnome/help/gnomesword/C/figures/gnomesword_interface.png
-share/gnome/help/gnomesword/C/figures/gnomesword_interface_biblepane.png
-share/gnome/help/gnomesword/C/figures/gnomesword_interface_commentarypane.png
-share/gnome/help/gnomesword/C/figures/gnomesword_interface_sidepane.png
-share/gnome/help/gnomesword/C/figures/gnomesword_interface_toolbar.png
-share/gnome/help/gnomesword/C/figures/gnomesword_preferences_font_colors.png
-share/gnome/help/gnomesword/C/figures/gnomesword_preferences_general.png
-share/gnome/help/gnomesword/C/figures/gnomesword_preferences_sword_config.png
-share/gnome/help/gnomesword/C/figures/gnomesword_studypad.png
-share/gnome/help/gnomesword/C/gnomesword.xml
-share/gnome/help/gnomesword/C/legal.xml
-share/gnome/help/gnomesword/fr/figures/gnomesword_interface.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_interface_bible.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_interface_commentarypane.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_interface_shortcutbar.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_interface_toolbar.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_preferences_font_colors.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_preferences_misc_settings.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_preferences_sword_config.png
-share/gnome/help/gnomesword/fr/figures/gnomesword_studypad.png
-share/gnome/help/gnomesword/fr/gnomesword.xml
-share/gnome/help/gnomesword/fr/legal.xml
-share/gnome/omf/gnomesword/gnomesword-C.omf
-share/gnome/omf/gnomesword/gnomesword-fr.omf
-share/gnome/pixmaps/gnomesword/about.png
-share/gnome/pixmaps/gnomesword/book-bl.png
-share/gnome/pixmaps/gnomesword/book-gold.png
-share/gnome/pixmaps/gnomesword/book-green.png
-share/gnome/pixmaps/gnomesword/book-un.png
-share/gnome/pixmaps/gnomesword/dlg-bl.png
-share/gnome/pixmaps/gnomesword/dlg-un.png
-share/gnome/pixmaps/gnomesword/dock.png
-share/gnome/pixmaps/gnomesword/epiphany-bookmark-page.png
-share/gnome/pixmaps/gnomesword/epiphany-bookmarks.png
-share/gnome/pixmaps/gnomesword/epiphany-secure.png
-share/gnome/pixmaps/gnomesword/epiphany-unsecure.png
-share/gnome/pixmaps/gnomesword/gs2-48x48.png
-share/gnome/pixmaps/gnomesword/logo.png
-share/gnome/pixmaps/gnomesword/new_tab_button.png
-share/gnome/pixmaps/gnomesword/splash.png
-share/gnome/pixmaps/gnomesword/sword.png
-share/gnome/pixmaps/gnomesword/sword3.png
-share/gnome/pixmaps/gnomesword/tt.png
-share/gnome/pixmaps/gnomesword/tt.xpm
-share/locale/de/LC_MESSAGES/gnomesword.mo
-share/locale/de_DE/LC_MESSAGES/gnomesword.mo
-share/locale/en_GB/LC_MESSAGES/gnomesword.mo
-share/locale/fr_FR/LC_MESSAGES/gnomesword.mo
-share/locale/ru/LC_MESSAGES/gnomesword.mo
-share/locale/uk/LC_MESSAGES/gnomesword.mo
-@dirrm share/gnome/pixmaps/gnomesword
-@dirrm share/gnome/omf/gnomesword
-@dirrm share/gnome/help/gnomesword/fr/figures
-@dirrm share/gnome/help/gnomesword/fr
-@dirrm share/gnome/help/gnomesword/C/figures
-@dirrm share/gnome/help/gnomesword/C
-@dirrm share/gnome/help/gnomesword
-%%PORTDOCS%%@dirrm %%DOCSDIR%%