aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/compat5x/Makefile3
-rw-r--r--misc/compat7x/Makefile3
-rw-r--r--misc/compat8x/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index e8f4f55282fe..52199d717a0e 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -11,6 +11,7 @@
PORTNAME= compat5x
PORTVERSION= 5.4.0.8.1
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=amdmi3/compat5x
@@ -64,7 +65,7 @@ PLIST_SUB+= SPARC64="@comment "
.endif
do-install:
- @${MKDIR} ${TARGET_DIR}
+ @${MKDIR} -m 0755 ${TARGET_DIR}
.if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/libpthread.so.1
(cd ${TARGET_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
diff --git a/misc/compat7x/Makefile b/misc/compat7x/Makefile
index 269a6b0d237c..4349314f7c98 100644
--- a/misc/compat7x/Makefile
+++ b/misc/compat7x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= compat7x
PORTVERSION= 7.3.703000.201008
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= garga/compat
@@ -36,7 +37,7 @@ USE_LDCONFIG32= ${TARGET32_DIR}
.endif
do-install:
- @${MKDIR} ${TARGET_DIR}
+ @${MKDIR} -m 0755 ${TARGET_DIR}
(cd ${WRKSRC}/lib && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
(cd ${TARGET_DIR} && ${LN} -sf /lib/libthr.so.3 libkse.so.3)
.if ${ARCH} == amd64
diff --git a/misc/compat8x/Makefile b/misc/compat8x/Makefile
index 269a6b0d237c..4349314f7c98 100644
--- a/misc/compat8x/Makefile
+++ b/misc/compat8x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= compat7x
PORTVERSION= 7.3.703000.201008
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= garga/compat
@@ -36,7 +37,7 @@ USE_LDCONFIG32= ${TARGET32_DIR}
.endif
do-install:
- @${MKDIR} ${TARGET_DIR}
+ @${MKDIR} -m 0755 ${TARGET_DIR}
(cd ${WRKSRC}/lib && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
(cd ${TARGET_DIR} && ${LN} -sf /lib/libthr.so.3 libkse.so.3)
.if ${ARCH} == amd64