aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/goldstr/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/misc/goldstr/Makefile b/misc/goldstr/Makefile
index 2e431869f333..80c8bbd86415 100644
--- a/misc/goldstr/Makefile
+++ b/misc/goldstr/Makefile
@@ -13,12 +13,15 @@ MASTER_SITES= http://it.geocities.com/andreamolteni/prog/goldstr/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= goldstr.1
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
+.endif
+
.include <bsd.port.mk>