aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile8
-rw-r--r--misc/sword15/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index feaa3dbdfc7a..423947ad1230 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -26,6 +26,12 @@ USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} >= 700000 )
+BROKEN= does not build on 7.X
+.endif
+
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --without-curl
PLIST_SUB+= INSTALLMGR="@comment "
@@ -56,4 +62,4 @@ post-install:
register:
@(cd ${WRKSRC} && make register)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/sword15/Makefile b/misc/sword15/Makefile
index feaa3dbdfc7a..423947ad1230 100644
--- a/misc/sword15/Makefile
+++ b/misc/sword15/Makefile
@@ -26,6 +26,12 @@ USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} >= 700000 )
+BROKEN= does not build on 7.X
+.endif
+
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --without-curl
PLIST_SUB+= INSTALLMGR="@comment "
@@ -56,4 +62,4 @@ post-install:
register:
@(cd ${WRKSRC} && make register)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>