aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/dnetc/Makefile2
-rw-r--r--misc/dnetc/pkg-install6
2 files changed, 4 insertions, 4 deletions
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index f2fcb6302bb1..fb428d85c100 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -18,8 +18,6 @@ DISTFILES= dnetc${PORTVERSION:E}-freebsd-x86-elf.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Distributed.net distributed computing project client
-IGNORE= uses an unregistered uid/gid.
-
WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd-x86-elf
ONLY_FOR_ARCHS= i386
diff --git a/misc/dnetc/pkg-install b/misc/dnetc/pkg-install
index 4affdc2a568a..4c3f2c347d1f 100644
--- a/misc/dnetc/pkg-install
+++ b/misc/dnetc/pkg-install
@@ -6,9 +6,11 @@ fi
CLIENTUSER=$3
CLIENTGROUP=$4
+UID=105
+GID=$UID
if ! pw groupshow "$CLIENTGROUP" 2>/dev/null 1>&2; then
- if pw groupadd $CLIENTGROUP; then
+ if pw groupadd $CLIENTGROUP -g $GID; then
echo "=> Added group \"$CLIENTGROUP\"."
else
echo "=> Adding group \"$CLIENTGROUP\" failed..."
@@ -17,7 +19,7 @@ if ! pw groupshow "$CLIENTGROUP" 2>/dev/null 1>&2; then
fi
if ! pw usershow "$CLIENTUSER" 2>/dev/null 1>&2; then
- if pw useradd $CLIENTUSER -g $CLIENTGROUP -h - \
+ if pw useradd $CLIENTUSER -u $UID -g $CLIENTGROUP -h - \
-s "/sbin/nologin" -d "/nonexistent" \
-c "distributed.net client and proxy pseudo-user"; \
then