aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/py-kartograph/Makefile3
-rw-r--r--misc/py-python-geohash/Makefile3
-rw-r--r--misc/py-socli/Makefile3
-rw-r--r--misc/py-toil/Makefile3
-rw-r--r--misc/py-yolk/Makefile3
-rw-r--r--misc/pyobd/Makefile3
6 files changed, 18 insertions, 0 deletions
diff --git a/misc/py-kartograph/Makefile b/misc/py-kartograph/Makefile
index 90bc5a7e619e..993d67326365 100644
--- a/misc/py-kartograph/Makefile
+++ b/misc/py-kartograph/Makefile
@@ -10,6 +10,9 @@ COMMENT= Framework for building interactive map applications
LICENSE= MIT
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gdal>0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
diff --git a/misc/py-python-geohash/Makefile b/misc/py-python-geohash/Makefile
index d457e8a20b94..04b3c645f436 100644
--- a/misc/py-python-geohash/Makefile
+++ b/misc/py-python-geohash/Makefile
@@ -14,6 +14,9 @@ COMMENT= Fast, accurate python geohashing library
LICENSE= APACHE20 MIT BSD3CLAUSE
LICENSE_COMB= multi
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
USES= python:2.7
USE_PYTHON= autoplist distutils
diff --git a/misc/py-socli/Makefile b/misc/py-socli/Makefile
index 406a34f2da8f..1e5a6cef90af 100644
--- a/misc/py-socli/Makefile
+++ b/misc/py-socli/Makefile
@@ -12,6 +12,9 @@ COMMENT= Stack overflow command line interface
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>=0:devel/py-backports.functools_lru_cache@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}colorama>=0:devel/py-colorama@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}stackexchange>=0:devel/py-stackexchange@${PY_FLAVOR} \
diff --git a/misc/py-toil/Makefile b/misc/py-toil/Makefile
index ee3033912a97..aede62a3a3da 100644
--- a/misc/py-toil/Makefile
+++ b/misc/py-toil/Makefile
@@ -11,6 +11,9 @@ COMMENT= Pipeline management software for clusters
LICENSE= APACHE20
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}addict>0:devel/py-addict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dill>0:devel/py-dill@${PY_FLAVOR} \
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index ffe66e08540c..e40dcf9b30b3 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -13,6 +13,9 @@ COMMENT= Command-line tool for querying PyPI and Python packages installed
LICENSE= BSD3CLAUSE
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
USES= python:2.7
USE_PYTHON= distutils autoplist
diff --git a/misc/pyobd/Makefile b/misc/pyobd/Makefile
index 23e43318831f..d200a51f2784 100644
--- a/misc/pyobd/Makefile
+++ b/misc/pyobd/Makefile
@@ -13,6 +13,9 @@ COMMENT= OBD-II compliant car diagnostic tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-08-15
+
BUILD_DEPENDS= convert:graphics/ImageMagick6
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${PY_FLAVOR}