aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/tuxcards/Makefile32
-rw-r--r--misc/tuxcards/distinfo1
-rw-r--r--misc/tuxcards/pkg-comment1
-rw-r--r--misc/tuxcards/pkg-descr15
-rw-r--r--misc/tuxcards/pkg-plist9
6 files changed, 59 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d2d4a1e5bb12..e9a05f5f2867 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -207,6 +207,7 @@
SUBDIR += tkregexp
SUBDIR += tkrunit
SUBDIR += ttyrec
+ SUBDIR += tuxcards
SUBDIR += tvguide
SUBDIR += txt2regex
SUBDIR += uf-view
diff --git a/misc/tuxcards/Makefile b/misc/tuxcards/Makefile
new file mode 100644
index 000000000000..15d429298230
--- /dev/null
+++ b/misc/tuxcards/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tuxcards
+# Date created: 08 Jan 2002
+# Whom: Tilman linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxcards
+PORTVERSION= 0.8
+CATEGORIES= misc kde
+MASTER_SITES= http://tuxcards.de/src/ \
+ http://www.arved.de/bsd/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= freebsdports@arved.de
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+USE_QT_VER= 2
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+pre-patch:
+ @${PERL} -pi -e 's|\$$\(prefix\)/doc|\$$\(prefix\)/share/doc|' \
+ ${WRKSRC}/tuxcards/docs/en/Makefile.in
+ @${PERL} -pi -e 's|-O2||' ${WRKSRC}/configure
+.ifdef(NOPORTDOCS)
+ @${PERL} -pi -e 's|install-data-am\: install-data-local||' \
+ ${WRKSRC}/tuxcards/docs/en/Makefile.in
+.endif #NOPORTDOCS
+
+.include <bsd.port.mk>
diff --git a/misc/tuxcards/distinfo b/misc/tuxcards/distinfo
new file mode 100644
index 000000000000..17ebf69840ec
--- /dev/null
+++ b/misc/tuxcards/distinfo
@@ -0,0 +1 @@
+MD5 (tuxcards-0.8-1.tar.gz) = ad26609b566e4b16dc3ec5159f56fa19
diff --git a/misc/tuxcards/pkg-comment b/misc/tuxcards/pkg-comment
new file mode 100644
index 000000000000..e5c3c051ad6d
--- /dev/null
+++ b/misc/tuxcards/pkg-comment
@@ -0,0 +1 @@
+TuxCards is a hierarchical Notebook
diff --git a/misc/tuxcards/pkg-descr b/misc/tuxcards/pkg-descr
new file mode 100644
index 000000000000..188caa5725f9
--- /dev/null
+++ b/misc/tuxcards/pkg-descr
@@ -0,0 +1,15 @@
+Unix Version of the Windowsprogram CueCards.
+
+General Idea: With TuxCards it is possible to create as many different
+entries or notes as you wish. Everytime you add a new one and you
+think your new entry belongs to the same topic as notes you already
+have, then you may decide to group them and to create a kind of
+"folder" where you store them all together. Just the same like you
+would put your books and paperwork from your job together in one
+place and not to the garden utilities (unless you work as a gardener)..
+
+With TuxCards you have a tool at your hand to enter and manage every
+kind of notes and ideas in a structured manner. This makes it much
+more easier to find them as you are in need.
+
+WWW: http://www.tuxcards.de Author: Alexander Theel
diff --git a/misc/tuxcards/pkg-plist b/misc/tuxcards/pkg-plist
new file mode 100644
index 000000000000..6ca465cf72d5
--- /dev/null
+++ b/misc/tuxcards/pkg-plist
@@ -0,0 +1,9 @@
+bin/tuxcards
+%%PORTDOCS%%share/doc/tuxcards/index-1.html
+%%PORTDOCS%%share/doc/tuxcards/index-2.html
+%%PORTDOCS%%share/doc/tuxcards/index-3.html
+%%PORTDOCS%%share/doc/tuxcards/index-4.html
+%%PORTDOCS%%share/doc/tuxcards/index-5.html
+%%PORTDOCS%%share/doc/tuxcards/index-6.html
+%%PORTDOCS%%share/doc/tuxcards/index.html
+%%PORTDOCS%%@dirrm share/doc/tuxcards