aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/floatator/Makefile27
-rw-r--r--misc/floatator/distinfo1
-rw-r--r--misc/floatator/pkg-comment1
-rw-r--r--misc/floatator/pkg-descr4
-rw-r--r--misc/floatator/pkg-plist2
6 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 060fc3e650d9..745bfb957fc4 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -71,6 +71,7 @@
SUBDIR += figlet
SUBDIR += figlet-fonts
SUBDIR += findutils
+ SUBDIR += floatator
SUBDIR += flyway
SUBDIR += fortuneit
SUBDIR += freedialog
diff --git a/misc/floatator/Makefile b/misc/floatator/Makefile
new file mode 100644
index 000000000000..b4234562ea6d
--- /dev/null
+++ b/misc/floatator/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: floatator
+# Date created: Jun 1, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= floatator
+PORTVERSION= 0.2.1
+CATEGORIES= misc
+MASTER_SITES= http://www.cichon.com/floatator/download/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_XLIB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+.for f in floatator floatator_X_interface
+ ${INSTALL_PROGRAM} ${WRKSRC}/$f ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/floatator/distinfo b/misc/floatator/distinfo
new file mode 100644
index 000000000000..ae993bc84b88
--- /dev/null
+++ b/misc/floatator/distinfo
@@ -0,0 +1 @@
+MD5 (floatator-0.2.1.tar.gz) = fca0a3162b4532183683e1ef5973f43e
diff --git a/misc/floatator/pkg-comment b/misc/floatator/pkg-comment
new file mode 100644
index 000000000000..04bd1b7a50c5
--- /dev/null
+++ b/misc/floatator/pkg-comment
@@ -0,0 +1 @@
+An interactive fluid dynamics simulation
diff --git a/misc/floatator/pkg-descr b/misc/floatator/pkg-descr
new file mode 100644
index 000000000000..272d1b594e02
--- /dev/null
+++ b/misc/floatator/pkg-descr
@@ -0,0 +1,4 @@
+Floatator is an interactive fluid dynamics simulation. The simulation and
+the visualisation are 2D.
+
+WWW: http://www.cichon.com/floatator/
diff --git a/misc/floatator/pkg-plist b/misc/floatator/pkg-plist
new file mode 100644
index 000000000000..6d981ba3a0ce
--- /dev/null
+++ b/misc/floatator/pkg-plist
@@ -0,0 +1,2 @@
+bin/floatator
+bin/floatator_X_interface