aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/xfce4-iconbox/Makefile10
-rw-r--r--misc/xfce4-iconbox/pkg-plist15
2 files changed, 23 insertions, 2 deletions
diff --git a/misc/xfce4-iconbox/Makefile b/misc/xfce4-iconbox/Makefile
index 4600611d34c7..5e321187e820 100644
--- a/misc/xfce4-iconbox/Makefile
+++ b/misc/xfce4-iconbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-iconbox
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= misc xfce
MASTER_SITES= http://www.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://linux.imp.mx/xfce4/xfce_${PORTVERSION}/src/
@@ -16,12 +17,17 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 icon box, an alternative taskbar
BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
USE_GNOME= gtk20
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/misc/xfce4-iconbox/pkg-plist b/misc/xfce4-iconbox/pkg-plist
index 0f8a185eaac9..d3606b2cbc9a 100644
--- a/misc/xfce4-iconbox/pkg-plist
+++ b/misc/xfce4-iconbox/pkg-plist
@@ -2,5 +2,20 @@ bin/xfce4-iconbox
lib/xfce4/mcs-plugins/xfce4-iconbox_settings.a
lib/xfce4/mcs-plugins/xfce4-iconbox_settings.la
lib/xfce4/mcs-plugins/xfce4-iconbox_settings.so
+share/locale/ca/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/de/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/es/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/es_MX/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/fr/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/hu/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/it/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/lt/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/ms/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/nl/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/pt_PT/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/ru/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/tr/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/zh_CN/LC_MESSAGES/xfce4-iconbox.mo
+share/locale/zh_TW/LC_MESSAGES/xfce4-iconbox.mo
@unexec rmdir %D/lib/xfce4/mcs-plugins 2>/dev/null || true
@unexec rmdir %D/lib/xfce4 2>/dev/null || true