aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/freecode-submit/Makefile30
-rw-r--r--misc/freecode-submit/distinfo2
-rw-r--r--misc/freecode-submit/pkg-descr7
-rw-r--r--misc/freshmeat-submit/Makefile30
-rw-r--r--misc/freshmeat-submit/distinfo2
-rw-r--r--misc/freshmeat-submit/pkg-descr7
7 files changed, 79 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index af7e27d8ecda..e4b924da4193 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -87,6 +87,7 @@
SUBDIR += fortune-mod-futurama
SUBDIR += fortuneit
SUBDIR += freedialog
+ SUBDIR += freshmeat-submit
SUBDIR += ftdi-eeprom
SUBDIR += ftree
SUBDIR += gaim-guifications
diff --git a/misc/freecode-submit/Makefile b/misc/freecode-submit/Makefile
new file mode 100644
index 000000000000..add4a5796b8a
--- /dev/null
+++ b/misc/freecode-submit/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: freshmeat-submit
+# Date created: 2 Jan 2005
+# Whom: x
+#
+# $FreeBSD$
+#
+
+PORTNAME= freshmeat-submit
+PORTVERSION= 1.6
+CATEGORIES= misc
+MASTER_SITES= http://www.catb.org/~esr/freshmeat-submit/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Submission of updates to Freshmeat via its XML-RPC
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/freshmeat-submit
+MAN1= freshmeat-submit.1
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/freshmeat-submit ${PREFIX}/bin
+ ${MKDIR} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/freshmeat-submit.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/misc/freecode-submit/distinfo b/misc/freecode-submit/distinfo
new file mode 100644
index 000000000000..59cadd27594d
--- /dev/null
+++ b/misc/freecode-submit/distinfo
@@ -0,0 +1,2 @@
+MD5 (freshmeat-submit-1.6.tar.gz) = 0c08186b4f0bd6d026c45c3028ed2ccc
+SIZE (freshmeat-submit-1.6.tar.gz) = 17296
diff --git a/misc/freecode-submit/pkg-descr b/misc/freecode-submit/pkg-descr
new file mode 100644
index 000000000000..8f99979e7a4a
--- /dev/null
+++ b/misc/freecode-submit/pkg-descr
@@ -0,0 +1,7 @@
+freshmeat-submit is a Python script that supports remote submission of
+release updates to Freshmeat via its XML-RPC interface. It is intended
+for use in project release scripts. It reads the metadata from an
+RFC-2822-like message on standard input, possibly with overrides
+by command-line switches.
+
+WWW: http://www.catb.org/~esr/freshmeat-submit/
diff --git a/misc/freshmeat-submit/Makefile b/misc/freshmeat-submit/Makefile
new file mode 100644
index 000000000000..add4a5796b8a
--- /dev/null
+++ b/misc/freshmeat-submit/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: freshmeat-submit
+# Date created: 2 Jan 2005
+# Whom: x
+#
+# $FreeBSD$
+#
+
+PORTNAME= freshmeat-submit
+PORTVERSION= 1.6
+CATEGORIES= misc
+MASTER_SITES= http://www.catb.org/~esr/freshmeat-submit/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Submission of updates to Freshmeat via its XML-RPC
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/freshmeat-submit
+MAN1= freshmeat-submit.1
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/freshmeat-submit ${PREFIX}/bin
+ ${MKDIR} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/freshmeat-submit.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/misc/freshmeat-submit/distinfo b/misc/freshmeat-submit/distinfo
new file mode 100644
index 000000000000..59cadd27594d
--- /dev/null
+++ b/misc/freshmeat-submit/distinfo
@@ -0,0 +1,2 @@
+MD5 (freshmeat-submit-1.6.tar.gz) = 0c08186b4f0bd6d026c45c3028ed2ccc
+SIZE (freshmeat-submit-1.6.tar.gz) = 17296
diff --git a/misc/freshmeat-submit/pkg-descr b/misc/freshmeat-submit/pkg-descr
new file mode 100644
index 000000000000..8f99979e7a4a
--- /dev/null
+++ b/misc/freshmeat-submit/pkg-descr
@@ -0,0 +1,7 @@
+freshmeat-submit is a Python script that supports remote submission of
+release updates to Freshmeat via its XML-RPC interface. It is intended
+for use in project release scripts. It reads the metadata from an
+RFC-2822-like message on standard input, possibly with overrides
+by command-line switches.
+
+WWW: http://www.catb.org/~esr/freshmeat-submit/