aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile165
-rw-r--r--multimedia/audacious-plugins/distinfo3
-rw-r--r--multimedia/audacious-plugins/pkg-descr5
-rw-r--r--multimedia/audacious-plugins/pkg-message2
-rw-r--r--multimedia/audacious-plugins/pkg-plist123
5 files changed, 0 insertions, 298 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
deleted file mode 100644
index a9f68f00eae2..000000000000
--- a/multimedia/audacious-plugins/Makefile
+++ /dev/null
@@ -1,165 +0,0 @@
-# New ports collection makefile for: audacious
-# Date created: 2006-01-01
-# Whom: Zastupov Stepan [RedChrom] <redchrom@mail.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= audacious
-PORTVERSION= 0.2
-PORTREVISION= 1
-CATEGORIES= multimedia audio
-MASTER_SITES= http://audacious-media-player.org/release/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= novel
-DISTNAME= audacious-${PORTVERSION}
-EXTRACT_SUFX=.tgz
-
-MAINTAINER= redchrom@gmail.com
-COMMENT= A media player based on BMP and XMMS
-
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
-
-USE_GNOME= gtk20 libglade2
-WANT_GNOME= yes
-USE_X_PREFIX= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lstdc++" \
- INPUT_PLUGINS="${INPUT_PLUGINS}" \
- OUTPUT_PLUGINS="${OUTPUT_PLUGINS}" \
- VISUALIZATION_PLUGINS="${VISUALIZATION_PLUGINS}"
-
-MAN1= audacious.1
-
-PORTDOCS= README AUTHORS ChangeLog NEWS
-
-INPUT_PLUGINS= cdaudio,mpg123,wav,tonegen,wma,console,sexypsf
-OUTPUT_PLUGINS= OSS,disk_writer,crossfade
-VISUALIZATION_PLUGINS= blur_scope
-
-OPTIONS= VORBIS "Enable Ogg Vorbis input" on \
- FLAC "Enable flac input" on \
- MODPLUG "Enable modplug input" off \
- MPC "Enable mpc input" off \
- ESOUND "Enable Esound output" off \
- VISUAL "Enable libvisual plugin" off \
- ID3V2 "Enable id3v2 editing" off \
- SIMD "Build with x86 SIMD(3DNow!/MMX) instructions support" on \
- SDL "Enable SDL support" off \
- GNOME "Build with gnomevfs/gconf support" off
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-INPUT_PLUGINS+= vorbis
-PLIST_SUB+= VORBISPLUGIN=""
-.else
-CONFIGURE_ARGS+= --disable-vorbis
-PLIST_SUB+= VORBISPLUGIN="@comment "
-.endif
-
-.if !defined(WITHOUT_FLAC)
-INPUT_PLUGINS+= flac
-PLIST_SUB+= FLACPLUGIN=""
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-.else
-PLIST_SUB+= FLACPLUGIN="@comment "
-CONFIGURE_ARGS+= --disable-flac
-.endif
-
-.if !defined(WITHOUT_MODPLUG)
-INPUT_PLUGINS+= modplug
-PLIST_SUB+= MODPLUG=""
-LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
-.else
-PLIST_SUB+= MODPLUG="@comment "
-CONFIGURE_ARGS+= --disable-modplug
-.endif
-
-.if !defined(WITHOUT_MPC)
-INPUT_PLUGINS+= musepack
-PLIST_SUB+= MPCPLUGIN=""
-LIB_DEPENDS+= mpcdec.3:${PORTSDIR}/audio/libmpcdec \
- tag.5:${PORTSDIR}/audio/taglib
-.else
-PLIST_SUB+= MPCPLUGIN="@comment "
-CONFIGURE_ARGS+= --disable-musepack
-.endif
-
-.if defined(WITH_ESOUND)
-USE_GNOME+= esound
-OUTPUT_PLUGINS+= esd
-PLIST_SUB+= ESDPLUGIN=""
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
-.else
-PKGNAMESUFFIX= -esound
-.endif
-.else
-CONFIGURE_ARGS+= --disable-esd
-PLIST_SUB+= ESDPLUGIN="@comment "
-.endif
-
-.if defined(WITH_VISUAL)
-PLIST_SUB+= LIBVISUAL=""
-VISUALIZATION_PLUGINS+= libvisual-proxy
-LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
-.else
-PLIST_SUB+= LIBVISUAL="@comment "
-.endif
-
-.if defined(WITH_ID3V2)
-LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
-.endif
-
-.if ${ARCH} != "i386"
-WITHOUT_SIMD= yes
-.endif
-
-.if !defined(WITHOUT_SIMD) && ${OSVERSION} >= 400021
-CONFIGURE_ARGS+= --enable-simd
-.endif
-
-.if defined(WITH_SDL)
-USE_SDL= sdl
-.endif
-
-.if defined(WITH_GNOME)
-USE_GNOME+= gconf2 gnomevfs2
-CONFIGURE_ARGS+= --enable-gnome-vfs --enable-gconf
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
- ${WRKSRC}/configure
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if defined(WITH_GNOME)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You have installed audacious with gconf support."
- @${ECHO_MSG} "ALL PRESETS will be storing in the gconf database."
- @${ECHO_MSG} ""
-.endif
-.if defined(WITH_VISUAL)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You have installed audacious with libvisual support."
- @${ECHO_MSG} "If you want to be able to access any visualizations,"
- @${ECHO_MSG} "you must install the graphics/libvisual-plugins port."
- @${ECHO_MSG} ""
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in README AUTHORS ChangeLog NEWS
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
deleted file mode 100644
index 801500dae195..000000000000
--- a/multimedia/audacious-plugins/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (audacious-0.2.tgz) = 42ecd9753684929482e598a0a7170147
-SHA256 (audacious-0.2.tgz) = 5999c83d6afccff6d1cb1410fc8bea439c0a4337b4077470c6ac2a93cb1fd0a8
-SIZE (audacious-0.2.tgz) = 3834934
diff --git a/multimedia/audacious-plugins/pkg-descr b/multimedia/audacious-plugins/pkg-descr
deleted file mode 100644
index 16c885cd90e5..000000000000
--- a/multimedia/audacious-plugins/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Audacious is a fork of beep-media-player 0.9.7.1.
-The primary goals of this fork are keeping ideology of original BMP
-and merging miscellaneous plugins into Audacious
-
-WWW: http://audacious-media-player.org
diff --git a/multimedia/audacious-plugins/pkg-message b/multimedia/audacious-plugins/pkg-message
deleted file mode 100644
index d3a0b0cf6d5c..000000000000
--- a/multimedia/audacious-plugins/pkg-message
+++ /dev/null
@@ -1,2 +0,0 @@
-audacious supports Gzipped and uncompressed skins. If you would like to use
-Zip format skins you will need to ensure archivers/unzip is installed.
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
deleted file mode 100644
index ef0cf2f711d1..000000000000
--- a/multimedia/audacious-plugins/pkg-plist
+++ /dev/null
@@ -1,123 +0,0 @@
-bin/audacious
-include/audacious/beepctrl.h
-include/audacious/configdb.h
-include/audacious/configfile.h
-include/audacious/dirbrowser.h
-include/audacious/formatter.h
-include/audacious/plugin.h
-include/audacious/rcfile.h
-include/audacious/titlestring.h
-include/audacious/util.h
-include/audacious/vfs.h
-include/audacious/input.h
-include/audacious/output.h
-include/audacious/xml_document.h
-lib/audacious/Effect/libladspa.la
-lib/audacious/Effect/libladspa.so
-lib/audacious/General/libsong_change.la
-lib/audacious/General/libsong_change.so
-lib/audacious/Input/libcdaudio.la
-lib/audacious/Input/libcdaudio.so
-lib/audacious/Input/libconsole.la
-lib/audacious/Input/libconsole.so
-lib/audacious/Input/libmpg123.la
-lib/audacious/Input/libmpg123.so
-lib/audacious/Input/libsexypsf.la
-lib/audacious/Input/libsexypsf.so
-lib/audacious/Input/libtonegen.la
-lib/audacious/Input/libtonegen.so
-%%VORBISPLUGIN%%lib/audacious/Input/libvorbis.la
-%%VORBISPLUGIN%%lib/audacious/Input/libvorbis.so
-%%FLACPLUGIN%%lib/audacious/Input/libflac.la
-%%FLACPLUGIN%%lib/audacious/Input/libflac.so
-%%MODPLUG%%lib/audacious/Input/libmodplug.la
-%%MODPLUG%%lib/audacious/Input/libmodplug.so
-%%MPCPLUGIN%%lib/audacious/Input/libmpc.la
-%%MPCPLUGIN%%lib/audacious/Input/libmpc.so
-lib/audacious/Input/libwav.la
-lib/audacious/Input/libwav.so
-lib/audacious/Input/libwma.la
-lib/audacious/Input/libwma.so
-lib/audacious/Output/libOSS.la
-lib/audacious/Output/libOSS.so
-%%ESDPLUGIN%%lib/audacious/Output/libesdout.la
-%%ESDPLUGIN%%lib/audacious/Output/libesdout.so
-lib/audacious/Output/libcrossfade.la
-lib/audacious/Output/libcrossfade.so
-lib/audacious/Output/libcrossfade.so.0
-lib/audacious/Output/libdisk_writer.la
-lib/audacious/Output/libdisk_writer.so
-lib/audacious/Visualization/libbscope.la
-lib/audacious/Visualization/libbscope.so
-%%LIBVISUAL%%lib/audacious/Visualization/libvisual_proxy.la
-%%LIBVISUAL%%lib/audacious/Visualization/libvisual_proxy.so
-lib/libaudacious.la
-lib/libaudacious.so
-lib/libaudacious.so.2
-libdata/pkgconfig/audacious.pc
-share/applications/audacious.desktop
-share/pixmaps/audacious.png
-%%DATADIR%%/Skins/Default/balance.png
-%%DATADIR%%/Skins/Default/cbuttons.png
-%%DATADIR%%/Skins/Default/eq_ex.png
-%%DATADIR%%/Skins/Default/eqmain.png
-%%DATADIR%%/Skins/Default/main.png
-%%DATADIR%%/Skins/Default/monoster.png
-%%DATADIR%%/Skins/Default/nums_ex.png
-%%DATADIR%%/Skins/Default/playpaus.png
-%%DATADIR%%/Skins/Default/pledit.png
-%%DATADIR%%/Skins/Default/pledit.txt
-%%DATADIR%%/Skins/Default/posbar.png
-%%DATADIR%%/Skins/Default/shufrep.png
-%%DATADIR%%/Skins/Default/text.png
-%%DATADIR%%/Skins/Default/titlebar.png
-%%DATADIR%%/Skins/Default/viscolor.txt
-%%DATADIR%%/Skins/Default/volume.png
-%%DATADIR%%/glade/addfiles.glade
-%%DATADIR%%/glade/prefswin.glade
-%%DATADIR%%/images/about-logo.png
-%%DATADIR%%/images/appearance.png
-%%DATADIR%%/images/eq.png
-%%DATADIR%%/images/mouse.png
-%%DATADIR%%/images/playlist.png
-%%DATADIR%%/images/plugins.png
-share/locale/br/LC_MESSAGES/audacious.mo
-share/locale/cs/LC_MESSAGES/audacious.mo
-share/locale/cy/LC_MESSAGES/audacious.mo
-share/locale/de/LC_MESSAGES/audacious.mo
-share/locale/el/LC_MESSAGES/audacious.mo
-share/locale/es/LC_MESSAGES/audacious.mo
-share/locale/fi/LC_MESSAGES/audacious.mo
-share/locale/fr/LC_MESSAGES/audacious.mo
-share/locale/hi/LC_MESSAGES/audacious.mo
-share/locale/hu/LC_MESSAGES/audacious.mo
-share/locale/it/LC_MESSAGES/audacious.mo
-share/locale/ja/LC_MESSAGES/audacious.mo
-share/locale/ka/LC_MESSAGES/audacious.mo
-share/locale/ko/LC_MESSAGES/audacious.mo
-share/locale/lt/LC_MESSAGES/audacious.mo
-share/locale/mk/LC_MESSAGES/audacious.mo
-share/locale/nl/LC_MESSAGES/audacious.mo
-share/locale/pl/LC_MESSAGES/audacious.mo
-share/locale/pt_BR/LC_MESSAGES/audacious.mo
-share/locale/ro/LC_MESSAGES/audacious.mo
-share/locale/ru/LC_MESSAGES/audacious.mo
-share/locale/sk/LC_MESSAGES/audacious.mo
-share/locale/sv/LC_MESSAGES/audacious.mo
-share/locale/uk/LC_MESSAGES/audacious.mo
-share/locale/zh_CN/LC_MESSAGES/audacious.mo
-share/locale/zh_TW/LC_MESSAGES/audacious.mo
-share/pixmaps/audacious.png
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%/Skins/Default
-@dirrm %%DATADIR%%/Skins
-@dirrm %%DATADIR%%
-@dirrm lib/audacious/Visualization
-@dirrm lib/audacious/Output
-@dirrm lib/audacious/Input
-@dirrm lib/audacious/General
-@dirrm lib/audacious/Effect
-@dirrm lib/audacious
-@dirrm include/audacious
-@dirrmtry share/applications