aboutsummaryrefslogtreecommitdiff
path: root/multimedia/camserv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/camserv/Makefile')
-rw-r--r--multimedia/camserv/Makefile36
1 files changed, 13 insertions, 23 deletions
diff --git a/multimedia/camserv/Makefile b/multimedia/camserv/Makefile
index 9a358b4b3838..06cb5c64d9c5 100644
--- a/multimedia/camserv/Makefile
+++ b/multimedia/camserv/Makefile
@@ -6,40 +6,30 @@
#
PORTNAME= camserv
-PORTVERSION= 0.42
+PORTVERSION= 0.5.0
+PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= http://cserv.sourceforge.net/old/
MAINTAINER= chein@freebsd.org
COMMENT= Camserv is a free program to do streaming video via the web
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
-
-# Things that should get fixed
-#
-# imlib2 still needs to be ported
-# http://www.us.rasterman.com/files/imlib2-0.0.5.tar.gz
-# imlib2:${PORTSDIR}/graphics/imlib2
-#
-# gtk12 has broken includes ...
-# should look something like this :
-# include <gtk12/gdk/gdkprivate.h>
-# instead of <gdk/gdkprivate.h>
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ Imlib2.2:${PORTSDIR}/graphics/imlib2 \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_X_LIB= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Broken pkg-plist"
-.endif
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include \
+ -I${X11BASE}/include/gtk12 -I${X11BASE}/include/gdk-pixbuf-1.0 \
+ -I${LOCALBASE}/include/glib12" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-install:
-
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/camserv
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/camserv
- ${INSTALL_DATA} ${WRKSRC}/javascript.txt ${PREFIX}/share/doc/camserv
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/javascript.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>