aboutsummaryrefslogtreecommitdiff
path: root/multimedia/emotion
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/emotion')
-rw-r--r--multimedia/emotion/Makefile4
-rw-r--r--multimedia/emotion/files/patch-src-modules-xine-emotion_xine_vo_out.c16
2 files changed, 18 insertions, 2 deletions
diff --git a/multimedia/emotion/Makefile b/multimedia/emotion/Makefile
index 0347ea1a7d88..7861c38a2f85 100644
--- a/multimedia/emotion/Makefile
+++ b/multimedia/emotion/Makefile
@@ -8,7 +8,7 @@
PORTNAME= emotion
PORTVERSION= 0.2.0.56361
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= multimedia enlightenment
MASTER_SITES= http://files.roorback.net/e17/2011-01-29/extra/
@@ -40,7 +40,7 @@ IGNORE= is useless without playback library. Please run 'make config' and choose
.endif
.if !defined(WITHOUT_XINE)
-LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+=--enable-xine
PLIST_SUB+= XINE=""
.else
diff --git a/multimedia/emotion/files/patch-src-modules-xine-emotion_xine_vo_out.c b/multimedia/emotion/files/patch-src-modules-xine-emotion_xine_vo_out.c
new file mode 100644
index 000000000000..b8a238bde9b5
--- /dev/null
+++ b/multimedia/emotion/files/patch-src-modules-xine-emotion_xine_vo_out.c
@@ -0,0 +1,16 @@
+--- src/modules/xine/emotion_xine_vo_out.c.orig
++++ src/modules/xine/emotion_xine_vo_out.c
+@@ -119,8 +119,13 @@ _emotion_class_init(xine_t *xine, void *
+ cl = (Emotion_Class *) malloc(sizeof(Emotion_Class));
+ if (!cl) return NULL;
+ cl->driver_class.open_plugin = _emotion_open;
++#if XINE_MAJOR_VERSION < 1 || (XINE_MAJOR_VERSION == 1 && XINE_MINOR_VERSION < 2)
+ cl->driver_class.get_identifier = _emotion_class_identifier_get;
+ cl->driver_class.get_description = _emotion_class_description_get;
++#else
++ cl->driver_class.identifier = _emotion_class_identifier_get(NULL);
++ cl->driver_class.description = _emotion_class_description_get(NULL);
++#endif
+ cl->driver_class.dispose = _emotion_class_dispose;
+ cl->config = xine->config;
+ cl->xine = xine;