aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins80/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer-plugins80/files')
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_dirac_gstdiracdec.cc22
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in23
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in23
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c13
4 files changed, 75 insertions, 6 deletions
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_dirac_gstdiracdec.cc b/multimedia/gstreamer-plugins80/files/patch-ext_dirac_gstdiracdec.cc
new file mode 100644
index 000000000000..2ad0b2caf587
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_dirac_gstdiracdec.cc
@@ -0,0 +1,22 @@
+--- ext/dirac/gstdiracdec.cc.orig Mon Feb 28 22:04:33 2005
++++ ext/dirac/gstdiracdec.cc Mon Feb 28 22:12:15 2005
+@@ -253,13 +253,18 @@
+
+ case STATE_SEQUENCE:{
+ guint8 *buf[3];
++ gint fps_num, fps_denom;
++
++ fps_num = diracdec->decoder->seq_params.frame_rate.numerator;
++ fps_denom = diracdec->decoder->seq_params.frame_rate.denominator;
+
+ /* start-of-sequence - allocate buffer */
+ if (!gst_diracdec_link (diracdec,
+ diracdec->decoder->seq_params.width,
+ diracdec->decoder->seq_params.height,
++ (gdouble) fps_num / (gdouble) fps_denom,
+ gst_diracdec_chroma_to_fourcc (diracdec->decoder->seq_params.
+- chroma), diracdec->decoder->seq_params.frame_rate)) {
++ chroma))) {
+ GST_ELEMENT_ERROR (diracdec, CORE, NEGOTIATION, (NULL),
+ ("Failed to set caps to %dx%d @ %d fps (format=" GST_FOURCC_FORMAT
+ "/%d)", diracdec->decoder->seq_params.width,
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in b/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in
new file mode 100644
index 000000000000..0ee53a92ecd6
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in
@@ -0,0 +1,23 @@
+--- ext/libcaca/Makefile.in.orig Mon Oct 4 00:07:18 2004
++++ ext/libcaca/Makefile.in Mon Oct 4 00:07:59 2004
+@@ -76,8 +76,7 @@
+ pluginLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(plugin_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+-libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
++libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ am_libgstcacasink_la_OBJECTS = libgstcacasink_la-gstcacasink.lo
+ libgstcacasink_la_OBJECTS = $(am_libgstcacasink_la_OBJECTS)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+@@ -616,9 +615,7 @@
+ plugin_LTLIBRARIES = libgstcacasink.la
+ libgstcacasink_la_SOURCES = gstcacasink.c
+ libgstcacasink_la_CFLAGS = $(GST_CFLAGS) $(LIBCACA_CFLAGS)
+-libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) \
+- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
+-
++libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) -lgstinterfaces-%%VERSION%%
+ libgstcacasink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+ noinst_HEADERS = gstcacasink.h
+ all: all-am
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in b/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in
new file mode 100644
index 000000000000..c943042ad72a
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in
@@ -0,0 +1,23 @@
+--- ext/sdl/Makefile.in.orig Mon Oct 4 00:56:57 2004
++++ ext/sdl/Makefile.in Mon Oct 4 00:57:47 2004
+@@ -76,8 +76,7 @@
+ pluginLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(plugin_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+-libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
++libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ am_libgstsdlvideosink_la_OBJECTS = \
+ libgstsdlvideosink_la-sdlvideosink.lo
+ libgstsdlvideosink_la_OBJECTS = $(am_libgstsdlvideosink_la_OBJECTS)
+@@ -617,9 +616,7 @@
+ plugin_LTLIBRARIES = libgstsdlvideosink.la
+ libgstsdlvideosink_la_SOURCES = sdlvideosink.c
+ libgstsdlvideosink_la_CFLAGS = $(GST_CFLAGS) $(SDL_CFLAGS)
+-libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) \
+- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
+-
++libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) -lgstinterfaces-%%VERSION%%
+ libgstsdlvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+ noinst_HEADERS = sdlvideosink.h
+ all: all-am
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c b/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c
index d595b086bff5..40b567337892 100644
--- a/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c
+++ b/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c
@@ -1,6 +1,6 @@
---- gst/tta/gstttaparse.c.orig Sun Jan 9 13:59:02 2005
-+++ gst/tta/gstttaparse.c Sun Jan 9 14:02:25 2005
-@@ -162,11 +162,13 @@
+--- gst/tta/gstttaparse.c.orig Sat Jan 8 13:36:26 2005
++++ gst/tta/gstttaparse.c Sat Jan 8 13:37:08 2005
+@@ -162,11 +162,14 @@
case GST_EVENT_SEEK:
{
if (GST_EVENT_SEEK_FORMAT (event) == GST_FORMAT_TIME) {
@@ -9,9 +9,10 @@
- guint64 time = GST_EVENT_SEEK_OFFSET (event);
- guint64 seek_frame = time / (FRAME_TIME * 1000000000);
- guint64 seekpos = ttaparse->index[seek_frame].pos;
-+ guint64 time;
-+ guint64 seek_frame;
-+ guint64 seekpos;
++ guint64 time;
++ guint64 seek_frame;
++ guint64 seekpos;
++ GST_DEBUG_OBJECT (ttaparse, "got seek event");
+ time = GST_EVENT_SEEK_OFFSET (event);
+ seek_frame = time / (FRAME_TIME * 1000000000);
+ seekpos = ttaparse->index[seek_frame].pos;