aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins80/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer-plugins80/files')
-rw-r--r--multimedia/gstreamer-plugins80/files/bsdi_dvd.h340
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-configure12
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext::ivorbis::vorbisenc.h103
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c34
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in23
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_mpeg2enc_gstmpeg2encoptions.cc26
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in23
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gcc29577
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_Makefile.in11
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_librfb_gstrfbsrc.c10
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-sys_cdrom_gstcdplayer-ioctl-bsd.h72
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.h10
12 files changed, 0 insertions, 741 deletions
diff --git a/multimedia/gstreamer-plugins80/files/bsdi_dvd.h b/multimedia/gstreamer-plugins80/files/bsdi_dvd.h
deleted file mode 100644
index ff61ebd252f6..000000000000
--- a/multimedia/gstreamer-plugins80/files/bsdi_dvd.h
+++ /dev/null
@@ -1,340 +0,0 @@
-#ifndef _DVD_H_
-#define _DVD_H_
-
-#include <sys/cdefs.h>
-#include <machine/endian.h>
-#include <sys/ioctl.h>
-
-__BEGIN_DECLS
-int dvd_cdrom_ioctl(int, unsigned long, void *);
-int cdrom_blocksize(int, int);
-void dvd_cdrom_debug(int);
-__END_DECLS
-
-#define ioctl(a,b,c) dvd_cdrom_ioctl((a),(b),(c))
-
-typedef unsigned char __u8;
-typedef unsigned short __u16;
-typedef unsigned int __u32;
-
-#define DVD_READ_STRUCT 0x5390 /* Read structure */
-#define DVD_WRITE_STRUCT 0x5391 /* Write structure */
-#define DVD_AUTH 0x5392 /* Authentication */
-
-#define DVD_STRUCT_PHYSICAL 0x00
-#define DVD_STRUCT_COPYRIGHT 0x01
-#define DVD_STRUCT_DISCKEY 0x02
-#define DVD_STRUCT_BCA 0x03
-#define DVD_STRUCT_MANUFACT 0x04
-
-struct dvd_layer {
- __u8 book_version : 4;
- __u8 book_type : 4;
- __u8 min_rate : 4;
- __u8 disc_size : 4;
- __u8 layer_type : 4;
- __u8 track_path : 1;
- __u8 nlayers : 2;
- __u8 track_density : 4;
- __u8 linear_density : 4;
- __u8 bca : 1;
- __u32 start_sector;
- __u32 end_sector;
- __u32 end_sector_l0;
-};
-
-struct dvd_physical {
- __u8 type;
- __u8 layer_num;
- struct dvd_layer layer[4];
-};
-
-struct dvd_copyright {
- __u8 type;
-
- __u8 layer_num;
- __u8 cpst;
- __u8 rmi;
-};
-
-struct dvd_disckey {
- __u8 type;
-
- unsigned agid : 2;
- __u8 value[2048];
-};
-
-struct dvd_bca {
- __u8 type;
-
- int len;
- __u8 value[188];
-};
-
-struct dvd_manufact {
- __u8 type;
-
- __u8 layer_num;
- int len;
- __u8 value[2048];
-};
-
-typedef union {
- __u8 type;
-
- struct dvd_physical physical;
- struct dvd_copyright copyright;
- struct dvd_disckey disckey;
- struct dvd_bca bca;
- struct dvd_manufact manufact;
-} dvd_struct;
-
-/*
- * DVD authentication ioctl
- */
-
-/* Authentication states */
-#define DVD_LU_SEND_AGID 0
-#define DVD_HOST_SEND_CHALLENGE 1
-#define DVD_LU_SEND_KEY1 2
-#define DVD_LU_SEND_CHALLENGE 3
-#define DVD_HOST_SEND_KEY2 4
-
-/* Termination states */
-#define DVD_AUTH_ESTABLISHED 5
-#define DVD_AUTH_FAILURE 6
-
-/* Other functions */
-#define DVD_LU_SEND_TITLE_KEY 7
-#define DVD_LU_SEND_ASF 8
-#define DVD_INVALIDATE_AGID 9
-#define DVD_LU_SEND_RPC_STATE 10
-#define DVD_HOST_SEND_RPC_STATE 11
-
-/* State data */
-typedef __u8 dvd_key[5]; /* 40-bit value, MSB is first elem. */
-typedef __u8 dvd_challenge[10]; /* 80-bit value, MSB is first elem. */
-
-struct dvd_lu_send_agid {
- __u8 type;
- unsigned agid : 2;
-};
-
-struct dvd_host_send_challenge {
- __u8 type;
- unsigned agid : 2;
-
- dvd_challenge chal;
-};
-
-struct dvd_send_key {
- __u8 type;
- unsigned agid : 2;
-
- dvd_key key;
-};
-
-struct dvd_lu_send_challenge {
- __u8 type;
- unsigned agid : 2;
-
- dvd_challenge chal;
-};
-
-#define DVD_CPM_NO_COPYRIGHT 0
-#define DVD_CPM_COPYRIGHTED 1
-
-#define DVD_CP_SEC_NONE 0
-#define DVD_CP_SEC_EXIST 1
-
-#define DVD_CGMS_UNRESTRICTED 0
-#define DVD_CGMS_SINGLE 2
-#define DVD_CGMS_RESTRICTED 3
-
-struct dvd_lu_send_title_key {
- __u8 type;
- unsigned agid : 2;
-
- dvd_key title_key;
- int lba;
- unsigned cpm : 1;
- unsigned cp_sec : 1;
- unsigned cgms : 2;
-};
-
-struct dvd_lu_send_asf {
- __u8 type;
- unsigned agid : 2;
-
- unsigned asf : 1;
-};
-
-struct dvd_host_send_rpcstate {
- __u8 type;
- __u8 pdrc;
-};
-
-struct dvd_lu_send_rpcstate {
- __u8 type : 2;
- __u8 vra : 3;
- __u8 ucca : 3;
- __u8 region_mask;
- __u8 rpc_scheme;
-};
-
-typedef union {
- __u8 type;
-
- struct dvd_lu_send_agid lsa;
- struct dvd_host_send_challenge hsc;
- struct dvd_send_key lsk;
- struct dvd_lu_send_challenge lsc;
- struct dvd_send_key hsk;
- struct dvd_lu_send_title_key lstk;
- struct dvd_lu_send_asf lsasf;
- struct dvd_host_send_rpcstate hrpcs;
- struct dvd_lu_send_rpcstate lrpcs;
-} dvd_authinfo;
-
-
-typedef struct {
- __u16 report_key_length;
- __u8 reserved1;
- __u8 reserved2;
-#if BYTE_ORDER == BIG_ENDIAN
- __u8 type_code : 2;
- __u8 vra : 3;
- __u8 ucca : 3;
-#elif BYTE_ORDER == LITTLE_ENDIAN
- __u8 ucca : 3;
- __u8 vra : 3;
- __u8 type_code : 2;
-#endif
- __u8 region_mask;
- __u8 rpc_scheme;
- __u8 reserved3;
-} rpc_state_t;
-
-/*
- * Stuff for the CDROM ioctls
-*/
-
-#define CDROMREADTOCHDR 0x5305 /* Read TOC header (cdrom_tochdr) */
-#define CDROMREADTOCENTRY 0x5306 /* Read TOC entry (cdrom_tocentry) */
-#define CDROMEJECT 0x5309 /* Ejects the cdrom media */
-#define CDROMCLOSETRAY 0x5319 /* Reverse of CDROMEJECT */
-#define CDROM_DRIVE_STATUS 0x5326 /* Get tray position, etc. */
-#define CDROM_DISC_STATUS 0x5327 /* Get disc type, etc. */
-#define CDROMREADMODE2 0x530c /* Read CDROM mode 2 data (2336 Bytes) */
-#define CDROMREADMODE1 0x530d /* Read CDROM mode 1 data (2048 Bytes) */
-#define CDROMREADRAW 0x5314 /* read data in raw mode (2352 bytes) */
-
-#define CD_MINS 74 /* max. minutes per CD, not really a limit */
-#define CD_SECS 60 /* seconds per minute */
-#define CD_FRAMES 75 /* frames per second */
-#define CD_MSF_OFFSET 150 /* MSF numbering offset of first frame */
-
-#define CD_HEAD_SIZE 4 /* header (address) bytes per raw data frame */
-#define CD_SYNC_SIZE 12 /* 12 sync bytes per raw data frame */
-#define CD_FRAMESIZE 2048 /* bytes per frame, "cooked" mode */
-#define CD_FRAMESIZE_RAW 2352 /* bytes per frame, "raw" mode */
-#define CD_FRAMESIZE_RAW0 (CD_FRAMESIZE_RAW-CD_SYNC_SIZE-CD_HEAD_SIZE) /*2336*/
-#define CD_FRAMESIZE_RAW1 (CD_FRAMESIZE_RAW-CD_SYNC_SIZE) /*2340*/
-
-/* CD-ROM address types (cdrom_tocentry.cdte_format) */
-#define CDROM_LBA 0x01 /* logical block: first frame is #0 */
-#define CDROM_MSF 0x02 /* minute-second-frame: binary. not bcd here!*/
-
-/* bit to tell whether track is data or audio (cdrom_tocentry.cdte_ctrl) */
-#define CDROM_DATA_TRACK 0x04
-
-/* The leadout track is always 0xAA, regardless of # of tracks on disc */
-#define CDROM_LEADOUT 0xAA
-
-/* drive status returned by CDROM_DRIVE_STATUS ioctl */
-#define CDS_NO_INFO 0 /* if not implemented */
-#define CDS_NO_DISC 1
-#define CDS_TRAY_OPEN 2
-#define CDS_DRIVE_NOT_READY 3
-#define CDS_DISC_OK 4
-
-/*
- * Return values for CDROM_DISC_STATUS ioctl.
- * Can also return CDS_NO_INFO and CDS_NO_DISC from above
-*/
-#define CDS_AUDIO 100
-#define CDS_DATA_1 101
-#define CDS_DATA_2 102
-#define CDS_XA_2_1 103
-#define CDS_XA_2_2 104
-#define CDS_MIXED 105
-
-/* For compile compatibility only - we don't support changers */
-#define CDSL_NONE ((int) (~0U>>1)-1)
-#define CDSL_CURRENT ((int) (~0U>>1))
-
-struct cdrom_msf
-{
- __u8 cdmsf_min0; /* start minute */
- __u8 cdmsf_sec0; /* start second */
- __u8 cdmsf_frame0; /* start frame */
- __u8 cdmsf_min1; /* end minute */
- __u8 cdmsf_sec1; /* end second */
- __u8 cdmsf_frame1; /* end frame */
-};
-
-struct cdrom_tochdr
- {
- __u8 cdth_trk0; /* start track */
- __u8 cdth_trk1; /* end track */
- };
-
-struct cdrom_msf0
-{
- __u8 minute;
- __u8 second;
- __u8 frame;
-};
-
-union cdrom_addr
-{
- struct cdrom_msf0 msf;
- int lba;
-};
-
-struct cdrom_tocentry
-{
- __u8 cdte_track;
- __u8 cdte_adr :4;
- __u8 cdte_ctrl :4;
- __u8 cdte_format;
- union cdrom_addr cdte_addr;
- __u8 cdte_datamode;
-};
-
-struct modesel_head
-{
- __u8 reserved1;
- __u8 medium;
- __u8 reserved2;
- __u8 block_desc_length;
- __u8 density;
- __u8 number_of_blocks_hi;
- __u8 number_of_blocks_med;
- __u8 number_of_blocks_lo;
- __u8 reserved3;
- __u8 block_length_hi;
- __u8 block_length_med;
- __u8 block_length_lo;
-};
-
-typedef struct
-{
- int data;
- int audio;
- int cdi;
- int xa;
- int error;
-} tracktype;
-
-#endif /* _DVD_H_ */
diff --git a/multimedia/gstreamer-plugins80/files/patch-configure b/multimedia/gstreamer-plugins80/files/patch-configure
deleted file mode 100644
index 92b1deb51a64..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig Wed Jun 23 21:30:24 2004
-+++ configure Wed Jun 23 21:30:25 2004
-@@ -46068,7 +46068,8 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-laudio $X_LIBS $LIBS"
-+#xxx fix the non x case is er niet...
-+LIBS="-laudio -lm -lXt $X_LIBS $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext::ivorbis::vorbisenc.h b/multimedia/gstreamer-plugins80/files/patch-ext::ivorbis::vorbisenc.h
deleted file mode 100644
index 90d39a1a29b2..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext::ivorbis::vorbisenc.h
+++ /dev/null
@@ -1,103 +0,0 @@
---- /dev/null Thu Feb 12 22:22:00 2004
-+++ ext/ivorbis/vorbisenc.h Thu Feb 12 22:24:08 2004
-@@ -0,0 +1,100 @@
-+/* GStreamer
-+ * Copyright (C) <1999> Erik Walthinsen <omega@cse.ogi.edu>
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Library General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * Library General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU Library General Public
-+ * License along with this library; if not, write to the
-+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-+ * Boston, MA 02111-1307, USA.
-+ */
-+
-+
-+#ifndef __VORBISENC_H__
-+#define __VORBISENC_H__
-+
-+
-+#include <gst/gst.h>
-+
-+#include <tremor/ivorbiscodec.h>
-+
-+#ifdef __cplusplus
-+extern "C" {
-+#endif /* __cplusplus */
-+
-+#define GST_TYPE_VORBISENC \
-+ (vorbisenc_get_type())
-+#define GST_VORBISENC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_CAST((obj),GST_TYPE_VORBISENC,VorbisEnc))
-+#define GST_VORBISENC_CLASS(klass) \
-+ (G_TYPE_CHECK_CLASS_CAST((klass),GST_TYPE_VORBISENC,VorbisEncClass))
-+#define GST_IS_VORBISENC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_TYPE((obj),GST_TYPE_VORBISENC))
-+#define GST_IS_VORBISENC_CLASS(obj) \
-+ (G_TYPE_CHECK_CLASS_TYPE((klass),GST_TYPE_VORBISENC))
-+
-+typedef struct _VorbisEnc VorbisEnc;
-+typedef struct _VorbisEncClass VorbisEncClass;
-+
-+struct _VorbisEnc {
-+ GstElement element;
-+
-+ GstPad *sinkpad,
-+ *srcpad;
-+
-+ ogg_stream_state os; /* take physical pages, weld into a logical
-+ stream of packets */
-+ ogg_page og; /* one Ogg bitstream page. Vorbis packets are inside */
-+ ogg_packet op; /* one raw packet of data for decode */
-+
-+ vorbis_info vi; /* struct that stores all the static vorbis bitstream
-+ settings */
-+ vorbis_comment vc; /* struct that stores all the user comments */
-+
-+ vorbis_dsp_state vd; /* central working state for the packet->PCM decoder */
-+ vorbis_block vb; /* local working space for packet->PCM decode */
-+
-+ gboolean eos;
-+
-+ gboolean managed;
-+ gint bitrate;
-+ gint min_bitrate;
-+ gint max_bitrate;
-+ gfloat quality;
-+ gboolean quality_set;
-+ gint serial;
-+
-+ gint channels;
-+ gint frequency;
-+
-+ guint64 samples_in;
-+ guint64 bytes_out;
-+
-+ GstCaps *metadata;
-+
-+ gboolean setup;
-+ gboolean flush_header;
-+ gchar *last_message;
-+};
-+
-+struct _VorbisEncClass {
-+ GstElementClass parent_class;
-+};
-+
-+GType vorbisenc_get_type(void);
-+
-+
-+#ifdef __cplusplus
-+}
-+#endif /* __cplusplus */
-+
-+
-+#endif /* __VORBISENC_H__ */
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c b/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c
deleted file mode 100644
index f3eb910fd77b..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_cdparanoia_gstcdparanoia.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- ext/cdparanoia/gstcdparanoia.c.orig Mon Aug 29 13:50:49 2005
-+++ ext/cdparanoia/gstcdparanoia.c Thu Sep 1 15:30:11 2005
-@@ -562,6 +562,7 @@
- gint16 *cdda_buf;
- gint64 timestamp;
- GstFormat format;
-+ GstEvent *discont_ev;
-
- /* convert the sequence sector number to a timestamp */
- format = GST_FORMAT_TIME;
-@@ -572,7 +573,6 @@
-
- if (!src->discont_sent && (is_track_switch (src, src->cur_sector) ||
- (src->prev_sec != src->cur_sector))) {
-- GstEvent *discont_ev;
-
- if (src->cur_track == src->d->tracks) {
- GST_DEBUG_OBJECT (src, "End of CD");
-@@ -815,9 +815,15 @@
-
- /* open the disc */
- if (cdda_open (src->d)) {
-+#if defined(__FreeBSD__)
-+ GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
-+ (_("Could not open CD device %s for reading."),
-+ src->d->dev->device_path), ("cdda_open failed"));
-+#else
- GST_ELEMENT_ERROR (src, RESOURCE, OPEN_READ,
- (_("Could not open CD device %s for reading."),
- src->d->cdda_device_name), ("cdda_open failed"));
-+#endif
- cdda_close (src->d);
- src->d = NULL;
- return FALSE;
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in b/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in
deleted file mode 100644
index 0ee53a92ecd6..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_libcaca_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- ext/libcaca/Makefile.in.orig Mon Oct 4 00:07:18 2004
-+++ ext/libcaca/Makefile.in Mon Oct 4 00:07:59 2004
-@@ -76,8 +76,7 @@
- pluginLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(plugin_LTLIBRARIES)
- am__DEPENDENCIES_1 =
--libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
-+libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
- am_libgstcacasink_la_OBJECTS = libgstcacasink_la-gstcacasink.lo
- libgstcacasink_la_OBJECTS = $(am_libgstcacasink_la_OBJECTS)
- DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
-@@ -616,9 +615,7 @@
- plugin_LTLIBRARIES = libgstcacasink.la
- libgstcacasink_la_SOURCES = gstcacasink.c
- libgstcacasink_la_CFLAGS = $(GST_CFLAGS) $(LIBCACA_CFLAGS)
--libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) \
-- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
--
-+libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) -lgstinterfaces-%%VERSION%%
- libgstcacasink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
- noinst_HEADERS = gstcacasink.h
- all: all-am
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_mpeg2enc_gstmpeg2encoptions.cc b/multimedia/gstreamer-plugins80/files/patch-ext_mpeg2enc_gstmpeg2encoptions.cc
deleted file mode 100644
index aabbc2971c4d..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_mpeg2enc_gstmpeg2encoptions.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- ext/mpeg2enc/gstmpeg2encoptions.cc.orig Mon Jul 5 19:54:18 2004
-+++ ext/mpeg2enc/gstmpeg2encoptions.cc Mon Jul 5 20:05:37 2004
-@@ -267,11 +267,23 @@
- * Class init stuff.
- */
-
-+#if !defined(_SC_NPROCESSORS_ONLN) && defined(__FreeBSD__)
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#endif
-+
- GstMpeg2EncOptions::GstMpeg2EncOptions ():
- MPEG2EncOptions ()
- {
- /* autodetect number of CPUs */
-+#if !defined(_SC_NPROCESSORS_ONLN) && defined(__FreeBSD__)
-+ /* We need to use a sysctl to get the number of CPUs. */
-+ size_t len = sizeof (num_cpus);
-+
-+ sysctlbyname ("hw.ncpu", &num_cpus, &len, NULL, 0);
-+#else
- num_cpus = sysconf (_SC_NPROCESSORS_ONLN);
-+#endif
- if (num_cpus < 0)
- num_cpus = 1;
- if (num_cpus > 32)
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in b/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in
deleted file mode 100644
index c943042ad72a..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_sdl_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- ext/sdl/Makefile.in.orig Mon Oct 4 00:56:57 2004
-+++ ext/sdl/Makefile.in Mon Oct 4 00:57:47 2004
-@@ -76,8 +76,7 @@
- pluginLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(plugin_LTLIBRARIES)
- am__DEPENDENCIES_1 =
--libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
-+libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
- am_libgstsdlvideosink_la_OBJECTS = \
- libgstsdlvideosink_la-sdlvideosink.lo
- libgstsdlvideosink_la_OBJECTS = $(am_libgstsdlvideosink_la_OBJECTS)
-@@ -617,9 +616,7 @@
- plugin_LTLIBRARIES = libgstsdlvideosink.la
- libgstsdlvideosink_la_SOURCES = sdlvideosink.c
- libgstsdlvideosink_la_CFLAGS = $(GST_CFLAGS) $(SDL_CFLAGS)
--libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) \
-- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
--
-+libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) -lgstinterfaces-%%VERSION%%
- libgstsdlvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
- noinst_HEADERS = sdlvideosink.h
- all: all-am
diff --git a/multimedia/gstreamer-plugins80/files/patch-gcc295 b/multimedia/gstreamer-plugins80/files/patch-gcc295
deleted file mode 100644
index a7a8491067c8..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-gcc295
+++ /dev/null
@@ -1,77 +0,0 @@
---- ext/polyp/polypsink.c.orig Sat Sep 10 19:39:39 2005
-+++ ext/polyp/polypsink.c Sat Sep 10 19:40:17 2005
-@@ -48,18 +48,6 @@
- "width = (int) 16, "
- "depth = (int) 16, "
- "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 16 ]"
--#if 0
-- ";audio/x-raw-float, "
-- "endianness = (int) { LITTLE_ENDIAN, BIG_ENDIAN }, "
-- "width = (int) 32, "
-- "rate = (int) [ 1, MAX ], "
-- "channels = (int) [ 1, 16 ];"
-- "audio/x-raw-int, "
-- "signed = (boolean) FALSE, "
-- "width = (int) 8, "
-- "depth = (int) 8, "
-- "rate = (int) [ 1, MAX ], " "channels = (int) [ 1, 16 ]"
--#endif
- )
- );
-
---- ext/pango/gsttextrender.c.orig Sat Sep 10 19:41:24 2005
-+++ ext/pango/gsttextrender.c Sat Sep 10 19:41:58 2005
-@@ -251,6 +251,7 @@
- GstTextRender *overlay = GST_TEXT_RENDER (gst_pad_get_parent (pad));
- guint size = GST_BUFFER_SIZE (buf);
- guint8 *data = GST_BUFFER_DATA (buf);
-+ gint n;
-
- /* somehow pango barfs over "\0" buffers... */
- while (size > 0 &&
-@@ -274,7 +275,6 @@
- gst_buffer_stamp (out, GST_BUFFER (buf));
- // gst_buffer_stamp (out, buf);
- data = GST_BUFFER_DATA (out);
-- gint n;
-
- for (n = 0; n < overlay->width * overlay->height; n++) {
- data[n * 4] = 0;
---- ext/ogg/gstoggparse.c.orig Sat Sep 10 19:43:13 2005
-+++ ext/ogg/gstoggparse.c Sat Sep 10 19:44:04 2005
-@@ -365,6 +365,7 @@
- guint32 serialno;
- GstBuffer *pagebuffer;
- GstClockTime buffertimestamp = GST_BUFFER_TIMESTAMP (buffer);
-+ page_type type;
-
- ogg = GST_OGG_PARSE (GST_OBJECT_PARENT (pad));
-
-@@ -464,7 +465,7 @@
-
- ogg->last_page_not_bos = TRUE;
-
-- page_type type = gst_ogg_parse_is_header (ogg, stream, &page);
-+ type = gst_ogg_parse_is_header (ogg, stream, &page);
-
- if (type == PAGE_PENDING && ogg->in_headers) {
- gst_buffer_ref (pagebuffer);
---- ext/gnomevfs/gstgnomevfssrc.c.orig Sat Sep 10 19:44:44 2005
-+++ ext/gnomevfs/gstgnomevfssrc.c Sat Sep 10 19:45:15 2005
-@@ -1114,6 +1114,7 @@
- GstBuffer *buf;
- GnomeVFSFileSize readbytes;
- guint8 *data;
-+ GstEvent *event;
-
- g_return_val_if_fail (pad != NULL, NULL);
- src = GST_GNOMEVFSSRC (gst_pad_get_parent (pad));
-@@ -1132,7 +1133,7 @@
- /* deal with tag list */
- if (src->icy_taglist) {
- gst_element_found_tags (GST_ELEMENT (src), src->icy_taglist);
-- GstEvent *event = gst_event_new_tag (src->icy_taglist);
-+ event = gst_event_new_tag (src->icy_taglist);
-
- gst_object_ref (GST_OBJECT (src));
- event->src = GST_OBJECT (src);
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_Makefile.in b/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_Makefile.in
deleted file mode 100644
index fb2afdfb0ef3..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-gst_ffmpegcolorspace_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- gst/ffmpegcolorspace/Makefile.in.orig Wed Mar 9 01:40:27 2005
-+++ gst/ffmpegcolorspace/Makefile.in Wed Mar 9 01:41:10 2005
-@@ -360,7 +360,7 @@
- LAME_LIBS = @LAME_LIBS@
- LCS_CFLAGS = @LCS_CFLAGS@
- LCS_LIBS = @LCS_LIBS@
--LDFLAGS = @LDFLAGS@
-+LDFLAGS = @LDFLAGS@ -Wl,-Bsymbolic -lc
- LIBCACA_CFLAGS = @LIBCACA_CFLAGS@
- LIBCACA_CONFIG = @LIBCACA_CONFIG@
- LIBCACA_LIBS = @LIBCACA_LIBS@
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_librfb_gstrfbsrc.c b/multimedia/gstreamer-plugins80/files/patch-gst_librfb_gstrfbsrc.c
deleted file mode 100644
index e83f136502cf..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-gst_librfb_gstrfbsrc.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gst/librfb/gstrfbsrc.c.orig Fri Jun 3 06:06:43 2005
-+++ gst/librfb/gstrfbsrc.c Fri Jun 3 06:08:21 2005
-@@ -28,6 +28,7 @@
- #include <string.h>
- #include <stdlib.h>
- #include <unistd.h>
-+#include <sys/time.h>
-
- #include <librfb/rfb.h>
-
diff --git a/multimedia/gstreamer-plugins80/files/patch-sys_cdrom_gstcdplayer-ioctl-bsd.h b/multimedia/gstreamer-plugins80/files/patch-sys_cdrom_gstcdplayer-ioctl-bsd.h
deleted file mode 100644
index daaefac5eb5d..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-sys_cdrom_gstcdplayer-ioctl-bsd.h
+++ /dev/null
@@ -1,72 +0,0 @@
---- sys/cdrom/gstcdplayer_ioctl_bsd.h.orig Mon Mar 1 06:52:03 2004
-+++ sys/cdrom/gstcdplayer_ioctl_bsd.h Tue Mar 9 16:05:36 2004
-@@ -142,6 +142,7 @@
- {
- struct ioc_toc_header toc_header;
- struct ioc_read_toc_entry toc_entry;
-+ struct cd_toc_entry toc_entry_data;
- guint i;
-
- cd->fd = open(device,O_RDONLY | O_NONBLOCK);
-@@ -151,7 +152,7 @@
- }
-
- /* get the toc header information */
-- if (ioctl(cd->fd,CDIOREADTOCHDR,&toc_header) != 0) {
-+ if (ioctl(cd->fd,CDIOREADTOCHEADER,&toc_header) != 0) {
- close(cd->fd);
- cd->fd = -1;
- return FALSE;
-@@ -161,6 +162,8 @@
- for (i = 1; i <= toc_header.ending_track; i++) {
- toc_entry.address_format = CD_MSF_FORMAT;
- toc_entry.starting_track = i;
-+ toc_entry.data = &toc_entry_data;
-+ toc_entry.data_len = sizeof(toc_entry_data);
-
- if (ioctl(cd->fd,CDIOREADTOCENTRYS,&toc_entry) != 0) {
- close(cd->fd);
-@@ -168,9 +171,9 @@
- return FALSE;
- }
-
-- cd->tracks[i].minute = toc_entry.entry.addr.msf.minute;
-- cd->tracks[i].second = toc_entry.entry.addr.msf.second;
-- cd->tracks[i].frame = toc_entry.entry.addr.msf.frame;
-+ cd->tracks[i].minute = toc_entry.data->addr.msf.minute;
-+ cd->tracks[i].second = toc_entry.data->addr.msf.second;
-+ cd->tracks[i].frame = toc_entry.data->addr.msf.frame;
- cd->tracks[i].data_track = (toc_entry.data->control & 4) == 4;
- }
-
-@@ -186,9 +189,9 @@
- return FALSE;
- }
-
-- cd->tracks[LEADOUT].minute = toc_entry.entry.addr.msf.minute;
-- cd->tracks[LEADOUT].second = toc_entry.entry.addr.msf.second;
-- cd->tracks[LEADOUT].frame = toc_entry.entry.addr.msf.frame;
-+ cd->tracks[LEADOUT].minute = toc_entry.data->addr.msf.minute;
-+ cd->tracks[LEADOUT].second = toc_entry.data->addr.msf.second;
-+ cd->tracks[LEADOUT].frame = toc_entry.data->addr.msf.frame;
-
- cd->num_tracks = toc_header.ending_track;
-
-@@ -224,6 +227,8 @@
- return FALSE;
- }
-
-+ /* lets return TRUE and lets see what happes (may not be correct)*/
-+ return TRUE;
- }
-
- gboolean cd_pause(struct cd *cd)
-@@ -321,7 +326,7 @@
- return -1;
- }
-
--#ifdef __NetBSD__
-+#if defined(__NetBSD__) || defined(__FreeBSD__)
- return sub_channel.data->what.track_info.track_number;
- #else
- return sub_channel.data->track_number;
diff --git a/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.h b/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.h
deleted file mode 100644
index 30258ba113c1..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-sys_oss_gstosselement.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sys/oss/gstosselement.h.orig Tue Mar 9 16:46:05 2004
-+++ sys/oss/gstosselement.h Tue Mar 9 16:46:14 2004
-@@ -23,6 +23,7 @@
- #ifndef __GST_OSS_ELEMENT_H__
- #define __GST_OSS_ELEMENT_H__
-
-+#include <sys/types.h>
- #include <gst/gst.h>
-
- /* debugging category */