aboutsummaryrefslogtreecommitdiff
path: root/multimedia/handbrake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/handbrake/Makefile')
-rw-r--r--multimedia/handbrake/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 369c2eca8883..46cb3e7dfb74 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -64,7 +64,7 @@ LIB_DEPENDS+= libdvdcss.so:multimedia/libdvdcss
GNU_CONFIGURE= yes
USE_GCC= yes
USES= autoreconf:build compiler:features gmake iconv \
- libtool:build localbase:ldflags pkgconfig python:build
+ libtool:build localbase:ldflags pkgconfig python:2.7,build
MAKE_ENV= V=1 ACLOCAL=${LOCALBASE}/bin/aclocal
CONFIGURE_ARGS= --force --enable-x265
@@ -124,6 +124,10 @@ post-extract: .SILENT
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}/download
.endfor
+post-patch:
+ @${REINPLACE_CMD} 's@python2 @${PYTHON_CMD} @' \
+ ${WRKSRC}/gtk/src/Makefile.am
+
post-install-X11-on:
${LN} -sf ghb ${STAGEDIR}${PREFIX}/bin/HandBrake