aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kissdx
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kissdx')
-rw-r--r--multimedia/kissdx/Makefile5
-rw-r--r--multimedia/kissdx/files/kissdx.in7
-rw-r--r--multimedia/kissdx/files/pkg-message.in2
3 files changed, 7 insertions, 7 deletions
diff --git a/multimedia/kissdx/Makefile b/multimedia/kissdx/Makefile
index 677af27aba44..506490663b7b 100644
--- a/multimedia/kissdx/Makefile
+++ b/multimedia/kissdx/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
USES= iconv
USE_DOS2UNIX= yes
+USE_GCC= any # XXX: uses nested functions
MAKE_ENV= FreeBSD=defined
MAN1= kissdx.1
@@ -33,10 +34,10 @@ PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's|Linux|Unix| ; s|/etc/|${PREFIX}&|' \
${WRKSRC}/kissdx.1
- @${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|' ${WRKSRC}/config.c
+ @${REINPLACE_CMD} -e 's|/etc/|${PREFIX}&|' ${WRKSRC}/config.c
@${RM} ${WRKSRC}/kissdx.o
# Fix parallel (-jX) builds: sanitize dependencies
- @${REINPLACE_CMD} -e 's|^\.o :|kissdx: $$(OBJS)| ; \
+ @${REINPLACE_CMD} -e 's|^\.o :|${PORTNAME}: $$(OBJS)| ; \
/^all:/s| $$(OBJS)||' ${WRKSRC}/Makefile
do-install:
diff --git a/multimedia/kissdx/files/kissdx.in b/multimedia/kissdx/files/kissdx.in
index 148d150ee12f..dbb0162c414e 100644
--- a/multimedia/kissdx/files/kissdx.in
+++ b/multimedia/kissdx/files/kissdx.in
@@ -1,16 +1,15 @@
#!/bin/sh
#
-# This script start and stop the KiSS DX deamon, using the rc.subr functionality
+# Script to start and stop the KiSS DX deamon, using the rc.subr functionality
#
# Add the following lines to /etc/rc.conf to enable this service at boot time:
#
-# kissdx_enable="YES" A
-# (kissdx="YES" for NetBSD)
+# kissdx_enable="YES" (kissdx="YES" for NetBSD)
#
. /etc/rc.subr
-#Name of program to start
+# Name of program to start
name="kissdx"
# Full path to program
diff --git a/multimedia/kissdx/files/pkg-message.in b/multimedia/kissdx/files/pkg-message.in
index 027358ec830e..9a4b94076807 100644
--- a/multimedia/kissdx/files/pkg-message.in
+++ b/multimedia/kissdx/files/pkg-message.in
@@ -1,5 +1,5 @@
The following line needs to be added to /etc/rc.conf in order to start the
-deamon at boot time.
+daemon at boot time.
kissdx_enable="YES" (or kissdx="YES" for NetBSD)