aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kmplayer-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kmplayer-kde4/Makefile')
-rw-r--r--multimedia/kmplayer-kde4/Makefile40
1 files changed, 36 insertions, 4 deletions
diff --git a/multimedia/kmplayer-kde4/Makefile b/multimedia/kmplayer-kde4/Makefile
index 0efc4d5a983b..c5eac263515a 100644
--- a/multimedia/kmplayer-kde4/Makefile
+++ b/multimedia/kmplayer-kde4/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= kmplayer
-PORTVERSION= 0.8.4.r2
CATEGORIES= multimedia audio kde
MASTER_SITES= http://www.xs4all.nl/%7Ejjvrieze/
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.r/-rc/}
+#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.r/-rc/}
+DISTVERSION= 0.8.4-rc4a
MAINTAINER= lioux@FreeBSD.org
COMMENT= KDE frontend to mplayer
@@ -21,6 +21,7 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
USE_BZIP2= yes
USE_KDEBASE_VER=3
+USE_XLIB= yes
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -28,8 +29,19 @@ CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--with-x=${X11BASE} --disable-debug
-OPTIONS= XINE "Enable support for video playback using libxine" off
+OPTIONS= GSTREAMER "Enable support for video playback using gstreamer" off \
+ XINE "Enable support for video playback using libxine" off
+WANT_GNOME= gstreamerplugins
+
+###
+## Lib Detection
+###
+# gstreamer
+.if exists(${X11BASE}/lib/libgstplay-0.8.so)
+WITH_GSTREAMER=yes
+.endif
+# xine
.if exists(${X11BASE}/lib/libxine.so)
WITH_XINE=yes
.endif
@@ -47,10 +59,30 @@ post-patch:
.include <bsd.port.pre.mk>
+###
+## Internal Detection
+###
+# gstreamer
+.if ${HAVE_GNOME:Mgstreamerplugins}
+WITH_GSTREAMER=yes
+.endif
+
+###
+## Support Activation
+###
+# gstreamer
+.if defined(WITH_GSTREAMER)
+USE_GNOME+= gstreamerplugins
+
+PLIST_FILES+= bin/kgstplayer
+.else
+CONFIGURE_ARGS+= --without-gstreamer
+.endif
+# xine
.if defined(WITH_XINE)
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
-PLIST_FILES= bin/kxineplayer
+PLIST_FILES+= bin/kxineplayer
.endif
# GCC < 3.1