aboutsummaryrefslogtreecommitdiff
path: root/multimedia/linux-f10-libv4l
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/linux-f10-libv4l')
-rw-r--r--multimedia/linux-f10-libv4l/Makefile23
-rw-r--r--multimedia/linux-f10-libv4l/distinfo.i3864
-rw-r--r--multimedia/linux-f10-libv4l/pkg-descr17
-rw-r--r--multimedia/linux-f10-libv4l/pkg-plist14
4 files changed, 58 insertions, 0 deletions
diff --git a/multimedia/linux-f10-libv4l/Makefile b/multimedia/linux-f10-libv4l/Makefile
new file mode 100644
index 000000000000..a37b41b0422b
--- /dev/null
+++ b/multimedia/linux-f10-libv4l/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: multimedia/linux-f10-libv4l
+# Date created: 2011-04-14
+# Whom: emulation@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libv4l
+PORTVERSION= 0.6.2
+CATEGORIES= multimedia linux
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Collection of video4linux support libraries (Fedora 10)
+
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 10
+RPMVERSION= 1.fc10
+USE_LDCONFIG= yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/multimedia/linux-f10-libv4l/distinfo.i386 b/multimedia/linux-f10-libv4l/distinfo.i386
new file mode 100644
index 000000000000..94bdf9360e8e
--- /dev/null
+++ b/multimedia/linux-f10-libv4l/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/10/libv4l-0.6.2-1.fc10.i386.rpm) = dc314477f8e771cfe6b9f654d1779e3cd8033d7ca65359e41dc1085b4d98cfe9
+SIZE (rpm/i386/fedora/10/libv4l-0.6.2-1.fc10.i386.rpm) = 110211
+SHA256 (rpm/i386/fedora/10/libv4l-0.6.2-1.fc10.src.rpm) = 077fbc584d3cdf76db525f2173676f9cd22a63abcd9bcc1808a199ed5e9a1606
+SIZE (rpm/i386/fedora/10/libv4l-0.6.2-1.fc10.src.rpm) = 136113
diff --git a/multimedia/linux-f10-libv4l/pkg-descr b/multimedia/linux-f10-libv4l/pkg-descr
new file mode 100644
index 000000000000..2426783acae1
--- /dev/null
+++ b/multimedia/linux-f10-libv4l/pkg-descr
@@ -0,0 +1,17 @@
+libv4l is a collection of libraries which adds a thin abstraction layer on
+top of video4linux2 devices. The purpose of this (thin) layer is to make it
+easy for application writers to support a wide variety of devices without
+having to write separate code for different devices in the same class. libv4l
+consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.
+
+libv4lconvert offers functions to convert from any (known) pixel-format
+to V4l2_PIX_FMT_BGR24 or V4l2_PIX_FMT_YUV420.
+
+libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
+of the drivers for those devices supporting v4l1 compatibility (which many
+v4l2 drivers do not).
+
+libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
+application transparent libv4lconvert conversion where necessary.
+
+WWW: http://hansdegoede.livejournal.com/3636.html
diff --git a/multimedia/linux-f10-libv4l/pkg-plist b/multimedia/linux-f10-libv4l/pkg-plist
new file mode 100644
index 000000000000..96b7396af4cd
--- /dev/null
+++ b/multimedia/linux-f10-libv4l/pkg-plist
@@ -0,0 +1,14 @@
+@comment file listing
+usr/lib/libv4l/ov511-decomp
+usr/lib/libv4l/ov518-decomp
+usr/lib/libv4l/v4l1compat.so
+usr/lib/libv4l/v4l2convert.so
+usr/lib/libv4l1.so.0
+usr/lib/libv4l2.so.0
+usr/lib/libv4lconvert.so.0
+usr/share/doc/libv4l-%%PORTVERSION%%/COPYING.LIB
+usr/share/doc/libv4l-%%PORTVERSION%%/ChangeLog
+usr/share/doc/libv4l-%%PORTVERSION%%/README
+usr/share/doc/libv4l-%%PORTVERSION%%/TODO
+@dirrm usr/share/doc/libv4l-%%PORTVERSION%%
+@dirrm usr/lib/libv4l