aboutsummaryrefslogtreecommitdiff
path: root/multimedia/linux-realplayer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/linux-realplayer/Makefile')
-rw-r--r--multimedia/linux-realplayer/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index 0fd36f01175a..50c9e55a8813 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linux-realplayer
PORTVERSION= 10.0.4
+PORTREVISION= 1
CATEGORIES= multimedia audio linux
MASTER_SITES= https://helixcommunity.org/download.php/1145/
DISTNAME= RealPlayer-10.0.4.750-20050401.i586
@@ -21,13 +22,11 @@ RUN_DEPENDS= \
WRKSRC= ${WRKDIR}/usr/local/RealPlayer
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
RESTRICTED= "Redistribution not allowed"
NO_BUILD= yes
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
RADIR= ${PREFIX}/lib/RealPlayer
PLUGINSDIR= ${PREFIX}/lib/linux-mozilla/plugins
RABINDIR= ${PREFIX}/bin
@@ -73,6 +72,7 @@ do-install:
${MKDIR} ${RADIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${WRKSRC}/README ${RADIR}
${INSTALL_PROGRAM} ${WRKSRC}/realplay.bin ${RADIR}
+ ${BRANDELF} -t Linux ${RADIR}/realplay.bin
.for dir in codecs common lib plugins share/default share/realplay
${MKDIR} ${RADIR}/${dir}