aboutsummaryrefslogtreecommitdiff
path: root/multimedia/linux-realplayer
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/linux-realplayer')
-rw-r--r--multimedia/linux-realplayer/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index efc7383673cf..2733b14e0a7c 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux-realplayer
PORTVERSION= 8.cs2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio linux
MASTER_SITES= http://docs.real.com/docs/playerpatch/unix/:update
DISTFILES= ${MAINDIST} ${UPDATEDIST:S/$/:update/}
@@ -42,6 +42,7 @@ IGNORE= may not be automatically fetched due to licensing\
${DISTDIR} and then restart this build.
.endif
+USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= "Redistribution not allowed"
NO_BUILD= yes
@@ -49,6 +50,10 @@ NO_BUILD= yes
post-extract:
cd ${WRKDIR}; rpm2cpio ${DISTDIR}/${MAINDIST} | cpio -id --quiet
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s@/usr/lib@${PREFIX}/lib@" ${WRKSRC}/postinstall.sh
+
do-install:
${MKDIR} ${RADIR}
.for f in mimeinstall.sh pluginstall.sh postinstall.sh