aboutsummaryrefslogtreecommitdiff
path: root/multimedia/moonlight/files/patch-configure
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/moonlight/files/patch-configure')
-rw-r--r--multimedia/moonlight/files/patch-configure56
1 files changed, 34 insertions, 22 deletions
diff --git a/multimedia/moonlight/files/patch-configure b/multimedia/moonlight/files/patch-configure
index 84cdf9a97800..7eb717b40229 100644
--- a/multimedia/moonlight/files/patch-configure
+++ b/multimedia/moonlight/files/patch-configure
@@ -1,23 +1,35 @@
---- configure.orig 2009-01-13 19:53:23.000000000 +0000
-+++ configure 2009-02-24 17:52:38.000000000 +0000
-@@ -23676,6 +23676,9 @@
- *linux* )
- TARGET_PLATFORM="Linux"
- ;;
-+ *freebsd* )
-+ TARGET_PLATFORM="FreeBSD"
-+ ;;
- * )
- { { echo "$as_me:$LINENO: error: Target os $target_os is unknown.
- Please add the appropriate string to configure.ac.
-@@ -24223,6 +24226,10 @@
- OSTYPE=linux
- CODECS_OS_SUPPORTED="yes"
- ;;
-+ *freebsd*)
-+ OSTYPE=freebsd
-+ CODECS_OS_SUPPORTED="no"
-+ ;;
- esac
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -17940,6 +17940,10 @@
+ MOONLIGHT_CODEC_OSTYPE=linux
+ CODECS_OS_SUPPORTED="yes"
+ ;;
++ *-*-*freebsd*)
++ MOONLIGHT_CODEC_OSTYPE=freebsd
++ CODECS_OS_SUPPORTED="yes"
++ ;;
+ esac
- if test ${ARCH} = unknown; then
+ if test ${MOONLIGHT_CODEC_ARCH} = unknown; then
+@@ -20603,6 +20607,9 @@
+ *linux*)
+ TARGET_PLATFORM="Linux"
+ ;;
++ *freebsd*)
++ TARGET_PLATFORM="FreeBSD"
++ ;;
+ *)
+ { { $as_echo "$as_me:$LINENO: error: Target os $target_os is unknown.
+ Please add the appropriate string to configure.ac.
+@@ -20619,7 +20626,7 @@
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86-gcc3
+ INSTALL_ARCH=i586
+ ;;
+- x86_64)
++ x86_64|amd64)
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86_64-gcc3
+ INSTALL_ARCH=x86_64
+ ;;