aboutsummaryrefslogtreecommitdiff
path: root/multimedia/moonlight/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/moonlight/files')
-rw-r--r--multimedia/moonlight/files/patch-class_System.Windows_Mono_NativeDependencyObjectHelper.cs21
-rw-r--r--multimedia/moonlight/files/patch-configure56
-rw-r--r--multimedia/moonlight/files/patch-m4_codecs.m416
-rw-r--r--multimedia/moonlight/files/patch-m4_firefox-xpi.m424
-rw-r--r--multimedia/moonlight/files/patch-plugin_plugin.cpp13
-rw-r--r--multimedia/moonlight/files/patch-src_application.cpp23
-rw-r--r--multimedia/moonlight/files/patch-src_bitmapimage.cpp15
-rw-r--r--multimedia/moonlight/files/patch-src_deployment.cpp28
-rw-r--r--multimedia/moonlight/files/patch-src_easing.cpp15
-rw-r--r--multimedia/moonlight/files/patch-src_file-downloader.cpp15
-rw-r--r--multimedia/moonlight/files/patch-src_pipeline-ui.cpp14
-rw-r--r--multimedia/moonlight/files/patch-src_pipeline.cpp71
-rw-r--r--multimedia/moonlight/files/patch-src_utils.cpp15
13 files changed, 294 insertions, 32 deletions
diff --git a/multimedia/moonlight/files/patch-class_System.Windows_Mono_NativeDependencyObjectHelper.cs b/multimedia/moonlight/files/patch-class_System.Windows_Mono_NativeDependencyObjectHelper.cs
new file mode 100644
index 000000000000..5d782e4e47f5
--- /dev/null
+++ b/multimedia/moonlight/files/patch-class_System.Windows_Mono_NativeDependencyObjectHelper.cs
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- class/System.Windows/Mono/NativeDependencyObjectHelper.cs.orig
++++ class/System.Windows/Mono/NativeDependencyObjectHelper.cs
+@@ -177,7 +177,6 @@
+ throw new ExecutionEngineException ("multiple mappings registered for the same unmanaged peer");
+ #endif
+ Console.WriteLine ("multiple mappings registered for the same unmanaged peer 0x{0:x}, type = {1}", native, wrapper.GetType());
+- Console.WriteLine (Environment.StackTrace);
+ return false;
+ }
+
+@@ -229,7 +228,6 @@
+ INativeEventObjectWrapper wrapper = CreateObject (k, ptr) as INativeEventObjectWrapper;
+ if (wrapper == null){
+ Report.Warning ("System.Windows: Returning a null object, did not know how to construct {0}", k);
+- Report.Warning (Environment.StackTrace);
+ }
+
+ return wrapper;
diff --git a/multimedia/moonlight/files/patch-configure b/multimedia/moonlight/files/patch-configure
index 84cdf9a97800..7eb717b40229 100644
--- a/multimedia/moonlight/files/patch-configure
+++ b/multimedia/moonlight/files/patch-configure
@@ -1,23 +1,35 @@
---- configure.orig 2009-01-13 19:53:23.000000000 +0000
-+++ configure 2009-02-24 17:52:38.000000000 +0000
-@@ -23676,6 +23676,9 @@
- *linux* )
- TARGET_PLATFORM="Linux"
- ;;
-+ *freebsd* )
-+ TARGET_PLATFORM="FreeBSD"
-+ ;;
- * )
- { { echo "$as_me:$LINENO: error: Target os $target_os is unknown.
- Please add the appropriate string to configure.ac.
-@@ -24223,6 +24226,10 @@
- OSTYPE=linux
- CODECS_OS_SUPPORTED="yes"
- ;;
-+ *freebsd*)
-+ OSTYPE=freebsd
-+ CODECS_OS_SUPPORTED="no"
-+ ;;
- esac
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -17940,6 +17940,10 @@
+ MOONLIGHT_CODEC_OSTYPE=linux
+ CODECS_OS_SUPPORTED="yes"
+ ;;
++ *-*-*freebsd*)
++ MOONLIGHT_CODEC_OSTYPE=freebsd
++ CODECS_OS_SUPPORTED="yes"
++ ;;
+ esac
- if test ${ARCH} = unknown; then
+ if test ${MOONLIGHT_CODEC_ARCH} = unknown; then
+@@ -20603,6 +20607,9 @@
+ *linux*)
+ TARGET_PLATFORM="Linux"
+ ;;
++ *freebsd*)
++ TARGET_PLATFORM="FreeBSD"
++ ;;
+ *)
+ { { $as_echo "$as_me:$LINENO: error: Target os $target_os is unknown.
+ Please add the appropriate string to configure.ac.
+@@ -20619,7 +20626,7 @@
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86-gcc3
+ INSTALL_ARCH=i586
+ ;;
+- x86_64)
++ x86_64|amd64)
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86_64-gcc3
+ INSTALL_ARCH=x86_64
+ ;;
diff --git a/multimedia/moonlight/files/patch-m4_codecs.m4 b/multimedia/moonlight/files/patch-m4_codecs.m4
new file mode 100644
index 000000000000..43814be520a1
--- /dev/null
+++ b/multimedia/moonlight/files/patch-m4_codecs.m4
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- m4/codecs.m4.orig
++++ m4/codecs.m4
+@@ -25,6 +25,10 @@
+ MOONLIGHT_CODEC_OSTYPE=linux
+ CODECS_OS_SUPPORTED="yes"
+ ;;
++ *-*-*freebsd*)
++ MOONLIGHT_CODEC_OSTYPE=freebsd
++ CODECS_OS_SUPPORTED="yes"
++ ;;
+ esac
+
+ if test ${MOONLIGHT_CODEC_ARCH} = unknown; then
diff --git a/multimedia/moonlight/files/patch-m4_firefox-xpi.m4 b/multimedia/moonlight/files/patch-m4_firefox-xpi.m4
new file mode 100644
index 000000000000..688d3404d69f
--- /dev/null
+++ b/multimedia/moonlight/files/patch-m4_firefox-xpi.m4
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- m4/firefox-xpi.m4.orig
++++ m4/firefox-xpi.m4
+@@ -16,6 +16,9 @@
+ *linux*)
+ TARGET_PLATFORM="Linux"
+ ;;
++ *freebsd*)
++ TARGET_PLATFORM="FreeBSD"
++ ;;
+ *)
+ AC_MSG_ERROR([Target os $target_os is unknown.
+ Please add the appropriate string to configure.ac.
+@@ -28,7 +31,7 @@
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86-gcc3
+ INSTALL_ARCH=i586
+ ;;
+- x86_64)
++ x86_64|amd64)
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86_64-gcc3
+ INSTALL_ARCH=x86_64
+ ;;
diff --git a/multimedia/moonlight/files/patch-plugin_plugin.cpp b/multimedia/moonlight/files/patch-plugin_plugin.cpp
new file mode 100644
index 000000000000..bfde8c1b7c9a
--- /dev/null
+++ b/multimedia/moonlight/files/patch-plugin_plugin.cpp
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- plugin/plugin.cpp.orig
++++ plugin/plugin.cpp
+@@ -17,6 +17,7 @@
+ #include <fcntl.h>
+ #include <stdlib.h>
+ #include <dlfcn.h>
++#include <unistd.h>
+
+ #include "plugin.h"
+ #include "plugin-spinner.h"
diff --git a/multimedia/moonlight/files/patch-src_application.cpp b/multimedia/moonlight/files/patch-src_application.cpp
new file mode 100644
index 000000000000..33e57fa6525a
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_application.cpp
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- src/application.cpp.orig
++++ src/application.cpp
+@@ -17,6 +17,10 @@
+ #include <fcntl.h>
+ #include <errno.h>
+
++#ifdef __FreeBSD__
++#include <unistd.h>
++#endif
++
+ #include "application.h"
+ #include "runtime.h"
+ #include "deployment.h"
+@@ -369,4 +373,4 @@
+ Deployment::GetCurrent()->TrackPath (resource_root);
+ }
+ return resource_root;
+-}
+\ No newline at end of file
++}
diff --git a/multimedia/moonlight/files/patch-src_bitmapimage.cpp b/multimedia/moonlight/files/patch-src_bitmapimage.cpp
new file mode 100644
index 000000000000..9bc492336d76
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_bitmapimage.cpp
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- src/bitmapimage.cpp.orig
++++ src/bitmapimage.cpp
+@@ -16,6 +16,9 @@
+ #include <glib/gstdio.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#ifdef __FreeBSD__
++#include <unistd.h>
++#endif
+
+ #include "application.h"
+ #include "bitmapimage.h"
diff --git a/multimedia/moonlight/files/patch-src_deployment.cpp b/multimedia/moonlight/files/patch-src_deployment.cpp
new file mode 100644
index 000000000000..ebd10a84bbb1
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_deployment.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- src/deployment.cpp.orig
++++ src/deployment.cpp
+@@ -237,8 +237,8 @@
+ }
+
+ if (mismatch) {
+- LOG_DEPLOYMENT ("Deployment::GetCurrent (): Domain mismatch, thread %u, (tls) deployment: %p, deployment->domain: %p, (mono_domain_get) current_domain: %p, root_domain: %p, hash deployment: %p\n",
+- (int) pthread_self (), deployment, deployment->domain, current_domain, root_domain, g_hash_table_lookup (current_hash, current_domain));
++ LOG_DEPLOYMENT ("Deployment::GetCurrent (): Domain mismatch, thread %li, (tls) deployment: %p, deployment->domain: %p, (mono_domain_get) current_domain: %p, root_domain: %p, hash deployment: %p\n",
++ (long) pthread_self (), deployment, deployment->domain, current_domain, root_domain, g_hash_table_lookup (current_hash, current_domain));
+ pthread_mutex_lock (&hash_mutex);
+ deployment = (Deployment *) g_hash_table_lookup (current_hash, current_domain);
+ pthread_mutex_unlock (&hash_mutex);
+@@ -270,9 +270,9 @@
+ {
+ #if DEBUG
+ if (deployment && mono_domain_get () != deployment->domain) {
+- LOG_DEPLOYMENT ("Deployment::SetCurrent (%p), thread: %i domain mismatch, is: %p\n", deployment, (int) pthread_self (), mono_domain_get ());
++ LOG_DEPLOYMENT ("Deployment::SetCurrent (%p), thread: %li domain mismatch, is: %p\n", deployment, (long) pthread_self (), mono_domain_get ());
+ } else if (pthread_getspecific (tls_key) != deployment) {
+- LOG_DEPLOYMENT ("Deployment::SetCurrent (%p), thread: %i deployment mismatch, is: %p\n", deployment, (int) pthread_self (), pthread_getspecific (tls_key));
++ LOG_DEPLOYMENT ("Deployment::SetCurrent (%p), thread: %li deployment mismatch, is: %p\n", deployment, (long) pthread_self (), pthread_getspecific (tls_key));
+ }
+ #endif
+
diff --git a/multimedia/moonlight/files/patch-src_easing.cpp b/multimedia/moonlight/files/patch-src_easing.cpp
new file mode 100644
index 000000000000..49974c3cac5c
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_easing.cpp
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- src/easing.cpp.orig
++++ src/easing.cpp
+@@ -16,7 +16,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+ #include <math.h>
+
+ #include <runtime.h>
diff --git a/multimedia/moonlight/files/patch-src_file-downloader.cpp b/multimedia/moonlight/files/patch-src_file-downloader.cpp
new file mode 100644
index 000000000000..2420a5b21c5f
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_file-downloader.cpp
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- src/file-downloader.cpp.orig
++++ src/file-downloader.cpp
+@@ -17,6 +17,9 @@
+ #include <glib/gstdio.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#ifdef __FreeBSD__
++#include <unistd.h>
++#endif
+
+ #include "file-downloader.h"
+ #include "zip/unzip.h"
diff --git a/multimedia/moonlight/files/patch-src_pipeline-ui.cpp b/multimedia/moonlight/files/patch-src_pipeline-ui.cpp
new file mode 100644
index 000000000000..79fc0b72705c
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_pipeline-ui.cpp
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/pipeline-ui.cpp.orig
++++ src/pipeline-ui.cpp
+@@ -310,7 +310,7 @@
+ if (env_url != NULL)
+ dl->Open ("GET", env_url, NoPolicy);
+ else
+- dl->Open ("GET", CODEC_URL, NoPolicy);
++ dl->Open ("GET", "", NoPolicy);
+
+ dl->Send ();
+
diff --git a/multimedia/moonlight/files/patch-src_pipeline.cpp b/multimedia/moonlight/files/patch-src_pipeline.cpp
index 42eb6251558d..205ce11f56e7 100644
--- a/multimedia/moonlight/files/patch-src_pipeline.cpp
+++ b/multimedia/moonlight/files/patch-src_pipeline.cpp
@@ -1,10 +1,61 @@
---- src/pipeline.cpp.orig 2009-02-12 20:44:18.000000000 +0000
-+++ src/pipeline.cpp 2009-02-12 20:44:30.000000000 +0000
-@@ -15,6 +15,7 @@
- #include <config.h>
- #include <stdio.h>
- #include <sys/types.h>
-+#include <sys/stat.h>
- #include <unistd.h>
- #include <fcntl.h>
- #include <errno.h>
+
+$FreeBSD$
+
+--- src/pipeline.cpp.orig
++++ src/pipeline.cpp
+@@ -40,6 +40,23 @@
+ #include "deployment.h"
+ #include "timesource.h"
+
++#ifdef __FreeBSD__
++int
++sigisemptyset(sigset_t *set)
++{
++ sigset_t empty;
++ int ret = sigemptyset (&empty);
++ if (ret == 0) {
++ if (0 == memcmp (&empty, set, sizeof (sigset_t)))
++ ret = 1;
++ else
++ ret = 0;
++ }
++
++ return ret;
++}
++#endif
++
+ /*
+ * Media
+ */
+@@ -2260,7 +2277,7 @@
+ }
+ pthread_mutex_unlock (&mutex);
+
+- LOG_PIPELINE ("MediaThreadPool::WorkerLoop () %u: Started thread with index %i.\n", (int) pthread_self (), self_index);
++ LOG_PIPELINE ("MediaThreadPool::WorkerLoop () %lu: Started thread with index %i.\n", (long) pthread_self (), self_index);
+
+ g_return_val_if_fail (self_index >= 0, NULL);
+
+@@ -2316,11 +2333,11 @@
+
+ media->SetCurrentDeployment (true, true);
+
+- LOG_FRAMEREADERLOOP ("MediaThreadLoop::WorkerLoop () %u: got %s %p for media %p on deployment %p, there are %d nodes left.\n", (int) pthread_self (), node->closure->GetDescription (), node, media, media->GetDeployment (), queue ? queue->Length () : -1);
++ LOG_FRAMEREADERLOOP ("MediaThreadLoop::WorkerLoop () %lu: got %s %p for media %p on deployment %p, there are %d nodes left.\n", (long) pthread_self (), node->closure->GetDescription (), node, media, media->GetDeployment (), queue ? queue->Length () : -1);
+
+ node->closure->Call ();
+
+- LOG_FRAMEREADERLOOP ("MediaThreadLoop::WorkerLoop () %u: processed node %p\n", (int) pthread_self (), node);
++ LOG_FRAMEREADERLOOP ("MediaThreadLoop::WorkerLoop () %lu: processed node %p\n", (long) pthread_self (), node);
+
+ delete node;
+ }
+@@ -2333,7 +2350,7 @@
+ pthread_cond_signal (&completed_condition);
+ pthread_mutex_unlock (&mutex);
+
+- LOG_PIPELINE ("MediaThreadPool::WorkerLoop () %u: Exited (index: %i).\n", (int) pthread_self (), self_index);
++ LOG_PIPELINE ("MediaThreadPool::WorkerLoop () %lu: Exited (index: %i).\n", (long) pthread_self (), self_index);
+
+ return NULL;
+ }
diff --git a/multimedia/moonlight/files/patch-src_utils.cpp b/multimedia/moonlight/files/patch-src_utils.cpp
new file mode 100644
index 000000000000..d363fd459082
--- /dev/null
+++ b/multimedia/moonlight/files/patch-src_utils.cpp
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- src/utils.cpp.orig
++++ src/utils.cpp
+@@ -16,6 +16,9 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#ifdef __FreeBSD__
++#include <unistd.h>
++#endif
+
+ #include "utils.h"
+ #include "application.h"