aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogle-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ogle-gui/Makefile')
-rw-r--r--multimedia/ogle-gui/Makefile35
1 files changed, 19 insertions, 16 deletions
diff --git a/multimedia/ogle-gui/Makefile b/multimedia/ogle-gui/Makefile
index 1c173b9fc609..d0ea715a6532 100644
--- a/multimedia/ogle-gui/Makefile
+++ b/multimedia/ogle-gui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ogle
-PORTVERSION= 0.7.5
+PORTVERSION= 0.8.2
CATEGORIES= graphics gnome
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
PKGNAMESUFFIX= -gui
@@ -14,34 +14,37 @@ DISTNAME= ${PORTNAME}_gui-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.4:${PORTSDIR}/graphics/ogle
+BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.5:${PORTSDIR}/graphics/ogle
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ giconv.2:${PORTSDIR}/converters/libiconv \
+ glade.4:${PORTSDIR}/devel/libglade \
+ xml2.5:${PORTSDIR}/textproc/libxml2
RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
USE_GTK= yes
USE_XPM= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-dvd-includes=${LOCALBASE}/include \
--with-dvdcontrol=${LOCALBASE} \
- --without-included-gettext
+ --without-included-gettext \
+ --with-gtk-prefix=${X11BASE} \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-libglade-config=${X11BASE}/bin/libglade-config \
+ --with-xml-prefix=${LOCALBASE}
post-patch:
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
- @${PERL} -pi -e "s/aclocal/${ACLOCAL}/;s/autoconf/${AUTOCONF}/; \
- s/autoheader/${AUTOHEADER}/" \
- ${CONFIGURE_WRKSRC}/aclocal.m4
+ @${PERL} -pi -e "s|(libglade\.so)\.0|\1.4|; \
+ s|(PACKAGE_PIXMAPS_DIR=\"$${prefix}/share/)(ogle_gui/\")|\1gnome/\2|; \
+ s!(CONFIG_FILE(\s|=)\")[^/]+?/!\1${LOCALBASE}/!; \
+ s|(CONFIG_FILE_DTD=\")[^/]+?/|\1${LOCALBASE}/|g; \
+ s|(PACKAGE_PIXMAPS_DIR=\").+\"|\1${PREFIX}/share/gnome/ogle_gui/\"|; \
+ s|%%LOCALBASE%%|${LOCALBASE}|" \
+ ${CONFIGURE_WRKSRC}/configure
-pre-configure:
- @${TOUCH} `find -E ${WRKSRC} -regex ".*Makefile\.(am|in)"`
-.for file in intl/Makefile.in po/Makefile.in.in
- @${ECHO} 'all:' > ${WRKSRC}/${file}
- @${ECHO} 'install:' >> ${WRKSRC}/${file}
-.endfor
+post-configure:
+ @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
.include <bsd.port.mk>