aboutsummaryrefslogtreecommitdiff
path: root/multimedia/smpeg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/smpeg/Makefile')
-rw-r--r--multimedia/smpeg/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index 076823110601..f566805f6661 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smpeg
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.lokigames.com/pub/open-source/smpeg/ \
ftp://sunsite.auc.dk/pub/os/linux/loki/open-source/smpeg/ \
@@ -22,7 +22,7 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
USE_GTK= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
@@ -35,4 +35,8 @@ CONFIGURE_ARGS= --disable-opengl-player \
MAN1= gtv.1 plaympeg.1
+post-configure:
+ @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
.include <bsd.port.mk>