aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem-pl-parser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/totem-pl-parser/Makefile')
-rw-r--r--multimedia/totem-pl-parser/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/multimedia/totem-pl-parser/Makefile b/multimedia/totem-pl-parser/Makefile
new file mode 100644
index 000000000000..9368540d1cf2
--- /dev/null
+++ b/multimedia/totem-pl-parser/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: totem-pl-parser
+# Date created: 2007-12-04
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/multimedia/totem-pl-parser/Makefile,v 1.8 2008/03/10 15:04:41 ahze Exp $
+#
+
+PORTNAME= totem-pl-parser
+PORTVERSION= 2.22.1
+CATEGORIES= multimedia gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GObject-based library to parse a host of playlist formats
+
+LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix gnomevfs2 intlhack evolutiondataserver \
+ ltverhack
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>