aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile35
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-browser-plugin_Makefile.in100
-rw-r--r--multimedia/totem/files/patch-configure29
-rw-r--r--multimedia/totem/pkg-plist143
5 files changed, 231 insertions, 82 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 6cc85fbada58..564c2e8c4269 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -3,11 +3,11 @@
# Whom: Hendrik Scholz <hendrik@scholz.net>
#
# $FreeBSD$
-# $MCom: ports/multimedia/totem/Makefile,v 1.77 2007/03/11 05:25:07 mezz Exp $
+# $MCom: ports/multimedia/totem/Makefile,v 1.89 2007/10/17 17:22:32 mezz Exp $
#
PORTNAME= totem
-PORTVERSION= 2.18.2
+PORTVERSION= 2.20.1
PORTREVISION?= 0
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
@@ -25,7 +25,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_XLIB= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
- nautiluscdburner ltverhack
+ nautiluscdburner ltverhack gnomecontrolcenter2
GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
INSTALLS_ICONS= yes
@@ -34,16 +34,38 @@ USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
INSTALLS_OMF= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXrandr"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lXrandr"
+CONFIGURE_ARGS= --with-plugins="${TOTEM_PLUGINS}"
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
CONFLICTS?= totem-gstreamer-[0-9]* totem-xine-[0-9]*
+OPTIONS= LIRC "Enable lirc support" off \
+ GALAGO "Enable Galago support" off
+
+TOTEM_PLUGINS= screensaver ontop gromit media-player-keys properties sidebar-test skipto
+
.include <bsd.port.pre.mk>
+.if defined(WITH_LIRC)
+LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
+PLIST_SUB+= LIRC=""
+TOTEM_PLUGINS:= ${TOTEM_PLUGINS} lirc
+.else
+PLIST_SUB+= LIRC="@comment "
+.endif
+
+.if defined(WITH_GALAGO)
+LIB_DEPENDS+= galago.3:${PORTSDIR}/devel/libgalago
+PLIST_SUB+= GALAGO=""
+TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
+.else
+PLIST_SUB+= GALAGO="@comment "
+.endif
+
.if defined(WITH_MOZILLA_PLUGIN) && ${SLAVE_PORT:L}=="yes"
USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
@@ -102,5 +124,8 @@ post-patch:
post-install:
@-update-desktop-database
+ ${MKDIR} ${PREFIX}/share/vala/vapi
+ ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vala ${PREFIX}/share/vala/vapi
+ ${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.deps ${PREFIX}/share/vala/vapi
.include <bsd.port.post.mk>
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index 5760d7220df2..62e019125a40 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-2.18.2.tar.bz2) = a77ca6f0c56b2fc6ececd8158bb0cdca
-SHA256 (gnome2/totem-2.18.2.tar.bz2) = ee310ae84cd8607548f25e802415262e247cb242bbe33c050fde34ce9a4cc2de
-SIZE (gnome2/totem-2.18.2.tar.bz2) = 2076779
+MD5 (gnome2/totem-2.20.1.tar.bz2) = 6627727e7abd7a7f95257be8df6359a6
+SHA256 (gnome2/totem-2.20.1.tar.bz2) = 59bd1fcbc723d32a678eeacf200394da4d8ae16dcd8ab36352659b55c29d04f5
+SIZE (gnome2/totem-2.20.1.tar.bz2) = 2196437
diff --git a/multimedia/totem/files/patch-browser-plugin_Makefile.in b/multimedia/totem/files/patch-browser-plugin_Makefile.in
index 2dd84be05bc8..df0d82b25039 100644
--- a/multimedia/totem/files/patch-browser-plugin_Makefile.in
+++ b/multimedia/totem/files/patch-browser-plugin_Makefile.in
@@ -1,110 +1,124 @@
---- browser-plugin/Makefile.in.orig Fri Mar 2 07:22:29 2007
-+++ browser-plugin/Makefile.in Fri Mar 2 07:24:05 2007
-@@ -72,7 +72,7 @@
+--- browser-plugin/Makefile.in.orig 2007-09-16 18:59:35.000000000 -0400
++++ browser-plugin/Makefile.in 2007-09-16 19:00:59.000000000 -0400
+@@ -69,7 +69,7 @@
pluginLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(noinst_LTLIBRARIES) $(plugin_LTLIBRARIES)
am__DEPENDENCIES_1 =
-@ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_DEPENDENCIES = \
- @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_BASIC_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
@ENABLE_BASIC_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -88,7 +88,7 @@
- $(am_libtotem_basic_plugin_la_OBJECTS)
+@@ -89,7 +89,7 @@
+ $(libtotem_basic_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
@ENABLE_BASIC_PLUGIN_TRUE@am_libtotem_basic_plugin_la_rpath = -rpath \
@ENABLE_BASIC_PLUGIN_TRUE@ $(plugindir)
-@ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_DEPENDENCIES = \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_COMPLEX_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
@ENABLE_COMPLEX_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -104,7 +104,7 @@
- $(am_libtotem_complex_plugin_la_OBJECTS)
+@@ -109,7 +109,7 @@
+ $(libtotem_complex_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
@ENABLE_COMPLEX_PLUGIN_TRUE@am_libtotem_complex_plugin_la_rpath = \
@ENABLE_COMPLEX_PLUGIN_TRUE@ -rpath $(plugindir)
-@ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_DEPENDENCIES = \
- @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_GMP_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
@ENABLE_GMP_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -124,7 +124,7 @@
- libtotem_gmp_plugin_la_OBJECTS = $(am_libtotem_gmp_plugin_la_OBJECTS)
+@@ -133,7 +133,7 @@
+ $(libtotem_gmp_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
@ENABLE_GMP_PLUGIN_TRUE@am_libtotem_gmp_plugin_la_rpath = -rpath \
@ENABLE_GMP_PLUGIN_TRUE@ $(plugindir)
-@ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_DEPENDENCIES = \
- @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_MULLY_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
@ENABLE_MULLY_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -140,7 +140,7 @@
- $(am_libtotem_mully_plugin_la_OBJECTS)
+@@ -153,7 +153,7 @@
+ $(libtotem_mully_plugin_la_LDFLAGS) $(LDFLAGS) -o $@
@ENABLE_MULLY_PLUGIN_TRUE@am_libtotem_mully_plugin_la_rpath = -rpath \
@ENABLE_MULLY_PLUGIN_TRUE@ $(plugindir)
-@ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_DEPENDENCIES = $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_DEPENDENCIES = \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(am__DEPENDENCIES_1) \
@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(am__DEPENDENCIES_1)
-@@ -360,7 +360,7 @@
+@@ -198,10 +198,6 @@
+ totem_plugin_viewer-totem-plugin-viewer.$(OBJEXT)
+ totem_plugin_viewer_OBJECTS = $(am_totem_plugin_viewer_OBJECTS)
+ totem_plugin_viewer_DEPENDENCIES = \
+- $(top_builddir)/src/backend/libbaconvideowidget.la \
+- $(top_builddir)/src/libtotem_player.la \
+- $(top_builddir)/src/plparse/libtotem-plparser.la \
+- $(top_builddir)/lib/libtotemscrsaver.la \
+ libtotempluginviewer_helper.la $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+@@ -381,7 +377,7 @@
MOZILLA_LIBDIR = @MOZILLA_LIBDIR@
MOZILLA_NOT_LINKED_CFLAGS = @MOZILLA_NOT_LINKED_CFLAGS@
MOZILLA_NOT_LINKED_LIBS = @MOZILLA_NOT_LINKED_LIBS@
-MOZILLA_PLUGINDIR = @MOZILLA_PLUGINDIR@
-+MOZILLA_PLUGINDIR = /var/tmp/totem/lib/browser_plugins
++MOZILLA_PLUGINDIR = $(libdir)/browser_plugins
MOZILLA_PREFIX = @MOZILLA_PREFIX@
MOZILLA_XPCOM_CFLAGS = @MOZILLA_XPCOM_CFLAGS@
MOZILLA_XPIDL = @MOZILLA_XPIDL@
-@@ -464,7 +464,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- SUBDIRS = idl
--plugindir = $(libdir)/mozilla/plugins
-+plugindir = $(libdir)/browser_plugins
- plugin_LTLIBRARIES = $(am__append_1) $(am__append_2) $(am__append_3) \
- $(am__append_4) $(am__append_5)
- BUILT_SOURCES = $(libtotempluginviewer_marshal_la_SOURCES) \
-@@ -581,7 +581,7 @@
+@@ -599,10 +595,7 @@
+ $(AM_CFLAGS)
+
+ totem_plugin_viewer_LDADD = \
+- $(top_builddir)/src/backend/libbaconvideowidget.la \
+- $(top_builddir)/src/libtotem_player.la \
+- $(top_builddir)/src/plparse/libtotem-plparser.la \
+- $(top_builddir)/lib/libtotemscrsaver.la \
++ -ltotem-plparser \
+ libtotempluginviewer_helper.la \
+ $(EXTRA_GNOME_LIBS) \
+ $(XVIDMODE_LIBS) \
+@@ -654,7 +647,7 @@
@ENABLE_BASIC_PLUGIN_TRUE@ $(AM_CXXFLAGS)
@ENABLE_BASIC_PLUGIN_TRUE@libtotem_basic_plugin_la_LIBADD = \
-@ENABLE_BASIC_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_BASIC_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_BASIC_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_BASIC_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_BASIC_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -641,7 +641,7 @@
+ @ENABLE_BASIC_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
+@@ -715,7 +708,7 @@
@ENABLE_GMP_PLUGIN_TRUE@ $(AM_CXXFLAGS)
@ENABLE_GMP_PLUGIN_TRUE@libtotem_gmp_plugin_la_LIBADD = \
-@ENABLE_GMP_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_GMP_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_GMP_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_GMP_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_GMP_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -695,7 +695,7 @@
+ @ENABLE_GMP_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
+@@ -770,7 +763,7 @@
@ENABLE_COMPLEX_PLUGIN_TRUE@ $(AM_CXXFLAGS)
@ENABLE_COMPLEX_PLUGIN_TRUE@libtotem_complex_plugin_la_LIBADD = \
-@ENABLE_COMPLEX_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
-+@ENABLE_COMPLEX_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
++@ENABLE_COMPLEX_PLUGIN_TRUE@ -ltotem-plparser
+ @ENABLE_COMPLEX_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_COMPLEX_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_COMPLEX_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -749,7 +749,7 @@
+ @ENABLE_COMPLEX_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
+@@ -825,7 +818,7 @@
@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(AM_CXXFLAGS)
@ENABLE_NARROWSPACE_PLUGIN_TRUE@libtotem_narrowspace_plugin_la_LIBADD = \
-@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_NARROWSPACE_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_NARROWSPACE_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
-@@ -803,7 +803,7 @@
+ @ENABLE_NARROWSPACE_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
+@@ -880,7 +873,7 @@
@ENABLE_MULLY_PLUGIN_TRUE@ $(AM_CXXFLAGS)
@ENABLE_MULLY_PLUGIN_TRUE@libtotem_mully_plugin_la_LIBADD = \
-@ENABLE_MULLY_PLUGIN_TRUE@ $(top_builddir)/src/plparse/libtotem-plparser-mini.la \
+@ENABLE_MULLY_PLUGIN_TRUE@ -ltotem-plparser \
- @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_marshal.la \
+ @ENABLE_MULLY_PLUGIN_TRUE@ libtotempluginviewer_helper.la \
@ENABLE_MULLY_PLUGIN_TRUE@ $(DBUS_LIBS) \
- @ENABLE_MULLY_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
+ @ENABLE_MULLY_PLUGIN_TRUE@ $(MOZILLA_LIBS) \
diff --git a/multimedia/totem/files/patch-configure b/multimedia/totem/files/patch-configure
new file mode 100644
index 000000000000..1fab81f6ed98
--- /dev/null
+++ b/multimedia/totem/files/patch-configure
@@ -0,0 +1,29 @@
+--- configure.orig Fri May 25 00:24:10 2007
++++ configure Fri May 25 00:24:23 2007
+@@ -22960,7 +22960,7 @@ GTK_LIBS="$GTK_LIBS $EXTRA_BACKEND_LIBS"
+
+ plugin_error_or_ignore()
+ {
+- if test "${error_on_bad_plugin}" == "1" ; then
++ if test "${error_on_bad_plugin}" = "1" ; then
+ { { echo "$as_me:$LINENO: error: $1" >&5
+ echo "$as_me: error: $1" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -22982,7 +22982,7 @@ fi
+ used_plugins=""
+ used_plugins2=""
+
+-if test "x${with_plugins}" == "xautodetect" ; then
++if test "x${with_plugins}" = "xautodetect" ; then
+ # Default to all plugins and just ignore them if they won't compile
+ with_plugins="all"
+ error_on_bad_plugin="0"
+@@ -23384,7 +23384,7 @@ fi
+ esac
+
+ # Add the specified plugin
+- if test "${add_plugin}" == "1" ; then
++ if test "${add_plugin}" = "1" ; then
+ used_plugins2="${used_plugins2} ${plugin}"
+ fi
+ done
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 0652746dc89b..4124fd04a080 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -8,12 +8,45 @@ include/totem/1/plparser/totem-pl-parser.h
lib/libtotem-plparser.a
lib/libtotem-plparser.la
lib/libtotem-plparser.so
-lib/libtotem-plparser.so.1
+lib/libtotem-plparser.so.7
lib/nautilus/extensions-1.0/libtotem-properties-page.a
lib/nautilus/extensions-1.0/libtotem-properties-page.la
lib/nautilus/extensions-1.0/libtotem-properties-page.so
+%%GALAGO%%lib/totem/plugins/galago/galago.totem-plugin
+%%GALAGO%%lib/totem/plugins/galago/libtgp.a
+%%GALAGO%%lib/totem/plugins/galago/libtgp.la
+%%GALAGO%%lib/totem/plugins/galago/libtgp.so
+lib/totem/plugins/gromit/gromit.totem-plugin
+lib/totem/plugins/gromit/libgromit.a
+lib/totem/plugins/gromit/libgromit.la
+lib/totem/plugins/gromit/libgromit.so
+%%LIRC%%lib/totem/plugins/lirc/lirc.totem-plugin
+%%LIRC%%lib/totem/plugins/lirc/liblirc.a
+%%LIRC%%lib/totem/plugins/lirc/liblirc.la
+%%LIRC%%lib/totem/plugins/lirc/liblirc.so
+lib/totem/plugins/media-player-keys/libmedia_player_keys.a
+lib/totem/plugins/media-player-keys/libmedia_player_keys.la
+lib/totem/plugins/media-player-keys/libmedia_player_keys.so
+lib/totem/plugins/media-player-keys/media-player-keys.totem-plugin
+lib/totem/plugins/ontop/libontop.a
+lib/totem/plugins/ontop/libontop.la
+lib/totem/plugins/ontop/libontop.so
+lib/totem/plugins/ontop/ontop.totem-plugin
+lib/totem/plugins/properties/libmovie-properties.a
+lib/totem/plugins/properties/libmovie-properties.la
+lib/totem/plugins/properties/libmovie-properties.so
+lib/totem/plugins/properties/movie-properties.totem-plugin
+lib/totem/plugins/screensaver/libscreensaver.a
+lib/totem/plugins/screensaver/libscreensaver.la
+lib/totem/plugins/screensaver/libscreensaver.so
+lib/totem/plugins/screensaver/screensaver.totem-plugin
+lib/totem/plugins/skipto/libskipto.a
+lib/totem/plugins/skipto/libskipto.la
+lib/totem/plugins/skipto/libskipto.so
+lib/totem/plugins/skipto/skipto.totem-plugin
+lib/totem/plugins/skipto/skipto.ui
libdata/pkgconfig/totem-plparser.pc
-share/gnome/applications/totem.desktop
+share/applications/totem.desktop
share/gnome/help/totem/C/figures/totem_next_button.png
share/gnome/help/totem/C/figures/totem_pause_button.png
share/gnome/help/totem/C/figures/totem_play_button.png
@@ -27,6 +60,15 @@ share/gnome/help/totem/C/totem.xml
share/gnome/help/totem/bg/figures/totem_start_window.png
share/gnome/help/totem/bg/legal.xml
share/gnome/help/totem/bg/totem.xml
+share/gnome/help/totem/ca/figures/totem_next_button.png
+share/gnome/help/totem/ca/figures/totem_pause_button.png
+share/gnome/help/totem/ca/figures/totem_play_button.png
+share/gnome/help/totem/ca/figures/totem_previous_button.png
+share/gnome/help/totem/ca/figures/totem_show_playlist_button.png
+share/gnome/help/totem/ca/figures/totem_start_window.png
+share/gnome/help/totem/ca/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/ca/figures/totem_volume_mute_button.png
+share/gnome/help/totem/ca/totem.xml
share/gnome/help/totem/de/figures/totem_next_button.png
share/gnome/help/totem/de/figures/totem_pause_button.png
share/gnome/help/totem/de/figures/totem_play_button.png
@@ -36,6 +78,15 @@ share/gnome/help/totem/de/figures/totem_start_window.png
share/gnome/help/totem/de/figures/totem_volume_maximum_button.png
share/gnome/help/totem/de/figures/totem_volume_mute_button.png
share/gnome/help/totem/de/totem.xml
+share/gnome/help/totem/en_GB/figures/totem_next_button.png
+share/gnome/help/totem/en_GB/figures/totem_pause_button.png
+share/gnome/help/totem/en_GB/figures/totem_play_button.png
+share/gnome/help/totem/en_GB/figures/totem_previous_button.png
+share/gnome/help/totem/en_GB/figures/totem_show_playlist_button.png
+share/gnome/help/totem/en_GB/figures/totem_start_window.png
+share/gnome/help/totem/en_GB/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/en_GB/figures/totem_volume_mute_button.png
+share/gnome/help/totem/en_GB/totem.xml
share/gnome/help/totem/es/figures/totem_next_button.png
share/gnome/help/totem/es/figures/totem_pause_button.png
share/gnome/help/totem/es/figures/totem_play_button.png
@@ -54,6 +105,15 @@ share/gnome/help/totem/fr/figures/totem_start_window.png
share/gnome/help/totem/fr/figures/totem_volume_maximum_button.png
share/gnome/help/totem/fr/figures/totem_volume_mute_button.png
share/gnome/help/totem/fr/totem.xml
+share/gnome/help/totem/oc/figures/totem_next_button.png
+share/gnome/help/totem/oc/figures/totem_pause_button.png
+share/gnome/help/totem/oc/figures/totem_play_button.png
+share/gnome/help/totem/oc/figures/totem_previous_button.png
+share/gnome/help/totem/oc/figures/totem_show_playlist_button.png
+share/gnome/help/totem/oc/figures/totem_start_window.png
+share/gnome/help/totem/oc/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/oc/figures/totem_volume_mute_button.png
+share/gnome/help/totem/oc/totem.xml
share/gnome/help/totem/pa/figures/totem_next_button.png
share/gnome/help/totem/pa/figures/totem_pause_button.png
share/gnome/help/totem/pa/figures/totem_play_button.png
@@ -99,33 +159,6 @@ share/gnome/help/totem/uk/figures/totem_start_window.png
share/gnome/help/totem/uk/figures/totem_volume_maximum_button.png
share/gnome/help/totem/uk/figures/totem_volume_mute_button.png
share/gnome/help/totem/uk/totem.xml
-share/gnome/omf/totem/totem-C.omf
-share/gnome/omf/totem/totem-bg.omf
-share/gnome/omf/totem/totem-de.omf
-share/gnome/omf/totem/totem-es.omf
-share/gnome/omf/totem/totem-fr.omf
-share/gnome/omf/totem/totem-pa.omf
-share/gnome/omf/totem/totem-pt_BR.omf
-share/gnome/omf/totem/totem-ru.omf
-share/gnome/omf/totem/totem-sv.omf
-share/gnome/omf/totem/totem-uk.omf
-share/gnome/pixmaps/vanity.png
-share/gnome/totem/filmholes-big-left.png
-share/gnome/totem/filmholes-big-right.png
-share/gnome/totem/filmholes.png
-share/gnome/totem/mozilla-viewer.glade
-share/gnome/totem/playlist-ui.xml
-share/gnome/totem/playlist.glade
-share/gnome/totem/properties.glade
-share/gnome/totem/screenshot.glade
-share/gnome/totem/skip_to.glade
-share/gnome/totem/stock-tool-brightness-contrast-22.png
-share/gnome/totem/totem-ui.xml
-share/gnome/totem/totem.glade
-share/gnome/totem/totem_logo.png
-share/gnome/totem/uri.glade
-share/gnome/totem/vanity.glade
-share/gnome/totem/vanity.png
share/icons/hicolor/16x16/apps/totem.png
share/icons/hicolor/22x22/apps/totem.png
share/icons/hicolor/24x24/apps/totem.png
@@ -180,6 +213,7 @@ share/locale/nb/LC_MESSAGES/totem.mo
share/locale/ne/LC_MESSAGES/totem.mo
share/locale/nl/LC_MESSAGES/totem.mo
share/locale/nn/LC_MESSAGES/totem.mo
+share/locale/oc/LC_MESSAGES/totem.mo
share/locale/or/LC_MESSAGES/totem.mo
share/locale/pa/LC_MESSAGES/totem.mo
share/locale/pl/LC_MESSAGES/totem.mo
@@ -206,8 +240,36 @@ share/locale/xh/LC_MESSAGES/totem.mo
share/locale/zh_CN/LC_MESSAGES/totem.mo
share/locale/zh_HK/LC_MESSAGES/totem.mo
share/locale/zh_TW/LC_MESSAGES/totem.mo
-@dirrm share/gnome/totem
-@dirrm share/gnome/omf/totem
+share/omf/totem/totem-C.omf
+share/omf/totem/totem-bg.omf
+share/omf/totem/totem-ca.omf
+share/omf/totem/totem-de.omf
+share/omf/totem/totem-en_GB.omf
+share/omf/totem/totem-es.omf
+share/omf/totem/totem-fr.omf
+share/omf/totem/totem-oc.omf
+share/omf/totem/totem-pa.omf
+share/omf/totem/totem-pt_BR.omf
+share/omf/totem/totem-ru.omf
+share/omf/totem/totem-sv.omf
+share/omf/totem/totem-uk.omf
+%%DATADIR%%/filmholes-big-left.png
+%%DATADIR%%/filmholes-big-right.png
+%%DATADIR%%/filmholes.png
+%%DATADIR%%/fullscreen.ui
+%%DATADIR%%/mozilla-viewer.ui
+%%DATADIR%%/playlist-ui.xml
+%%DATADIR%%/playlist.ui
+%%DATADIR%%/plugins.ui
+%%DATADIR%%/properties.ui
+%%DATADIR%%/totem-ui.xml
+%%DATADIR%%/totem.ui
+%%DATADIR%%/totem_logo.png
+%%DATADIR%%/uri.ui
+share/vala/vapi/totem.deps
+share/vala/vapi/totem.vala
+@dirrm %%DATADIR%%
+@dirrm share/omf/totem
@dirrm share/gnome/help/totem/uk/figures
@dirrm share/gnome/help/totem/uk
@dirrm share/gnome/help/totem/sv/figures
@@ -218,17 +280,33 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrm share/gnome/help/totem/pt_BR
@dirrm share/gnome/help/totem/pa/figures
@dirrm share/gnome/help/totem/pa
+@dirrm share/gnome/help/totem/oc/figures
+@dirrm share/gnome/help/totem/oc
@dirrm share/gnome/help/totem/fr/figures
@dirrm share/gnome/help/totem/fr
@dirrm share/gnome/help/totem/es/figures
@dirrm share/gnome/help/totem/es
+@dirrm share/gnome/help/totem/en_GB/figures
+@dirrm share/gnome/help/totem/en_GB
@dirrm share/gnome/help/totem/de/figures
@dirrm share/gnome/help/totem/de
+@dirrm share/gnome/help/totem/ca/figures
+@dirrm share/gnome/help/totem/ca
@dirrm share/gnome/help/totem/bg/figures
@dirrm share/gnome/help/totem/bg
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem
+@dirrm lib/totem/plugins/skipto
+@dirrm lib/totem/plugins/screensaver
+@dirrm lib/totem/plugins/properties
+@dirrm lib/totem/plugins/ontop
+@dirrm lib/totem/plugins/media-player-keys
+%%LIRC%%@dirrm lib/totem/plugins/lirc
+@dirrm lib/totem/plugins/gromit
+%%GALAGO%%@dirrm lib/totem/plugins/galago
+@dirrm lib/totem/plugins
+@dirrm lib/totem
@dirrmtry lib/browser_plugins
@dirrm include/totem/1/plparser
@dirrm include/totem/1
@@ -245,6 +323,8 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrmtry share/locale/te
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@@ -257,3 +337,4 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/applications