aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tunapie/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/tunapie/Makefile')
-rw-r--r--multimedia/tunapie/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index 2f1e1e3e912f..bf35c7637d55 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tunapie
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.3.3
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,8 +15,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= Tuner for streaming internet radio and TV
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
- streamripper:${PORTSDIR}/audio/streamripper \
- xmms:${PORTSDIR}/multimedia/xmms
+ streamripper:${PORTSDIR}/audio/streamripper
NO_BUILD= yes
USE_PYTHON= yes
@@ -24,7 +23,9 @@ USE_WX= 2.6
WX_COMPS= python:run
OPTIONS= ADULT "non-censored TV listings" off \
- XINE "use xine instead of mplayer" off
+ XINE "use xine instead of mplayer as default" off \
+ AUDACIOUS "use audacious instead of xmms as default" off \
+ BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms as default" off
MAN1= tunapie.1
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
@@ -34,12 +35,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME:C/-rc4-3$/_rc4/}
FIND_FILES= -type f -and \( -name "install.sh" -or -name "*.py" \)
post-patch:
- cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} \
+ @cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} \
-e 's|%%DATADIR%%|${DATADIR}|g'\
-e 's|%%DESKTOPDIR%%|${DESKTOPDIR}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%MANPREFIX%%|${MANPREFIX}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%AUDIOPLAYER%%|${AUDIOPLAYER}|g' \
-e 's|%%VIDEOPLAYER%%|${VIDEOPLAYER}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' {} ";"
@@ -54,6 +56,7 @@ do-install:
ADULT_TVLIST= --adult
.endif
+# default VIDEOPLAYER
.if defined(WITH_XINE)
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
VIDEOPLAYER= ${X11BASE}/bin/xine
@@ -62,4 +65,16 @@ RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
VIDEOPLAYER= ${LOCALBASE}/bin/mplayer
.endif
+# default AUDIOPLAYER
+.if defined(WITH_AUDACIOUS)
+RUN_DEPENDS+= audacious:${PORTSDIR}/multimedia/audacious
+AUDIOPLAYER= ${LOCALBASE}/bin/audacious
+.elifdef(WITH_BEEP_MEDIA_PLAYER)
+RUN_DEPENDS+= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
+AUDIOPLAYER= ${LOCALBASE}/bin/beep-media-player
+.else
+RUN_DEPENDS+= xmms:${PORTSDIR}/multimedia/xmms
+AUDIOPLAYER= ${X11BASE}/bin/xmms
+.endif
+
.include <bsd.port.post.mk>