aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vic
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vic')
-rw-r--r--multimedia/vic/Makefile44
-rw-r--r--multimedia/vic/distinfo3
-rw-r--r--multimedia/vic/files/patch-Makefile.in64
-rw-r--r--multimedia/vic/files/patch-Tcl.cpp19
-rw-r--r--multimedia/vic/files/patch-config25
-rw-r--r--multimedia/vic/files/patch-configure.in33
-rw-r--r--multimedia/vic/files/patch-configure.in.tail15
-rw-r--r--multimedia/vic/files/patch-configure.in.tk56
-rw-r--r--multimedia/vic/files/patch-const101
-rw-r--r--multimedia/vic/files/patch-defs16
-rw-r--r--multimedia/vic/files/patch-histtolut.cpp73
-rw-r--r--multimedia/vic/files/patch-inet6.h34
-rw-r--r--multimedia/vic/files/patch-main53
-rw-r--r--multimedia/vic/files/patch-mbus_handler9
-rw-r--r--multimedia/vic/files/patch-md521
-rw-r--r--multimedia/vic/files/patch-net-ipv6.cpp10
-rw-r--r--multimedia/vic/files/patch-nomalloc_h8
-rw-r--r--multimedia/vic/files/patch-renderer-window14
-rw-r--r--multimedia/vic/files/patch-ui-ctrlmenu.tcl25
-rw-r--r--multimedia/vic/files/patch-ui-resource.tcl11
-rw-r--r--multimedia/vic/files/patch-video-grabber-video4linux.cpp60
-rw-r--r--multimedia/vic/files/patch-warns9
-rw-r--r--multimedia/vic/pkg-descr4
-rw-r--r--multimedia/vic/pkg-plist2
24 files changed, 0 insertions, 709 deletions
diff --git a/multimedia/vic/Makefile b/multimedia/vic/Makefile
deleted file mode 100644
index d4573de7ed94..000000000000
--- a/multimedia/vic/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: vic
-# Date created: 14 December 1994
-# Whom: wollman
-#
-# $FreeBSD$
-#
-
-PORTNAME= vic
-PORTVERSION= 2.8.1.1.6
-PORTREVISION= 2
-CATEGORIES= mbone tk ipv6
-MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/vic/2.8ucl1.1.6/
-DISTNAME= ${PORTNAME}-2.8ucl1.1.6
-
-MAINTAINER= mi@aldan.algebra.com
-COMMENT= MBONE video tool
-
-BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= uclmmbase:${PORTSDIR}/devel/uclmmbase
-
-USE_TK= 84
-USE_TK_BUILD= 84
-
-USE_AUTOTOOLS= autoconf:213
-USE_XORG= xext
-CONFIGURE_ARGS= -x-libraries=${LOCALBASE}/lib \
- -x-includes=${LOCALBASE}/include \
- -without-ucltcl \
- -with-tcl=${LOCALBASE} \
- -without-ucltk \
- -with-tk=${LOCALBASE}
-.ifndef (NO_INET6)
-CONFIGURE_ARGS+=-enable-ipv6
-.endif
-MAN1= vic.1
-
-post-patch:
- ${RM} ${WRKSRC}/md5*
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/vic
- ${STRIP_CMD} ${PREFIX}/bin/histtolut
-
-.include <bsd.port.mk>
diff --git a/multimedia/vic/distinfo b/multimedia/vic/distinfo
deleted file mode 100644
index 50562e1c912d..000000000000
--- a/multimedia/vic/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (vic-2.8ucl1.1.6.tar.gz) = f2330ad98655ad43d489a023847645c0
-SHA256 (vic-2.8ucl1.1.6.tar.gz) = 8cb8293c56757e4e1b87dcfdc17988be30a05cbfaae13173d309ae4a98cdb60b
-SIZE (vic-2.8ucl1.1.6.tar.gz) = 1119176
diff --git a/multimedia/vic/files/patch-Makefile.in b/multimedia/vic/files/patch-Makefile.in
deleted file mode 100644
index a1dd00423658..000000000000
--- a/multimedia/vic/files/patch-Makefile.in
+++ /dev/null
@@ -1,64 +0,0 @@
---- Makefile.in.orig Wed Apr 30 13:50:17 2003
-+++ Makefile.in Fri Feb 9 16:08:03 2007
-@@ -58,7 +58,7 @@
- INCLUDE_TK = @V_INCLUDE_TK@
- INCLUDE_TCL = @V_INCLUDE_TCL@
- INCLUDE_X11 = @V_INCLUDE_X11@
--INCLUDE_MISC = @V_INCLUDE@ -I. -Icodec/tmndec -Icodec/tmn-x -Icodec/h263 -Irtp -Irender -Inet -Ivideo -Icodec -I../common/src
-+INCLUDE_MISC = @V_INCLUDE@ -I. -Icodec/tmndec -Icodec/tmn-x -Icodec/h263 -Irtp -Irender -Inet -Ivideo -Icodec -I${LOCALBASE}/include/uclmmbase -I${LOCALBASE}/include
-
- STATIC = @V_STATIC@
- MKDEP = ./mkdep
-@@ -89,12 +89,12 @@
- OBJ_XIL = @V_OBJ_XIL@
- OBJ_CRYPT = @V_OBJ_CRYPT@
- LIB = $(LIB_GRABBER) @V_LIB_TK@ @V_LIB_TCL@ @V_LIB_X11@ @V_LIB@ \
-- codec/tmndec/libh263.a codec/tmn-x/libh263coder.a ../common/src/libuclmmbase.a -lm
-+ codec/tmndec/libh263.a codec/tmn-x/libh263coder.a -L${LOCALBASE}/lib -luclmmbase -lm
- INCLUDE = $(INCLUDE_MISC) $(INCLUDE_GRABBER) $(INCLUDE_TK) $(INCLUDE_TCL) \
- $(INCLUDE_X11) $(MD_INC) -Icodec/jpeg -Icodec/p64 -I.
- DEFINE = @V_DEFINE@ -DED_YBITS=$(ED_YBITS) -DSIGRET=@V_SIGRET@ -DNLAYER=8
- BFLAGS = $(DEFINE) $(INCLUDE)
--CFLAGS = $(CCOPT) $(BFLAGS)
-+CFLAGS += $(BFLAGS)
-
- #
- # Remember to add a dependency if you add any tcl sources here.
-@@ -122,7 +122,7 @@
- codec/h263/idctenc.o codec/h263/sac.o
-
- # .c objects
--OBJ1 = net/inet.o net/inet6.o codec/cellb_tables.o tkStripchart.o md5c.o random.o \
-+OBJ1 = net/inet.o net/inet6.o codec/cellb_tables.o tkStripchart.o \
- $(H263_OBJS)
- # session-rtpv1.o session-nv.o session-ivs.o # Not supported anymore
- # .cpp objects
-@@ -329,15 +329,9 @@
- $(CC) -o $@ $(CFLAGS) render/ppmtolut/ppmtolut.c -lm $(STATIC)
-
- install: force
-- cp vic @prefix@/bin/vic
-- chown bin @prefix@/bin/vic
-- chgrp bin @prefix@/bin/vic
-- chmod 555 @prefix@/bin/vic
-- cp vic.1 @prefix@/man/vic.1
-- cp histtolut @prefix@/bin/histtolut
-- chown bin @prefix@/bin/histtolut
-- chgrp bin @prefix@/bin/histtolut
-- chmod 555 @prefix@/bin/histtolut
-+ ${BSD_INSTALL_PROGRAM} vic @prefix@/bin/vic
-+ ${BSD_INSTALL_MAN} vic.1 @prefix@/man/man1/vic.1
-+ ${BSD_INSTALL_PROGRAM} histtolut @prefix@/bin/histtolut
-
- clean:
- rm -f *.o codec/jpeg/*.o codec/p64/*.o codec/h263/*.o \
-@@ -410,7 +404,7 @@
-
-
- codec/tmn-x/libh263coder.a:
-- (cd codec/tmn-x; $(MAKE) CC=$(CC) CCOPT="$(CCOPT)" )
-+ (cd codec/tmn-x; $(MAKE) CC=$(CC) CCOPT="$(CFLAGS)" )
-
- codec/tmndec/libh263.a:
-- (cd codec/tmndec; $(MAKE) CC=$(CC) CCOPT="$(CCOPT)" -f Makefile.lib)
-+ (cd codec/tmndec; $(MAKE) CC=$(CC) CCOPT="$(CFLAGS)" -f Makefile.lib)
diff --git a/multimedia/vic/files/patch-Tcl.cpp b/multimedia/vic/files/patch-Tcl.cpp
deleted file mode 100644
index cf26626a5499..000000000000
--- a/multimedia/vic/files/patch-Tcl.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- Tcl.cpp Thu Sep 9 08:21:53 1999
-+++ Tcl.cpp Thu Sep 23 18:59:59 2004
-@@ -66,6 +66,7 @@
- {
- instance_.tcl_ = tcl;
- instance_.application_ = application;
-+ Tcl_Init(tcl);
- }
-
- void Tcl::evalc(const char* s)
-@@ -214,7 +215,7 @@
- }
- }
-
--int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, char** av)
-+int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, const char** av)
- {
- TclObject* tc = (TclObject*)cd;
- return (tc->command(ac, (const char*const*)av));
diff --git a/multimedia/vic/files/patch-config b/multimedia/vic/files/patch-config
deleted file mode 100644
index dd572f7a85c8..000000000000
--- a/multimedia/vic/files/patch-config
+++ /dev/null
@@ -1,25 +0,0 @@
---- config.h Thu Apr 10 13:57:28 2003
-+++ config.h Thu Sep 23 18:37:11 2004
-@@ -38,11 +38,6 @@
-
- #if defined(sgi) || defined(__bsdi__) || defined(__FreeBSD__)
- #include <sys/types.h>
--#ifndef uint16_t
--typedef unsigned char uint8_t;
--typedef unsigned short uint16_t;
--typedef unsigned int uint32_t;
--#endif
- #elif defined(sun)
-
- #include <sys/types.h>
-@@ -91,10 +86,6 @@
- #include "debug.h"
- #include <stdlib.h>
- #include <time.h> /* For clock_t */
--
--#ifdef HAVE_MALLOC_H
--#include <malloc.h>
--#endif /* HAVE_MALLOC_H */
-
- #if defined(NEED_SUNOS_PROTOS)
- #if defined(__cplusplus)
diff --git a/multimedia/vic/files/patch-configure.in b/multimedia/vic/files/patch-configure.in
deleted file mode 100644
index aac7387cf554..000000000000
--- a/multimedia/vic/files/patch-configure.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- configure.in.orig Thu Jul 10 16:55:43 2003
-+++ configure.in Mon Feb 12 17:58:29 2007
-@@ -69,18 +69,11 @@
- if test -r /usr/include/machine/ioctl_meteor.h ; then
- V_OBJ_GRABBER="video/grabber-meteor.o $V_OBJ_GRABBER"
- fi
--if test -r /usr/include/linux/videodev.h ; then
-- if grep V4L2 /usr/include/linux/videodev.h >/dev/null 2>&1 ; then
-- V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-v4l2.o"
-- else
-- V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-video4linux.o"
-- fi
--fi
--#if test -r /usr/local/lib/libspigot.a -a ${PORTOBJFORMAT} != elf; then
--if test -r /usr/local/lib/libspigot.a ; then
-- V_OBJ_GRABBER="video/grabber-spigot.o $V_OBJ_GRABBER"
-- V_LIB_GRABBER="$V_LIB_GRABBER -lspigot"
-+if test -r /usr/local/include/linux/videodev.h ; then
- V_INCLUDE_GRABBER="$V_INCLUDE_GRABBER -I/usr/local/include"
-+ V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-video4linux.o"
-+ # no V4L2 support yet.
-+ # V_OBJ_GRABBER="$V_OBJ_GRABBER video/grabber-v4l2.o"
- fi
- if test "$qcamdir" != "" ; then
- V_OBJ_GRABBER="video/grabber-qcam.o $V_OBJ_GRABBER"
-@@ -254,6 +247,7 @@
- else
- V_DEFINE="$V_DEFINE -DFreeBSD"
- fi
-+ V_DEFINE="$V_DEFINE -DSIGARGS=int"
- OPSYS=freebsd
- ;;
- *-*-hpux*)
diff --git a/multimedia/vic/files/patch-configure.in.tail b/multimedia/vic/files/patch-configure.in.tail
deleted file mode 100644
index 44ab63487ae9..000000000000
--- a/multimedia/vic/files/patch-configure.in.tail
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.in.tail.orig Fri Jan 31 09:09:33 2003
-+++ configure.in.tail Fri Jan 31 09:09:47 2003
-@@ -35,9 +35,9 @@
-
- AC_SUBST(V_STATIC)
-
--if test "$host_cpu" = alpha ; then
-- V_DEFINE="$V_DEFINE -DINT_64=u_long"
--fi
-+#if test "$host_cpu" = alpha ; then
-+# V_DEFINE="$V_DEFINE -DINT_64=u_long"
-+#fi
-
- # various include hacks
- dirs="/usr/src/local/include-fixes \
diff --git a/multimedia/vic/files/patch-configure.in.tk b/multimedia/vic/files/patch-configure.in.tk
deleted file mode 100644
index d4fdc8a8a3da..000000000000
--- a/multimedia/vic/files/patch-configure.in.tk
+++ /dev/null
@@ -1,56 +0,0 @@
---- configure.in.tk.org Tue May 8 08:42:54 2001
-+++ configure.in.tk Tue May 8 08:56:43 2001
-@@ -32,13 +32,13 @@
- echo "'$d' is not a directory"
- exit 1
- fi
-- V_INCLUDE_TCL=-I$d/include
-- if test ! -r $d/include/tcl.h ; then
-+ V_INCLUDE_TCL=-I$d/include/tcl8.4/
-+ if test ! -r $d/include/tcl8.4/tcl.h ; then
- echo "can't find tcl.h in $d/include"
- exit 1
- fi
-- places="$d/lib/libtcl8.0.so \
-- $d/lib/libtcl8.0.a \
-+ places="$d/lib/libtcl84.so \
-+ $d/lib/libtcl84.a \
- $d/lib/libtcl.so \
- $d/lib/libtcl.a"
- V_LIB_TCL=FAIL
-@@ -52,7 +52,7 @@
- echo "can't find libtcl.a in $d/lib"
- exit 1
- fi
-- places="$d/lib/tcl-8.0 \
-+ places="$d/lib/tcl8.4 \
- $d/lib/tcl8.0 \
- $d/lib/tcl"
- V_LIBRARY_TCL=FAIL
-@@ -190,13 +190,13 @@
- echo "'$d' is not a directory"
- exit 1
- fi
-- V_INCLUDE_TK=-I$d/include
-- if test ! -r $d/include/tk.h ; then
-+ V_INCLUDE_TK=-I$d/include/tk8.4
-+ if test ! -r $d/include/tk8.4/tk.h ; then
- echo "can't find tk.h in $d/include"
- exit 1
- fi
-- places="$d/lib/libtk8.0.so \
-- $d/lib/libtk8.0.a \
-+ places="$d/lib/libtk84.so \
-+ $d/lib/libtk84.a \
- $d/lib/libtk.so \
- $d/lib/libtk.a"
- V_LIB_TK=FAIL
-@@ -210,7 +210,7 @@
- echo "can't find libtk.a in $d/lib"
- exit 1
- fi
-- places="$d/lib/tk8.0 \
-+ places="$d/lib/tk8.4 \
- $d/lib/tk"
- V_LIBRARY_TK=FAIL
- for dir in $places; do
diff --git a/multimedia/vic/files/patch-const b/multimedia/vic/files/patch-const
deleted file mode 100644
index de01fd3898ca..000000000000
--- a/multimedia/vic/files/patch-const
+++ /dev/null
@@ -1,101 +0,0 @@
---- tkStripchart.c.orig Mon Jun 29 15:17:00 1998
-+++ tkStripchart.c Tue Mar 22 13:02:03 2005
-@@ -329,7 +329,7 @@
- */
- static void Callback(Stripchart* StripchartPtr);
--static void ComputeStripchartGeometry(Stripchart* StripchartPtr);
-+static void ComputeStripchartGeometry(const Stripchart* StripchartPtr);
- static int ConfigureStripchart(Tcl_Interp* interp, Stripchart* StripchartPtr,
-- int argc, char** argv, int flags);
-+ int argc, const char** argv, int flags);
- static void DestroyStripchart(char* clientData);
- static void DisplayStripchart(ClientData clientData);
-@@ -337,9 +337,9 @@
- static void EventuallyRedrawStripchart(Stripchart* StripchartPtr,
- int displaybits);
--static void ReplaceColours(Stripchart* StripchartPtr, int argc, char** argv);
-+static void ReplaceColours(Stripchart* StripchartPtr, int argc, const char** argv);
- static void ScrollStrips(Stripchart* StripchartPtr);
- static void StripchartEventProc(ClientData clientData, XEvent* eventPtr);
- static int StripchartWidgetCmd(ClientData clientData, Tcl_Interp* interp,
-- int argc, char** argv);
-+ int argc, const char** argv);
- static void SetStripchartValue(Stripchart* StripchartPtr, double value);
- static void SwapColours(Stripchart* StripchartPtr);
-@@ -364,5 +364,5 @@
- int
- Tk_StripchartCmd(ClientData clientData, Tcl_Interp *interp, int argc,
-- char **argv)
-+ const char **argv)
- {
- Tk_Window tkwin = (Tk_Window) clientData;
-@@ -419,5 +419,5 @@
- static int
- StripchartWidgetCmd(ClientData clientData, Tcl_Interp *interp,
-- int argc, char **argv)
-+ int argc, const char **argv)
- {
- register Stripchart *StripchartPtr = (Stripchart*)clientData;
-@@ -629,5 +629,5 @@
- static int
- ConfigureStripchart(Tcl_Interp *interp, Stripchart *StripchartPtr,
-- int argc, char** argv, int flags)
-+ int argc, const char** argv, int flags)
- {
- XGCValues gcValues;
-@@ -699,5 +699,5 @@
- */
- static void
--ComputeStripchartGeometry(Stripchart* StripchartPtr)
-+ComputeStripchartGeometry(const Stripchart* StripchartPtr)
- {
- int tt = hasatitle(StripchartPtr);
-@@ -1040,5 +1040,5 @@
- */
- static void
--ReplaceColours(Stripchart* StripchartPtr, int argc, char** argv)
-+ReplaceColours(Stripchart* StripchartPtr, int argc, const char** argv)
- {
- StripchartPtr->altborder =
---- vic_tcl.h Thu Sep 9 08:05:49 1999
-+++ vic_tcl.h Thu Sep 23 19:00:33 2004
-@@ -74,6 +77,6 @@
- error(file);
- }
-- inline char* var(const char* varname, int flags = TCL_GLOBAL_ONLY) {
-- return (Tcl_GetVar(tcl_, (char*)varname, flags));
-+ inline CONST char* var(const char* varname, int flags = TCL_GLOBAL_ONLY) {
-+ return (Tcl_GetVar(tcl_, varname, flags));
- }
- /*
-@@ -125,5 +128,5 @@
- void class_name(const char*);
- /* make this public for Sun's compiler */
-- static int callback(ClientData, Tcl_Interp*, int ac, char** av);
-+ static int callback(ClientData, Tcl_Interp*, int ac, CONST char** av);
- static void reset_all();
- protected:
---- rate-variable.cpp Thu Sep 9 08:21:55 1999
-+++ rate-variable.cpp Thu Sep 23 18:55:10 2004
-@@ -62,11 +62,11 @@
- RateVariable(const char* name) : TclObject(name) { }
- protected:
-- static char* update_rate_var(ClientData, Tcl_Interp*, char* name1,
-- char* name2, int flags);
-+ static char* update_rate_var(ClientData, Tcl_Interp*, const char* name1,
-+ const char* name2, int flags);
- int command(int argc, const char*const* argv);
- } rate_variable_cmd("rate_variable");
-
- char* RateVariable::update_rate_var(ClientData clientData, Tcl_Interp* tcl,
-- char* name1, char* name2, int flags)
-+ const char* name1, const char* name2, int flags)
- {
- rv_data* rv = (rv_data*)clientData;
-@@ -81,5 +81,5 @@
- char res[128];
- flags &= TCL_GLOBAL_ONLY;
-- char* cv = Tcl_GetVar2(tcl, name1, name2, flags);
-+ const char* cv = Tcl_GetVar2(tcl, name1, name2, flags);
- if (cv == NULL)
- return (tcl->result);
diff --git a/multimedia/vic/files/patch-defs b/multimedia/vic/files/patch-defs
deleted file mode 100644
index 2215cae8a4f1..000000000000
--- a/multimedia/vic/files/patch-defs
+++ /dev/null
@@ -1,16 +0,0 @@
---- codec/h263/Motion.h Thu Sep 9 08:45:55 1999
-+++ codec/h263/Motion.h Tue Mar 22 14:04:18 2005
-@@ -42,4 +42,5 @@
- } MVector;
- /***********************************************************CommentEnd********/
-+MVector *AllocMVector(void);
-
- #endif /* _MOTION_STRUCTS_H_ */
---- codec/h263/code.h Thu Sep 9 08:45:58 1999
-+++ codec/h263/code.h Tue Mar 22 14:06:24 2005
-@@ -167,4 +167,4 @@
- /***********************************************************CommentEnd********/
-
--
-+Code *InitCode(char *title, int size, int eventDim, int *event, char *cw[]);
- #endif /* _CODE_H */
diff --git a/multimedia/vic/files/patch-histtolut.cpp b/multimedia/vic/files/patch-histtolut.cpp
deleted file mode 100644
index c47168d31e64..000000000000
--- a/multimedia/vic/files/patch-histtolut.cpp
+++ /dev/null
@@ -1,73 +0,0 @@
---- render/histtolut/histtolut.cpp.orig Thu Jan 23 18:13:08 2003
-+++ render/histtolut/histtolut.cpp Thu Jan 23 18:15:11 2003
-@@ -62,6 +62,7 @@
- #endif
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <cstring>
-
- #ifdef WIN32
- extern "C" {
-@@ -142,7 +143,7 @@
- * For further details see "Introduction to Algorithms" by Carmen,
- * Lieserson and Rivest.
- */
--//extern void *memset(void *, int, size_t);
-+//extern void *std::memset(void *, int, size_t);
-
- /* XXX should pass backup array in as argument, that way can create it
- only once. */
-@@ -154,7 +155,7 @@
- \
- register histItem** hist = &h[idx]; \
- int j; \
-- memset((void *)aux, 0, 256 * sizeof(int)); \
-+ std::memset((void *)aux, 0, 256 * sizeof(int)); \
- for (j = 0; j < n; j++) \
- aux[hist[j]->c.fld]++; \
- \
-@@ -199,7 +200,7 @@
- box* bv = new box[sizeof(box) * newcolors];
-
- register u_char* colormap = cmap;
-- memset(colormap, 0, 3 * newcolors);
-+ std::memset(colormap, 0, 3 * newcolors);
-
- /* Set up the initial box. */
- bv[0].ind = 0;
-@@ -450,7 +451,7 @@
- box* bv = new box[sizeof(box) * newcolors];
-
- register u_char* colormap = cmap;
-- memset(colormap, 0, 3 * newcolors);
-+ std::memset(colormap, 0, 3 * newcolors);
-
- /* Set up the initial box. */
- bv[0].ind = 0;
-@@ -639,7 +640,7 @@
- abort();
-
- int ncol[MAX_YLEVELS];
-- memset(ncol, 0, sizeof(ncol));
-+ std::memset(ncol, 0, sizeof(ncol));
- /*
- * We do this in two passes so that the size of the table can be
- * calculated. Otherwise it would be have to be too big:
-@@ -657,7 +658,7 @@
- table[i] = new histItem[ncol[i]];
-
- i = 0;
-- memset(ncol, 0, sizeof(ncol));
-+ std::memset(ncol, 0, sizeof(ncol));
- for (v = 0; v < 1 << 5; ++v) {
- for (int u = 0; u < 1 << 5; ++u) {
- for (int y = 0; y < 1 << 4; ++y) {
-@@ -688,7 +689,7 @@
- }
-
- histItem** histogram[MAX_YLEVELS];
-- memset(histogram, 0, sizeof(histogram));
-+ std::memset(histogram, 0, sizeof(histogram));
- int totcol = 0;
- for (i = 0; i < ny; ++i) {
- if (ncol[i] != 0) {
diff --git a/multimedia/vic/files/patch-inet6.h b/multimedia/vic/files/patch-inet6.h
deleted file mode 100644
index ed330bfa8b04..000000000000
--- a/multimedia/vic/files/patch-inet6.h
+++ /dev/null
@@ -1,34 +0,0 @@
---- net/inet6.h.org Mon Feb 4 17:51:39 2002
-+++ net/inet6.h Mon Feb 4 17:52:02 2002
-@@ -44,7 +44,6 @@
- #define vic_inet6_h
-
- #ifdef HAVE_IPV6
--
- #include <sys/types.h>
- #ifdef WIN32
- //#include <winsock.h>
-@@ -62,10 +61,23 @@
- }
- #else
- #include <netinet/in.h>
-+#include <netinet6/in6.h>
- #endif
- #endif
- #ifndef WIN32
- #include <arpa/inet.h>
-+#ifdef _NETINET6_IN6_H_
-+#ifndef IPV6_ADD_MEMBERSHIP
-+#ifdef IPV6_JOIN_GROUP
-+#define IPV6_ADD_MEMBERSHIP IPV6_JOIN_GROUP
-+#endif /* IPV6_JOIN_GROUP */
-+#endif /* IPV6_ADD_MEMBERSHIP */
-+#ifndef IPV6_DROP_MEMBERSHIP
-+#ifdef IPV6_LEAVE_GROUP
-+#define IPV6_DROP_MEMBERSHIP IPV6_LEAVE_GROUP
-+#endif /* IPV6_LEAVE_GROUP */
-+#endif /* IPV6_DROP_MEMBERSHIP */
-+#endif /* _NETINET6_IN6_H_ */
- #endif
-
- #include "config.h"
diff --git a/multimedia/vic/files/patch-main b/multimedia/vic/files/patch-main
deleted file mode 100644
index 7a217d731fd3..000000000000
--- a/multimedia/vic/files/patch-main
+++ /dev/null
@@ -1,53 +0,0 @@
---- main.cpp Tue Feb 25 12:55:08 2003
-+++ main.cpp Tue Mar 22 12:37:51 2005
-@@ -363,36 +363,4 @@
- #endif
-
--/*
-- * From the RTP spec.
-- */
--u_int32_t
--heuristic_random()
--{
-- struct {
-- struct timeval tv;
-- clock_t cpu;
-- pid_t pid;
-- u_long hid;
-- uid_t uid;
-- gid_t gid;
-- struct utsname name;
-- } s;
--
-- gettimeofday(&s.tv, 0);
-- uname(&s.name);
-- s.cpu = clock();
-- s.pid = getpid();
-- s.hid = gethostid();
-- s.uid = getuid();
-- s.gid = getgid();
--
-- MD5_CTX context;
-- MD5Init(&context);
-- MD5Update(&context, (u_char*)&s, sizeof(s));
-- u_int32_t out[4];
-- MD5Final((u_char *)out, &context);
-- return (out[0] ^ out[1] ^ out[2] ^ out[3]);
--}
--
- void loadbitmaps(Tcl_Interp* tcl)
- {
-@@ -407,5 +375,5 @@
- }
-
--extern "C" int Tk_StripchartCmd(ClientData, Tcl_Interp*, int ac, char** av);
-+extern "C" int Tk_StripchartCmd(ClientData, Tcl_Interp*, int ac, const char** av);
- #ifdef WIN32
- extern "C" int WinPutsCmd(ClientData, Tcl_Interp*, int ac, char** av);
-@@ -433,5 +401,5 @@
- main(int argc, const char** argv)
- {
-- srandom(heuristic_random());
-+ srandomdev();
-
- #ifdef SIGHUP
diff --git a/multimedia/vic/files/patch-mbus_handler b/multimedia/vic/files/patch-mbus_handler
deleted file mode 100644
index 8237fee3b279..000000000000
--- a/multimedia/vic/files/patch-mbus_handler
+++ /dev/null
@@ -1,9 +0,0 @@
---- net/mbus_handler.h Thu Mar 16 08:21:37 2000
-+++ net/mbus_handler.h Thu Sep 23 21:31:33 2004
-@@ -50,6 +50,4 @@
- #include "memory.h"
- #include "mbus.h"
--#include "mbus_config.h"
--
-
- #ifdef WIN32
diff --git a/multimedia/vic/files/patch-md5 b/multimedia/vic/files/patch-md5
deleted file mode 100644
index ba52895aa139..000000000000
--- a/multimedia/vic/files/patch-md5
+++ /dev/null
@@ -1,21 +0,0 @@
---- net/crypt.cpp Thu Sep 9 08:48:51 1999
-+++ net/crypt.cpp Tue Mar 22 13:08:25 2005
-@@ -42,5 +42,5 @@
- #define PROTOTYPES 1
- #include "global.h"
--#include "md5.h"
-+#include <openssl/md5.h>
-
- Crypt::Crypt() : badpktlen_(0), badpbit_(0)
-@@ -70,8 +70,8 @@
- {
- MD5_CTX context;
-- MD5Init(&context);
-- MD5Update(&context, (u_char*)key, strlen(key));
-+ MD5_Init(&context);
-+ MD5_Update(&context, (u_char*)key, strlen(key));
- u_char hash[16];
-- MD5Final((u_char *)hash, &context);
-+ MD5_Final((u_char *)hash, &context);
- return (install_key(hash));
- }
diff --git a/multimedia/vic/files/patch-net-ipv6.cpp b/multimedia/vic/files/patch-net-ipv6.cpp
deleted file mode 100644
index 4e8812eff9ff..000000000000
--- a/multimedia/vic/files/patch-net-ipv6.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- net/net-ipv6.cpp Thu Apr 24 10:53:26 2003
-+++ net/net-ipv6.cpp Thu Sep 23 19:08:53 2004
-@@ -59,7 +59,6 @@
- #include "config.h"
- #include "net.h"
- #include "vic_tcl.h"
--#include "inet_ntop.h"
-
- #include "inet6.h"
- #include "net-addr.h"
diff --git a/multimedia/vic/files/patch-nomalloc_h b/multimedia/vic/files/patch-nomalloc_h
deleted file mode 100644
index 0d7613d84587..000000000000
--- a/multimedia/vic/files/patch-nomalloc_h
+++ /dev/null
@@ -1,8 +0,0 @@
---- codec/h263/Util.h Thu Sep 9 08:45:56 1999
-+++ codec/h263/Util.h Thu Sep 23 18:31:34 2004
-@@ -7,5 +7,4 @@
- #define _UTIL_
-
--#include <malloc.h>
- #include "error.h"
- #include <stdlib.h>
diff --git a/multimedia/vic/files/patch-renderer-window b/multimedia/vic/files/patch-renderer-window
deleted file mode 100644
index 8e940d34f0b4..000000000000
--- a/multimedia/vic/files/patch-renderer-window
+++ /dev/null
@@ -1,14 +0,0 @@
---- render/renderer-window.h Thu Sep 9 08:38:16 1999
-+++ render/renderer-window.h Thu Sep 23 21:43:13 2004
-@@ -54,10 +54,10 @@
- int minx, int maxx) const;
- void sync() const;
- void resize(int w, int h);
-- protected:
- /*XXX*/
- void dither_null(const u_char* frm, u_int off, u_int x,
- u_int width, u_int height) const;
-+ protected:
- virtual void setcolor(int c);
- void compute_scale(int w, int h);
- virtual void alloc_image() = 0;
diff --git a/multimedia/vic/files/patch-ui-ctrlmenu.tcl b/multimedia/vic/files/patch-ui-ctrlmenu.tcl
deleted file mode 100644
index d8a3514fe595..000000000000
--- a/multimedia/vic/files/patch-ui-ctrlmenu.tcl
+++ /dev/null
@@ -1,25 +0,0 @@
---- tcl/ui-ctrlmenu.tcl.org Thu May 10 08:44:51 2001
-+++ tcl/ui-ctrlmenu.tcl Thu May 10 08:48:19 2001
-@@ -408,16 +408,16 @@
- -relief raised -command transmit \
- -anchor w -variable transmitButtonState -font $f \
- -state disabled -highlightthickness 0
--# checkbutton $w.freeze -text "Freeze" \
--# -relief raised -command "grabber freeze \$freeze" \
--# -anchor w -variable freeze -font $f \
--# -highlightthickness 0
-+ checkbutton $w.freeze -text "Freeze" \
-+ -relief raised -command "grabber freeze \$freeze" \
-+ -anchor w -variable freeze -font $f \
-+ -highlightthickness 0
- button $w.release -text "Release" \
- -relief raised -command release_device \
- -font $f -highlightthickness 0
-
--# pack $w.send $w.release $w.freeze -fill both
-- pack $w.send $w.release -fill both
-+ pack $w.send $w.release $w.freeze -fill both
-+# pack $w.send $w.release -fill both
- }
-
- proc doNothing { args } {
diff --git a/multimedia/vic/files/patch-ui-resource.tcl b/multimedia/vic/files/patch-ui-resource.tcl
deleted file mode 100644
index b1134d6f5e76..000000000000
--- a/multimedia/vic/files/patch-ui-resource.tcl
+++ /dev/null
@@ -1,11 +0,0 @@
---- tcl/ui-resource.tcl.org Mon May 7 16:17:03 2001
-+++ tcl/ui-resource.tcl Mon May 7 16:17:29 2001
-@@ -153,7 +153,7 @@
- option add Vic.infoHighlightColor LightYellow2 startupFile
- option add Vic.useJPEGforH261 false startupFile
- option add Vic.useHardwareComp false startupFile
-- option add Vic.stillGrabber false startupFile
-+ option add Vic.stillGrabber true startupFile ; # XXX was false
- option add Vic.siteDropTime "300" startupFile
- option add Vic.quality "0" startupFile
-
diff --git a/multimedia/vic/files/patch-video-grabber-video4linux.cpp b/multimedia/vic/files/patch-video-grabber-video4linux.cpp
deleted file mode 100644
index 8aa3f98be10e..000000000000
--- a/multimedia/vic/files/patch-video-grabber-video4linux.cpp
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -ubwr video/grabber-video4linux.cpp ../../test/vic-2.8ucl1.1.6/video/grabber-video4linux.cpp
---- video/grabber-video4linux.cpp Fri Sep 12 19:36:19 2003
-+++ ../../test/vic-2.8ucl1.1.6/video/grabber-video4linux.cpp Fri Feb 9 16:15:12 2007
-@@ -36,7 +36,7 @@
-
-
- extern "C" {
--#include <asm/types.h>
-+//#include <asm/types.h>
- #include <linux/videodev.h>
- }
-
-@@ -312,9 +314,20 @@
- }
-
- if( !( have_422P || have_422 || have_420P)) {
-- debug_msg("No suituable palette found\n");
-+ debug_msg("No suituable palette found, try normal\n");
-+ /* this needs to cleaned up heavily */
-+ have_420P = 1; /* assume no mmap and try 420 is default */
-+ struct video_picture vp;
-+ if(ioctl(fd_,VIDIOCGPICT,&vp) == -1) {
-+ debug_msg("Failed to get current picture info");
- exit(1);
- }
-+ vp.palette = VIDEO_PALETTE_YUV420P;
-+ if(ioctl(fd_,VIDIOCSPICT,&vp) == -1) {
-+ debug_msg("Failed to set current picture info");
-+ exit(1);
-+ }
-+ }
-
- /* Release device */
- close(fd_);
-@@ -551,10 +564,15 @@
- Grabber::stop();
- }
-
-+/*
-+ * quick hack - support only a single device of this kind,
-+ * with a static max-sized buffer for reads.
-+ */
-+static char buf1[1024*768*3/2];
-+
- int V4lGrabber::grab()
- {
- char *fr=NULL;
--
- debug_msg((sync_count % 2) ? "o" : "e");
-
- if (have_mmap) {
-@@ -566,6 +584,8 @@
- else
- sync_count++;
- } else {
-+ read(fd_, buf1, (size_t)height_*width_*3/2);
-+ fr = buf1;
- /* FIXME: read() */
- }
-
diff --git a/multimedia/vic/files/patch-warns b/multimedia/vic/files/patch-warns
deleted file mode 100644
index 8db7f714fc0a..000000000000
--- a/multimedia/vic/files/patch-warns
+++ /dev/null
@@ -1,9 +0,0 @@
---- codec/p64/p64.cpp Thu Sep 9 08:46:10 1999
-+++ codec/p64/p64.cpp Mon Mar 26 01:44:44 2007
-@@ -1069,5 +1069,5 @@
- * with 8 bits; otherwise, prime it with a 16.
- */
-- if ((int)bp & 1) {
-+ if ((intptr_t)bp & 1) {
- bs_ = (u_short*)(bp + 1);
- bb_ = *bp;
diff --git a/multimedia/vic/pkg-descr b/multimedia/vic/pkg-descr
deleted file mode 100644
index 720c00f6188e..000000000000
--- a/multimedia/vic/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This package contains the binary release of LBL's `vic' network video
-conferencing tool.
-
-WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/vic/
diff --git a/multimedia/vic/pkg-plist b/multimedia/vic/pkg-plist
deleted file mode 100644
index 3ae0decf49cb..000000000000
--- a/multimedia/vic/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/vic
-bin/histtolut