aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/xine/Makefile')
-rw-r--r--multimedia/xine/Makefile69
1 files changed, 0 insertions, 69 deletions
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
deleted file mode 100644
index a6ecf618933c..000000000000
--- a/multimedia/xine/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-# New ports collection makefile for: xine
-# Date created: 14 Oct 2000
-# Whom: alex
-#
-# $FreeBSD$
-#
-
-PORTNAME= xine
-PORTVERSION= 0.9.9
-CATEGORIES= graphics
-MASTER_SITES= http://xine.sourceforge.net/files/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-ui-${PORTVERSION}
-
-MAINTAINER= nobutaka@FreeBSD.org
-
-LIB_DEPENDS= xine.0:${PORTSDIR}/graphics/libxine \
- aa.1:${PORTSDIR}/graphics/aalib \
- png.5:${PORTSDIR}/graphics/png \
- intl.2:${PORTSDIR}/devel/gettext
-
-USE_X_PREFIX= yes
-USE_IMLIB= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- THREAD_LIBS="${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32
-
-MANLANG= "" de es fr pl
-MAN1= aaxine.1 xine.1 xine-bugreport.1 xine-check.1 xine-remote.1
-
-.include <bsd.port.pre.mk>
-
-.if (${ARCH} == "i386")
-.if !defined(WITHOUT_WIN32_CODECS)
-RUN_DEPENDS= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
-
-CODEC_PORT= ${PORTSDIR}/graphics/win32-codecs
-CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
-.endif
-.endif
-
-post-patch:
- @${PERL} -pi -e \
- 's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
- s|THREAD_CFLAGS=.*$$|THREAD_CFLAGS="\$$THREAD_CFLAGS"|g ; \
- s|-L/usr/local/lib||g ; \
- s|-I/usr/local/include||g' ${WRKSRC}/configure
-
-post-install:
-.for l in es fr
- @${CP} ${PREFIX}/man/man1/aaxine.1 ${PREFIX}/man/${l}/man1/aaxine.1
-.endfor
-.for l in es fr pl
- @${CP} ${PREFIX}/man/man1/xine-bugreport.1 ${PREFIX}/man/${l}/man1/xine-bugreport.1
-.endfor
-.for l in es fr pl
- @${CP} ${PREFIX}/man/man1/xine-check.1 ${PREFIX}/man/${l}/man1/xine-check.1
-.endfor
-.for l in de es fr pl
- @${CP} ${PREFIX}/man/man1/xine-remote.1 ${PREFIX}/man/${l}/man1/xine-remote.1
-.endfor
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>